> ok I'll didn't notice this., do you mind that I cleanup the other
> entries in the same time ?
I already cleaned up some, but go ahead.
--
Eric Botcazou
On 11/06/2013 11:57 AM, Eric Botcazou wrote:
>> thanks, applied together with the cleanup referenced earlier and a
>> slight variable renaming (start_addr->curr_addr, end_addr->start_addr)
>> for readability as obvious,
> Minor nit: no gcc/ prefix in gcc/ChangeLog.
ok I'll didn't notice this., do
> thanks, applied together with the cleanup referenced earlier and a
> slight variable renaming (start_addr->curr_addr, end_addr->start_addr)
> for readability as obvious,
Minor nit: no gcc/ prefix in gcc/ChangeLog.
--
Eric Botcazou
On 11/05/2013 02:12 PM, Kaz Kojima wrote:
> Christian Bruel wrote:
>> No regressions for sh-none-elf. OK for trunk ?
> OK.
>
> Regards,
> kaz
thanks, applied together with the cleanup referenced earlier and a
slight variable renaming (start_addr->curr_addr, end_addr->start_addr)
for readab
Christian Bruel wrote:
> No regressions for sh-none-elf. OK for trunk ?
OK.
Regards,
kaz
Hello,
This patch inlines strlen when optimizing for speed.
A strlen body is now inlined as:
mov r4,r0
tst #3,r0
bf/s.L6
mov r4,r1
mov #0,r3
.L4:
mov.l @r1+,r2
cmp/str r3,r2
bf .L4
add #-4,r1
.