On 11/06/2013 11:57 AM, Eric Botcazou wrote:
>> thanks, applied together with the cleanup referenced earlier and a
>> slight variable renaming (start_addr->curr_addr, end_addr->start_addr)
>> for readability as obvious,
> Minor nit: no gcc/ prefix in gcc/ChangeLog.
ok I'll didn't notice this.,  do you mind that I cleanup the other
entries in the same time ?

        * gcc/config/sh/sh-mem.cc (sh_expand_cmpnstr, sh_expand_cmpstr):
        * gcc/config/sh/sh-protos.h (sh_expand_strlen): Declare.
        * gcc/config/sh/sh.md (strlensi): New pattern.
        * gcc/config/i386/i386.c (memory_address_length): Extract a part
        * gcc/config/i386/i386.h: Add new tune features about macro-fusion.
        * gcc/config/i386/x86-tune.def (DEF_TUNE): Ditto.
        * gcc/doc/tm.texi: Generated.
        * gcc/doc/tm.texi.in: Ditto.
        * gcc/haifa-sched.c (try_group_insn): New Function.
        * gcc/target.def: Add two hooks: macro_fusion_p and
        * gcc/config/i386/i386-c.c (ix86_target_macros_internal): Separate
        * gcc/config/i386/i386.c (ix86_option_override_internal): Ditto.
        * gcc/config/i386/i386.h (enum target_cpu_default): Ditto.
        * gcc/config/i386/x86-tune.def (DEF_TUNE): Ditto.
        * gcc/tree-cfg.c (replace_loop_annotate): Replace warning by
        * gcc/config/sh/sh-mem.cc (sh_expand_cmpnstr): New function.
        * gcc/config/sh/sh-protos.h (sh_expand_cmpstrn): Declare.
        * gcc/config/sh/sh.md (cmpstrnsi): New pattern.
        * gcc/config/arc/arc.c (arc_ccfsm_post_advance): Also handle
        * gcc/config/sh/t-sh (sh-mem.o): New rule.
        * gcc/config/sh/sh-mem.cc (expand_block_move): Moved here.
        * gcc/config/sh/sh.c (force_into, expand_block_move): Move to
sh-mem.c.
        * gcc/config/sh/sh-protos.h (sh_expand_cmpstr): Declare.
        * gcc/config/sh/sh.md (cmpstrsi, cmpstr_t): New patterns.
        * gcc/config/rs6000/vector.md (vec_unpacks_hi_v4sf): Correct for
        * gcc/config/arm/vfp.md (movhf_vfp_neon): Update type attribute.
        * gcc/config/arm/neon.md (neon_mov): Update type attribute.

thanks

Christian


Reply via email to