On Wed, 1 Mar 2017, Martin Sebor wrote:
> On 02/28/2017 11:41 PM, Richard Biener wrote:
> > On March 1, 2017 3:34:46 AM GMT+01:00, Martin Sebor
> > wrote:
> > > On 02/28/2017 01:41 PM, Richard Biener wrote:
> > > > On February 28, 2017 7:00:39 PM GMT+01:00, Jeff Law
> > > wrote:
> > > > > On 02/
This fixes the case where we only late during insertion are able to
simplify an expression (when we re-instantiated range-info on all
SSA names). We can't do anything here but give up since we'd end up
with a SSA name with two values which for sure will eventually end up
confusing elimination.
H
Am 02.03.2017 um 08:32 schrieb Janne Blomqvist:
On Wed, Mar 1, 2017 at 11:00 PM, Thomas Koenig wrote:
Hello world,
the attached patch enables FMA for the AVX2 and AVX512F variants of
matmul. This should bring a very nice speedup (although I have
been unable to run benchmarks due to lack of a
Hi,
the following patch changes "nopr %r7" to "nopr %r0" which is
advantageous from a hardware perspective. It will only be emitted for
hotpatching and should not impact normal code.
Bootstrapped and regression tested on s390 and s390x.
Regards
Robin
gcc/ChangeLog:
2017-03-02 Robin Dapp
On Wed, Mar 1, 2017 at 11:00 PM, Thomas Koenig wrote:
> Hello world,
>
> the attached patch enables FMA for the AVX2 and AVX512F variants of
> matmul. This should bring a very nice speedup (although I have
> been unable to run benchmarks due to lack of a suitable machine).
In lieu of benchmarks,
On Wed, Mar 01, 2017 at 03:10:15PM -1000, Nathan Sidwell wrote:
> On 03/01/2017 09:40 AM, Jakub Jelinek wrote:
>
> > Unfortunately my patch apparently broke the case where such ctor in virtual
> > class has no arguments (void_type_node is used in that case instead of a
> > TREE_LIST, it is a littl
Hi Jerry,
I would prefer that it was tested on the actual expected platform. Does
anyone anywhere on this list have access to one of these machines to test?
If anybody wants to test who does not have --enable-maintainer-mode
activated, here is a patch that works "out of the box".
Regards
On 27 February 2017 at 20:11, François Dumont wrote:
> Hi
>
>
> I had some problems when testing pretty printers while having activated
> concept checks. I noticed that std::deque had already the
> _SGIAssignableConcept check disable when using C++11 so I propose to
> generalize to all usages o
Some of these are years old, most are more recent. The new testcase
should help prevent us trying to use these names again.
PR libstdc++/79789
* include/bits/hashtable_policy.h (__clp2): Use reserved names for
parameters and local variables.
* include/bits/ios_base.
Another case of problems caused by incorrect use of result_of. Because
functions can't have top-level const on parameters result_of is result_of so doesn't give you the answer for the question
you meant to ask.
PR libstdc++/79798
* include/std/functional (bind::_Res_type_impl): Fix
On 03/01/2017 01:00 PM, Thomas Koenig wrote:
Hello world,
the attached patch enables FMA for the AVX2 and AVX512F variants of
matmul. This should bring a very nice speedup (although I have
been unable to run benchmarks due to lack of a suitable machine).
Question: Is this still appropriate for
On Tue, Feb 28, 2017 at 1:56 PM, Jason Merrill wrote:
> This patch implements some proposed resolutions to open issues with
> C++17 class template argument deduction.
And some more:
commit 41e5f38da5699736eb02a5b9c65549799c288714
Author: Jason Merrill
Date: Wed Mar 1 13:15:11 2017 -1000
On 03/01/2017 09:40 AM, Jakub Jelinek wrote:
Unfortunately my patch apparently broke the case where such ctor in virtual
class has no arguments (void_type_node is used in that case instead of a
TREE_LIST, it is a little bit weird (I'd have expected perhaps
void_list_node instead), but it is what
On Wed, 1 Mar 2017, Martin Sebor wrote:
> Joseph, since you commented on the bug, do you have a suggestion
> for a different site for it or a guard? The only other call to
> the function is in the Fortran FE and it's neither guarded nor
> does it appear to ever be called.
I don't think a guard i
So in some cases you use
+ /* For an indeterminate precision the lower bound must be assumed
+ to be zero. */
+ if (prec[0] < 0 && prec[1] >= 0)
Note prec[1] >= 0
In other cases you have:
+/* The minimum output with unknown precision is a single byte
+ (e.g., "0") but the more
The uses of MPFR in gimple-ssa-sprintf.c apparently cause
the library to allocates some internal caches that it then leaks
on program exit, causing Valgrind memory leak errors. The MPFR
manual "strongly advises to [call mpfr_free_cache] before
terminating a thread, or before exiting when using to
This is a proposed patch for the bug 79794 which I just submitted.
This isn't a regression, so this can wait for after the gcc 7 branch
if necessary.
The problem here is that a reg+offset MEM target is passed to
extract_bit_field with a vector register source. On aarch64, we have
an instruction f
On Wed, Mar 01, 2017 at 12:45:41PM -0600, Bill Schmidt wrote:
> The PowerPC documentation doesn't currently identify the default code model.
> This is rather complicated due to all the various subtargets, but it is
> valuable to at least document the common case for 64-bit Linux.
>
> Verified on p
Hello world,
the attached patch enables FMA for the AVX2 and AVX512F variants of
matmul. This should bring a very nice speedup (although I have
been unable to run benchmarks due to lack of a suitable machine).
Question: Is this still appropriate for the current state of trunk?
Or rather, OK for
Hello, gentle maintainer.
This is a message from the Translation Project robot.
A revised PO file for textual domain 'gcc' has been submitted
by the Spanish team of translators. The file is available at:
http://translationproject.org/latest/gcc/es.po
(This file, 'gcc-7.1-b20170226.es.po',
Richard Biener writes:
> On Wed, 1 Mar 2017, Richard Sandiford wrote:
>
>> Richard Biener writes:
>> > On Wed, 1 Mar 2017, Richard Sandiford wrote:
>> >
>> >> Richard Biener writes:
>> >> > On Wed, 1 Mar 2017, Richard Sandiford wrote:
>> >> >
>> >> >> Sorry for the late reply, but:
>> >> >>
>>
Hi!
On Tue, Feb 28, 2017 at 02:47:31PM -1000, Nathan Sidwell wrote:
> On 02/28/2017 02:41 PM, Jason Merrill wrote:
> > On Tue, Feb 28, 2017 at 12:48 PM, Jakub Jelinek wrote:
> > > The DR1659/DR1611 changes result in construct_virtual_base not being
> > > called,
> > > but unfortunately the call
On Wed, Mar 01, 2017 at 03:03:29PM +0100, Richard Biener wrote:
> The patch adds better limiting to that interface and fixes one
> false positive in fixed-value.c. Two other false positives are
> fixed by the wide-int.h patch posted a few hours ago and a patch
> to genemit from Jakub.
Here is tha
On Wed, Mar 1, 2017 at 11:41 AM, Uros Bizjak wrote:
> On Wed, Mar 1, 2017 at 10:00 AM, Uros Bizjak wrote:
>> On Wed, Mar 1, 2017 at 9:48 AM, Jakub Jelinek wrote:
>>> On Wed, Mar 01, 2017 at 09:34:53AM +0100, Uros Bizjak wrote:
Some more thoughts on 64-bit reg on 32-bit targets warning.
The following testcase ICEd with -Wduplicated-branches and -fopenmp
because we tried to has omp_parallel expression that contained some
TREE_VECs, but those aren't handled in inchash::add_expr. Handling
that is easy and fixes the ICE.
Bootstrapped/regtested on x86_64-linux, ok for trunk?
2017-03
Hi,
The PowerPC documentation doesn't currently identify the default code model.
This is rather complicated due to all the various subtargets, but it is
valuable to at least document the common case for 64-bit Linux.
Verified on powerpc64le-unknown-linux-gnu. Ok for trunk?
Thanks,
Bill
2017-0
On Wed, Mar 01, 2017 at 05:21:44AM -0600, Segher Boessenkool wrote:
> On Wed, Mar 01, 2017 at 01:37:14AM -0500, Michael Meissner wrote:
> > This patch fixes PR target/79439, which is a recursive call when the 64-bit
> > code is compiled with -fpic doesn't have the NOP after the call. It is
> > pos
Since I fixed both vec_sra and vec_vsrad, the testcase should be testing
both. Committed as obvious.
-Pat
2017-03-01 Pat Haugen
* gcc.target/powerpc/pr79544.c: Add test for vec_vsrad and fix up
scan string.
Index: gcc.target/powerpc/pr79544.c
==
On Wed, 01 Mar 2017 05:38:42 PST (-0800), ger...@pfeifer.com wrote:
> On Wed, 8 Feb 2017, Gerald Pfeifer wrote:
>> Except http://riscv.org actually redirects to https://riscv.org . :-}
>
> I now made the same update to readings.html as well.
>
> Applied.
Thanks!
On 02/28/2017 11:41 PM, Richard Biener wrote:
On March 1, 2017 3:34:46 AM GMT+01:00, Martin Sebor wrote:
On 02/28/2017 01:41 PM, Richard Biener wrote:
On February 28, 2017 7:00:39 PM GMT+01:00, Jeff Law
wrote:
On 02/28/2017 10:54 AM, Martin Sebor wrote:
The GCC 7 release criteria page ment
Hi Rainer,
Thank you for the feedback.
As you suggested, I have added a check_gettimeofday_available proc in
target-supports.exp and a dg-require-gettimeofday proc in target-supports-dg.exp
which check for gettimeofday using the existing check_function_available proc.
The test still runs and pas
On 03/01/2017 08:08 AM, Gerald Pfeifer wrote:
On Tue, 28 Feb 2017, Martin Sebor wrote:
The GCC 7 release criteria page mentions Java even though
the front end has been removed. The attached patch removes Java
from the criteria page. While reviewing the rest of the text I
noticed a few minor ty
On Tue, Feb 28, 2017 at 01:12:38PM -1000, Jason Merrill wrote:
> On Tue, Feb 28, 2017 at 10:10 AM, Marek Polacek wrote:
> > On Fri, Feb 24, 2017 at 11:11:05AM -0800, Jason Merrill wrote:
> >> On Fri, Feb 24, 2017 at 8:22 AM, Marek Polacek wrote:
> >> > I had an interesting time tracking down some
On Tue, 28 Feb 2017, Martin Sebor wrote:
The GCC 7 release criteria page mentions Java even though
the front end has been removed. The attached patch removes Java
from the criteria page. While reviewing the rest of the text I
noticed a few minor typos that I corrected in the patch as well.
Th
On Wed, 1 Mar 2017, Richard Sandiford wrote:
> Richard Biener writes:
> > On Wed, 1 Mar 2017, Richard Sandiford wrote:
> >
> >> Richard Biener writes:
> >> > On Wed, 1 Mar 2017, Richard Sandiford wrote:
> >> >
> >> >> Sorry for the late reply, but:
> >> >>
> >> >> Richard Biener writes:
> >> >
The following addresses a regression in uninit warnings that happens
because clobber stmts preclude the very simple-minded support we have
for memory. The patch fixes this by instead implementing uninit
warnings for memory properly, using the alias oracle walk_aliased_vdefs
helper.
The patch add
On Wed, 8 Feb 2017, Gerald Pfeifer wrote:
> Except http://riscv.org actually redirects to https://riscv.org . :-}
I now made the same update to readings.html as well.
Applied.
Gerald
Index: readings.html
===
RCS file: /cvs/gcc/wwwd
On 01/03/17 13:32, Torsten Duwe wrote:
> On Wed, Mar 01, 2017 at 11:34:37AM +, Richard Earnshaw (lists) wrote:
>> On 01/03/17 11:26, Torsten Duwe wrote:
>>>
>>> However, writing some more documentation and being asked for clarity,
>>> I found it more depicting to talk about the function entry p
On Wed, Mar 01, 2017 at 11:34:37AM +, Richard Earnshaw (lists) wrote:
> On 01/03/17 11:26, Torsten Duwe wrote:
> >
> > However, writing some more documentation and being asked for clarity,
> > I found it more depicting to talk about the function entry point than
> > about the prologue. Also, t
Instead of making this change (for top level URLs, the trailing dash
has been optional per the standards for a decade or two) I could have
tweaked a whitelist I am maintaining with a better regexp, but figured
why not simplify things?
Committed.
Gerald
Index: codingconventions.html
=
Hi Toma,
> The patch below adds a dg_require_effective_target for gettimeofday.
> Does it look good ? I'm having some doubts about the new directive's name.
no, this has a couple of problems. See below.
> Also, this patch makes the dg-skip-if for AVR redundant. Should I remove it ?
Of course:
Richard Biener writes:
> On Wed, 1 Mar 2017, Richard Sandiford wrote:
>
>> Richard Biener writes:
>> > On Wed, 1 Mar 2017, Richard Sandiford wrote:
>> >
>> >> Sorry for the late reply, but:
>> >>
>> >> Richard Biener writes:
>> >> > On Mon, 7 Nov 2016, Richard Biener wrote:
>> >> >
>> >> >>
>>
Hi,
inline-memcpy-3.c fails when using -mabi=n64 and -mabi=n32 as a test-run option
because it does not impose a specific ABI in its test options.
As there already are variants of this test which force a specific ABI (N64 in
inline-memcpy-4.c and N32 in inline-memcpy-5.c), inline-memcpy-3.c shoul
> From: Catherine Moore
>
> Hi Toma,
> There are some MIPS ELF targets that do support gettimeofday. Perhaps you
> could handle this with a dg_require_effective_target entry for gettimeofday.
> Thanks,
> Catherine
>
Hi,
Thank you for your quick reply.
The patch below adds a dg_require_effect
On Wed, 1 Mar 2017, Richard Sandiford wrote:
> Richard Biener writes:
> > On Wed, 1 Mar 2017, Richard Sandiford wrote:
> >
> >> Sorry for the late reply, but:
> >>
> >> Richard Biener writes:
> >> > On Mon, 7 Nov 2016, Richard Biener wrote:
> >> >
> >> >>
> >> >> Currently we force peeling for
On Wed, 1 Mar 2017, Jakub Jelinek wrote:
> On Wed, Mar 01, 2017 at 01:08:58PM +0100, Richard Biener wrote:
> >
> > In debugging a -Wuninitialized issue from ipa-cp.c which does
> >
> > vr.min = vr.max = wi::zero (INT_TYPE_SIZE);
>
> Note maybe it would be faster to:
> vr.min
Richard Biener writes:
> On Wed, 1 Mar 2017, Richard Sandiford wrote:
>
>> Sorry for the late reply, but:
>>
>> Richard Biener writes:
>> > On Mon, 7 Nov 2016, Richard Biener wrote:
>> >
>> >>
>> >> Currently we force peeling for gaps whenever element overrun can occur
>> >> but for aligned acc
On Wed, Mar 01, 2017 at 01:08:58PM +0100, Richard Biener wrote:
>
> In debugging a -Wuninitialized issue from ipa-cp.c which does
>
> vr.min = vr.max = wi::zero (INT_TYPE_SIZE);
Note maybe it would be faster to:
vr.min = wi::zero (INT_TYPE_SIZE);
vr.max = wi::zero (
On Wed, Mar 1, 2017 at 1:03 PM, Bin Cheng wrote:
> Hi,
> As reported in PR66768, IVOPTs drops address-space information. Root cause
> is IVOPTs fails to preserve base-object during identifying/rewriting address
> type iv_use for pointers converted from constant values. This patch just
> skips
In debugging a -Wuninitialized issue from ipa-cp.c which does
vr.min = vr.max = wi::zero (INT_TYPE_SIZE);
I figured we are missing this operator and are thus copying possibly
uninitialized data.
This means instead of a plain assignment of wide_int_storage we
get a loop here. So I
On Wed, 1 Mar 2017, Richard Sandiford wrote:
> Sorry for the late reply, but:
>
> Richard Biener writes:
> > On Mon, 7 Nov 2016, Richard Biener wrote:
> >
> >>
> >> Currently we force peeling for gaps whenever element overrun can occur
> >> but for aligned accesses we know that the loads won't
Hi,
As reported in PR66768, IVOPTs drops address-space information. Root cause is
IVOPTs fails to preserve base-object during identifying/rewriting address type
iv_use for pointers converted from constant values. This patch just skips
address type iv_use if base-object can't be determined. In
Sorry for the late reply, but:
Richard Biener writes:
> On Mon, 7 Nov 2016, Richard Biener wrote:
>
>>
>> Currently we force peeling for gaps whenever element overrun can occur
>> but for aligned accesses we know that the loads won't trap and thus
>> we can avoid this.
>>
>> Bootstrap and regte
Patch OK?
ChangeLog:
* unwind-seh.c: Suppress warnings for RtlUnwindEx() calls.
Index: libgcc/unwind-seh.c
===
--- libgcc/unwind-seh.c (revision 245806)
+++ libgcc/unwind-seh.c (working copy)
@@ -221,7 +221,7 @@
test is tha
On 01/03/17 11:26, Torsten Duwe wrote:
> On Fri, Feb 17, 2017 at 11:30:29PM -0700, Sandra Loosemore wrote:
>>>
>>> +@item prolog_pad
>>> +@cindex @code{prolog_pad} function attribute
>>
>> I'm only a documentation maintainer so this is out of my area of
>> responsibility, but I really wish we could
On Fri, Feb 17, 2017 at 11:30:29PM -0700, Sandra Loosemore wrote:
> >
> >+@item prolog_pad
> >+@cindex @code{prolog_pad} function attribute
>
> I'm only a documentation maintainer so this is out of my area of
> responsibility, but I really wish we could rename the attribute and
> command-line opti
On Wed, Mar 01, 2017 at 01:37:14AM -0500, Michael Meissner wrote:
> This patch fixes PR target/79439, which is a recursive call when the 64-bit
> code is compiled with -fpic doesn't have the NOP after the call. It is
> possible for the function to be overriden at link time. In such a case, the
>
On Wed, Mar 01, 2017 at 11:20:37AM +0100, Tom de Vries wrote:
> > 2017-02-27 Jakub Jelinek
> >
> > * config/i386/i386.c (ix86_option_override_internal): Use
> > cond ? G_("...") : G_("...") instead of just cond ? "..." : "...".
> > * config/nvptx/nvptx.c (nvptx_goacc_validate_dims):
On Wed, Mar 1, 2017 at 10:00 AM, Uros Bizjak wrote:
> On Wed, Mar 1, 2017 at 9:48 AM, Jakub Jelinek wrote:
>> On Wed, Mar 01, 2017 at 09:34:53AM +0100, Uros Bizjak wrote:
>>> Some more thoughts on 64-bit reg on 32-bit targets warning.
>>>
>>> Actually, we never *print* register name for instructi
On 27/02/17 18:33, Jakub Jelinek wrote:
On Mon, Feb 27, 2017 at 12:47:09PM +, Joseph Myers wrote:
On Mon, 27 Feb 2017, Jakub Jelinek wrote:
On Mon, Feb 27, 2017 at 11:04:36AM +0100, Volker Reichelt wrote:
This is not -Wformat-security friendly, perhaps better
pedwarn (EXPR_LOC_O
On Wed, Mar 1, 2017 at 9:48 AM, Jakub Jelinek wrote:
> On Wed, Mar 01, 2017 at 09:34:53AM +0100, Uros Bizjak wrote:
>> Some more thoughts on 64-bit reg on 32-bit targets warning.
>>
>> Actually, we never *print* register name for instruction that use "A"
>> constraint, since %eax/%edx is always im
On Wed, Mar 01, 2017 at 09:34:53AM +0100, Uros Bizjak wrote:
> Some more thoughts on 64-bit reg on 32-bit targets warning.
>
> Actually, we never *print* register name for instruction that use "A"
> constraint, since %eax/%edx is always implicit The warning does not
> deal with constraints, so un
On Tue, Feb 28, 2017 at 4:34 PM, Uros Bizjak wrote:
> On Tue, Feb 28, 2017 at 12:06 PM, Jakub Jelinek wrote:
>> On Tue, Feb 28, 2017 at 11:41:56AM +0100, Richard Biener wrote:
>>> > 2017-02-28 Uros Bizjak
>>> >
>>> > * config/i386/i386.c (print_reg): Warn for values of 64-bit size
>>> >
Hi,
I have opened a defect for the same here:
https://sourceware.org/bugzilla/show_bug.cgi?id=21187
Thanks and Regards,
Nitish K Mishra
On Wed, Mar 1, 2017 at 1:25 PM, Nitish Kumar Mishra
wrote:
> Hi,
> The patch is for the broken exception handling in GDB on AIX platform.
> When linked statical
64 matches
Mail list logo