For "(int) -x", which is a NOP_EXPR, negate_expr_p returns true, which means
that fold_negate_expr cannot return NULL_TREE. But that's what happens here,
leading to a crash in fold_build2. negate_expr_p has (as well as negate_expr)
STRIP_SIGN_NOPS, so the "(int) -x" becomes "-x", but fold_negate_
On 02/15/2017 01:17 PM, Jason Merrill wrote:
On Wed, Feb 15, 2017 at 1:57 PM, Jonathan Wakely wrote:
On 15 February 2017 at 15:53, Jason Merrill wrote:
On Sat, Feb 11, 2017 at 4:19 PM, Jonathan Wakely wrote:
On 11 February 2017 at 20:36, Sandra Loosemore wrote:
On 02/11/2017 06:21 AM, Jonat
On 02/14/2017 03:05 AM, Bin Cheng wrote:
Hi,
This is the second try fixing PR71437. The old version patch tried to fix
issue in VRP but it requires further non-trivial change in VRP, specifically,
to better support variable value ranges. This is not appropriate at stage 4.
Alternatively, th
Hi,
This is GCC5 backport discussed in
https://gcc.gnu.org/ml/gcc-patches/2017-02/msg01034.html. Please commit it for
me, if it is ok.
PR target/76731
* config/i386/avx512fintrin.h
(_mm512_i32gather_ps): Change __addr type to void const*.
(_mm512_mask_i32gather_p
On 02/16/2017 11:48 AM, Bin Cheng wrote:
> BTW, it may also help PR78116? Hi Pat, could you please help verify this?
> Thanks!
The first testcase in pr78116 no longer contains loads from spill in the
loop even before your patch. When built with your patch, there are four
additional register cop
On 02/16/2017 04:55 AM, Richard Biener wrote:
On Tue, Feb 14, 2017 at 11:05 AM, Bin Cheng wrote:
Hi,
This is the second try fixing PR71437. The old version patch tried to fix
issue in VRP but it requires further non-trivial change in VRP, specifically,
to better support variable value ranges
On 02/14/2017 03:05 AM, Bin Cheng wrote:
Hi,
This is the second try fixing PR71437. The old version patch tried to fix
issue in VRP but it requires further non-trivial change in VRP, specifically,
to better support variable value ranges. This is not appropriate at stage 4.
Alternatively, th
On Thu, 16 Feb 2017, Jakub Jelinek wrote:
> > #define SPEC_MESSAGE(msg) msg
> >
> > "... %e" SPEC_MESSAGE ("Message") "} ..."
> >
> > and then only handling SPEC_MESSAGE specially in exgettext, rather than %e?
>
> We have over 90 of these, plus it would make the specs even harder to read.
>
On 02/14/2017 01:32 PM, Jakub Jelinek wrote:
On Tue, Feb 14, 2017 at 12:15:59PM -0700, Martin Sebor wrote:
That comment explains how the likely_adjust variable ("the adjustment")
is being used, or more precisely, how it was being used in the first
version of the patch. The comment became somewh
On 02/14/2017 06:43 AM, Jakub Jelinek wrote:
On Tue, Feb 14, 2017 at 08:18:13AM +0100, Jakub Jelinek wrote:
On Mon, Feb 13, 2017 at 04:53:19PM -0700, Jeff Law wrote:
dirtype is one of the standard {un,}signed {char,short,int,long,long long}
types, all of them have 0 in their ranges.
For VR_RANG
On 02/16/2017 12:49 PM, Jason Merrill wrote:
On Thu, Feb 16, 2017 at 11:33 AM, Jakub Jelinek wrote:
PR c++/79502
* pt.c (apply_late_template_attributes): If there are
no dependent attributes, set *p to attributes. If there were
some attributes in *p previously w
On 02/16/2017 10:46 AM, Segher Boessenkool wrote:
The testcases pr59833.c and pr61441.c check whether signaling NaNs as
input to some operation result in quiet NaNs. Without -fsignaling-nans
this is not guaranteed to happen. So, this patch add this option to
these testcases.
Tested on powerpc6
On 02/10/2017 05:29 PM, Alan Modra wrote:
On Fri, Feb 03, 2017 at 01:55:33AM -0700, Jeff Law wrote:
That seems pretty pessimistic -- do we have dominance information at this
point? If so we could check that the assignment to the register dominates
the use. If they are in the same block, then
Sorry, here is the right patch(previous one had a typo). Changelog is right.
-Original Message-
From: Koval, Julia
Sent: Thursday, February 16, 2017 11:31 PM
To: 'Uros Bizjak'
Cc: GCC Patches
Subject: RE: [PATCH] Enable RDPID instruction.
Sorry, fixed it.
gcc/
* common/config
Sorry, fixed it.
gcc/
* common/config/i386/i386-common.c (OPTION_MASK_ISA_RDPID_SET): New.
(OPTION_MASK_ISA_PKU_UNSET): New.
(ix86_handle_option): Handle -mrdpid.
* config/i386/cpuid.h
(bit_RDPID): New.
* config/i386/driver-i386.c (host_detect_local_
On 16.02.17 22:03, Jakub Jelinek wrote:
On Thu, Feb 16, 2017 at 09:57:48PM +0100, Andreas Tobler wrote:
is this patch ok for trunk?
Fixes bootstrap for x86_64-*-freebsd12 where the internal struct rtentry has
gone from userland.
TIA,
Andreas
2017-02-16 Andreas Tobler
PR sanitizer/
On Thu, Feb 16, 2017 at 09:57:48PM +0100, Andreas Tobler wrote:
> is this patch ok for trunk?
>
> Fixes bootstrap for x86_64-*-freebsd12 where the internal struct rtentry has
> gone from userland.
>
> TIA,
> Andreas
>
> 2017-02-16 Andreas Tobler
>
> PR sanitizer/79562
> * sanitiz
Hi all,
is this patch ok for trunk?
Fixes bootstrap for x86_64-*-freebsd12 where the internal struct rtentry
has gone from userland.
TIA,
Andreas
2017-02-16 Andreas Tobler
PR sanitizer/79562
* sanitizer_common/sanitizer_platform_limits_posix.cc: Cherry-pick
upstre
Hi,
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=79261 records that the interface
vec_xxpermdi isn't implemented in a bi-endian fashion; instead, it produces
results appropriate for big-endian vector element numbering even when run on
a little endian machine. This is not part of the "official vec
On Thu, Feb 16, 2017 at 11:33 AM, Jakub Jelinek wrote:
> PR c++/79502
> * pt.c (apply_late_template_attributes): If there are
> no dependent attributes, set *p to attributes. If there were
> some attributes in *p previously with or without dependent
> attri
The following patch fixes
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=78127
The patch was successfully bootstrapped and tested on x86-64.
Committed as rev. 245514.
Index: ChangeLog
===
--- ChangeLog (revision 245513)
+++ C
On Wed, 15 Feb 2017, Jeff Law wrote:
>> .../gerald/gcc-HEAD/libquadmath/math/remainderq.c:67:1: internal
>> compiler error: in ira_init_register_move_cost, at ira.c:1580
> Already testing a fix.
Thanks, Jeff. Just to confirm that things are back to bootstrap
land.
Gerald
We have two registers being assigned to each other:
(set (reg 213) (reg 209))
(set (reg 209) (reg 213))
These being the only definitions, we are happy to forward propagate reg
209 for reg 213 into a third insn, making a new use for reg 209. We are
then happy to forward propagate reg 213 for
Hi all,
the attached patch adds unwind support for aarch64-*-freebsd*.
John used to catch unwind tests in ada.
So far it bootstraps and I see no regressions.
is this ok for trunk?
TIA,
Andreas
2017-02-16 John Marino
* config/aarch64/freebsd-unwind.h: New file.
* config.hos
On Thu, Feb 16, 2017 at 10:46:46AM -0800, Carl E. Love wrote:
> I have backported the mainline fixes for the RTL definitions for
> xvcvsxdsp and xvcvuxdsp instructions, commit r245460 on 2017-02-14 to
> the GCC 5 branch.
>
> The RTL defined the instructions with a V2DF argument and returning
> V4S
GCC Maintainers:
I have backported the mainline fixes for the RTL definitions for
xvcvsxdsp and xvcvuxdsp instructions, commit r245460 on 2017-02-14 to
the GCC 5 branch.
The RTL defined the instructions with a V2DF argument and returning
V4SI. They should take a V2DI argument and return a V4SF ba
Dear Jerry,
> OK for trunk. Not applicable for 6-branch
dh! Thanks
> Yes OK as long as we are not in freeze.
This is not, strictly speaking what we all agreed about a year ago; ie
that we would try to abide by gcc conditions. However, I see that
everybody else is committing to their heart'
On 02/16/2017 03:31 AM, Paul Richard Thomas wrote:
Dear All,
The fix for the original bug is tested in dtio_24.f90. It is triggered
by the PRIVATE statement in the module and occurs because there is no
such generic interface in the module. Note, however, that there is a
typebound generic interfa
Hi,
After fixing PR79347, the main problem with vectorizer is we scale down
profiling counters
for vect_loop by VF, regardless of context CFG's profiling information. This
is wrong and
sometimes makes vect_loop not hot code, which may confuses following
optimizers. This
patch generates well-fo
Thanks.
Committed with the mentioned change. Patch in attachment for reference.
Best regards,
Thomas
On 15/02/17 11:26, Richard Earnshaw (lists) wrote:
On 15/02/17 11:23, Thomas Preudhomme wrote:
Hi,
ARMv5 and ARMv5E architectures have no known implementation. I therefore
suggest that we de
The testcases pr59833.c and pr61441.c check whether signaling NaNs as
input to some operation result in quiet NaNs. Without -fsignaling-nans
this is not guaranteed to happen. So, this patch add this option to
these testcases.
Tested on powerpc64-linux {-m32,-m64}, on aarch64-linux, and on
x86_64
The MSP430 target supports the automatic placement of functions and
data in different memory regions when passing the
"-mdata-region=either" and "-mcode-region=either" options.
MSP430x devices support the large memory model, "-mlarge", which
enables 20 bit pointers, however the vector table across
Here, the problem was that the constexpr code for handling assignments
within a constexpr function, or to a temporary object created within
the constant-expression, was also allowing assignment to the target of
the initialization. Fixed by specifically excluding that case.
Tested x86_64-pc-linux-
LTO doesn't know how to stream undeduced auto, which shows up as a
TEMPLATE_TYPE_PARM. Such a declaration isn't useful, since any
reference to it would give an error, so let's just remove it from
BLOCK_VARS.
Tested x86_64-pc-linux-gnu, applying to trunk.
commit 3ea102f324537e5706400bfdc8d9f571378
On Thu, Feb 16, 2017 at 04:57:54PM +0100, Jakub Jelinek wrote:
> Unfortunately it broke bootstrap, *p can already contain some
> other attributes (like abi_tag) and then we ICE in
> apply_identity_attributes. Note the attrib54.C testcase ICEs even
> on vanilla trunk, so if there are any dependent
On Thu, Feb 16, 2017 at 07:08:00PM +0300, Alexander Monakov wrote:
> On Thu, 16 Feb 2017, Jakub Jelinek wrote:
> > On Thu, Feb 16, 2017 at 01:56:15PM +0300, Alexander Monakov wrote:
> > Are you sure you can't have them in *.c file (e.g. by setting some variable
> > to a spec string or similar)?
> >
On Thu, 16 Feb 2017, Jakub Jelinek wrote:
> On Thu, Feb 16, 2017 at 01:56:15PM +0300, Alexander Monakov wrote:
> Are you sure you can't have them in *.c file (e.g. by setting some variable
> to a spec string or similar)?
> I think it is better to scan all those files.
Hm, probably that idea was pr
On Wed, Feb 15, 2017 at 03:19:23PM -0500, Jason Merrill wrote:
> OK.
>
> > 2017-02-15 Jakub Jelinek
> >
> > PR c++/79502
> > * pt.c (apply_late_template_attributes): If there are
> > no dependent attributes, set *p to attributes.
> >
> > * g++.dg/cpp1z/nodiscard4
> On Tue, Feb 23, 2016 at 12:32 PM, Richard Biener wrote:
> > On Tue, 23 Feb 2016, Jan Hubicka wrote:
> >
> >> >
> >> > Ok, so maybe a better question to symtab would be if there is an
> >> > actual definition for what __builtin_FOO will call. Not really
> >> > whether that definition is cfun. O
On Thu, 16 Feb 2017, Prathamesh Kulkarni wrote:
> Hi Richard,
> The attached patch handles fma_expr in gimple-fe.
> Does it look OK ?
+ tree arg0_type = TREE_TYPE (args[0]);
+ if (!SCALAR_FLOAT_TYPE_P (arg0_type))
+ {
+ error_at (loc, "operand
Hi Richard,
The attached patch handles fma_expr in gimple-fe.
Does it look OK ?
Thanks,
Prathamesh
diff --git a/gcc/c/gimple-parser.c b/gcc/c/gimple-parser.c
index d959877..fbd4c8c 100644
--- a/gcc/c/gimple-parser.c
+++ b/gcc/c/gimple-parser.c
@@ -856,6 +856,50 @@ c_parser_gimple_postfix_expressio
I am testing the following patch for PR79547. Those builtins do not
return anything that can be used to re-construct the pointer(s) passed
to them.
Queued for GCC 8.
Richard.
2017-02-16 Richard Biener
PR tree-optimization/79547
* tree-ssa-structalias.c (find_func_aliases_fo
On 15/02/17 22:44 +0100, François Dumont wrote:
Hi
Here is the end result. I eventually chose to detect usage of
versioned namespace while generating the .gdb file. I haven't use any
caching mecanism considering the limited number of test cases.
Tested under Linux x86_64 with and witho
On 03/02/17 19:02 +, Jonathan Wakely wrote:
Move explicit instantiation definitions for string I/O functions into
their own files so that iostream and locale definitions are not needed
for uses of strings without I/O. Move functions for throwing C++11
exceptions into the individual files defi
Hi!
Both C and C++ FE had forgotten case when #pragma omp target
is not followed by any identifier token. We need to ignore the pragma
in that case the same as we ignore it e.g. for #pragma omp target data
etc.
Bootstrapped/regtested on x86_64-linux and i686-linux, committed to trunk.
2017-02-1
On Tue, Feb 14, 2017 at 11:05 AM, Bin Cheng wrote:
> Hi,
> This is the second try fixing PR71437. The old version patch tried to fix
> issue in VRP but it requires further non-trivial change in VRP, specifically,
> to better support variable value ranges. This is not appropriate at stage 4.
>
On Thu, Feb 16, 2017 at 01:56:15PM +0300, Alexander Monakov wrote:
> I'm unfamiliar with exgettext (and not objecting to the patch), but from a
> quick git-grep it appears that specs strings where this %n/%e capturing needs
> to take place only appear in gcc.c and a few .h files. And on the other
On Tue, Feb 14, 2017 at 10:41 PM, Jeff Law wrote:
> On 02/14/2017 01:58 AM, Richard Biener wrote:
>>>
>>>
>>> I spoke with Andrew a bit today, he's consistently seeing cases where the
>>> union of 3 ranges is necessary to resolve the kinds of queries we're
>>> interested in. He's made a design de
On Thu, Feb 16, 2017 at 11:45 AM, Aldy Hernandez wrote:
> On 02/16/2017 03:46 AM, Martin Liška wrote:
>>
>> On 02/15/2017 05:06 PM, Aldy Hernandez wrote:
>>>
>>> On 02/15/2017 09:49 AM, Martin Liška wrote:
Hi.
As mentioned in the PR, gimple nops are wrongly handled in
is_m
Dear All,
The fix for the original bug is tested in dtio_24.f90. It is triggered
by the PRIVATE statement in the module and occurs because there is no
such generic interface in the module. Note, however, that there is a
typebound generic interface, which should not be affected by the
PRIVATE state
On Thu, 16 Feb 2017, Thomas Schwinge wrote:
> On Mon, 9 Jan 2017 17:21:41 +0100, I wrote:
> > On Thu, 29 Dec 2016 16:15:01 +0100, Jakub Jelinek wrote:
> > > PR translation/78745
> > > * exgettext: Handle multi-line help texts in *.opt files.
> >
> > With this committed in r243981, I noticed t
On Thu, Feb 16, 2017 at 11:21 AM, Koval, Julia wrote:
> Can you commit it for me please? Also these intrinsics are very old, can I
> also backport it to GCC5 and GCC4.9?
Backport to gcc-5 is OK, but gcc-4.9 branch is closed.
Uros.
On 02/16/2017 03:46 AM, Martin Liška wrote:
On 02/15/2017 05:06 PM, Aldy Hernandez wrote:
On 02/15/2017 09:49 AM, Martin Liška wrote:
Hi.
As mentioned in the PR, gimple nops are wrongly handled in is_maybe_undefined
function.
Patch can bootstrap on ppc64le-redhat-linux and survives regression
Hi Dominik,
> The attached patch removes the xfail on two sub tests of
> attr-alloc_size-11.c for the targets who were reported to produce
> an XPASS:
> https://gcc.gnu.org/bugzilla/show_bug.cgi?id=79356
>
> Tested on s390x biarch and s390. Please check if the strings for
> the other targets are
Hi!
On Mon, 9 Jan 2017 17:21:41 +0100, I wrote:
> On Thu, 29 Dec 2016 16:15:01 +0100, Jakub Jelinek wrote:
> > PR translation/78745
> > * exgettext: Handle multi-line help texts in *.opt files.
>
> With this committed in r243981, I noticed the following new snippet in
> gcc/po/gcc.pot:
>
Can you commit it for me please? Also these intrinsics are very old, can I also
backport it to GCC5 and GCC4.9?
Thanks,
Julia
-Original Message-
From: Uros Bizjak [mailto:ubiz...@gmail.com]
Sent: Thursday, February 16, 2017 9:27 AM
To: Koval, Julia
Cc: GCC Patches
Subject: Re: [PATCH]
On 16 February 2017 at 14:01, Richard Biener wrote:
> On Wed, 15 Feb 2017, Prathamesh Kulkarni wrote:
>
>> Hi,
>> For the following (invalid) test-case:
>>
>> void __GIMPLE () foo (int a)
>> {
>> int t0;
>> int _1;
>> _1 = a;
>> t0_1 = a;
>> }
>>
>> results in following ICE:
>> gimplefe-er
On 02/15/2017 05:06 PM, Aldy Hernandez wrote:
> On 02/15/2017 09:49 AM, Martin Liška wrote:
>> Hi.
>>
>> As mentioned in the PR, gimple nops are wrongly handled in
>> is_maybe_undefined function.
>> Patch can bootstrap on ppc64le-redhat-linux and survives regression tests.
>
>>
>> gimple *d
On Wed, Feb 15, 2017 at 3:09 PM, Koval, Julia wrote:
> Hi,
>
> This patch enables RDPID intrinsic, described in SDM 4-534 Vol. 2B
> https://software.intel.com/sites/default/files/managed/39/c5/325462-sdm-vol-1-2abcd-3abcd.pdf
> and intrinsic guide:
> https://software.intel.com/sites/landingpage/In
On Wed, 15 Feb 2017, Prathamesh Kulkarni wrote:
> Hi,
> For the following (invalid) test-case:
>
> void __GIMPLE () foo (int a)
> {
> int t0;
> int _1;
> _1 = a;
> t0_1 = a;
> }
>
> results in following ICE:
> gimplefe-error-4.c: In function ‘foo’:
> gimplefe-error-4.c:20:1: error: SSA_N
On Wed, Feb 15, 2017 at 1:03 PM, Koval, Julia wrote:
> Hi,
> Is it ok to backport this fix to GCC6 branch?
>
> PR target/76731
> * config/i386/avx512fintrin.h
> (_mm512_i32gather_ps): Change __addr type to void const*.
> (_mm512_mask_i32gather_ps): Ditto.
>
61 matches
Mail list logo