Greg Padgett has uploaded a new change for review.
Change subject: core: simplify businessentity equals() methods [part 1]
..
core: simplify businessentity equals() methods [part 1]
Instead of manually doing a null-safe comparis
Vojtech Szocs has uploaded a new change for review.
Change subject: userportal: Set default refresh rate to 30s
..
userportal: Set default refresh rate to 30s
Work in progress, needs verification, use at own risk :-)
Change-Id:
Alexander Wels has posted comments on this change.
Change subject: userportal: fix memory leak when VM selected
..
Patch Set 7: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/12301
To
Alexander Wels has posted comments on this change.
Change subject: userportal: fix memory leak when VM selected
..
Patch Set 5: Looks good to me, but someone else must approve
Removed the if(this.model != model).
--
To view, v
Allon Mureinik has uploaded a new change for review.
Change subject: ui: Fix possible NPE in VmListModel
..
ui: Fix possible NPE in VmListModel
Fixed a possible NullPointerException in VmListModel, as
retVal.isSucceeded() is cal
Allon Mureinik has uploaded a new change for review.
Change subject: ui: AddDataCenterRM redundant null check
..
ui: AddDataCenterRM redundant null check
The rollback3() method checks model for being null a couple of lines
after
Allon Mureinik has uploaded a new change for review.
Change subject: tools: StandaloneDataSource: configReader.close
..
tools: StandaloneDataSource: configReader.close
Fixed a possible NPE when closing configReader in the finall
Allon Mureinik has uploaded a new change for review.
Change subject: tools: StandaloneDataSource: add @Override
..
tools: StandaloneDataSource: add @Override
Added missing @Override annotations to StandaloneDataSource's methods.
Allon Mureinik has uploaded a new change for review.
Change subject: packaging: Remove Module.resourcePath
..
packaging: Remove Module.resourcePath
The resourcePath member in Module is never initialized, and in fact,
there is no
Allon Mureinik has uploaded a new change for review.
Change subject: userportal: fix possible NPE in % progress bar
..
userportal: fix possible NPE in % progress bar
DoublePercentageProgressBar unboxes valueA and valueB (into fa
Allon Mureinik has uploaded a new change for review.
Change subject: core: Remove vdsGroups member from storage_pool
..
core: Remove vdsGroups member from storage_pool
Removed the private member "vdsGroups" from the storage_pool
Allon Mureinik has uploaded a new change for review.
Change subject: core: Fix DnsSRVLocator possible NPE
..
core: Fix DnsSRVLocator possible NPE
getSRVResult extracted recordList's length before null-checking it,
which may have
Allon Mureinik has uploaded a new change for review.
Change subject: core: Remove vm_last_up_time member from VmDynamic
..
core: Remove vm_last_up_time member from VmDynamic
Removed the private member "vm_last_up_time" from the
Allon Mureinik has uploaded a new change for review.
Change subject: ui: Simplify keySelected eval in KeyValueModel
..
ui: Simplify keySelected eval in KeyValueModel
Simplify the evaluation of eventRaised()'s keySelected variabl
Allon Mureinik has uploaded a new change for review.
Change subject: core: GSSAPIDirContextAuthentication null-check
..
core: GSSAPIDirContextAuthentication null-check
Removed a redundant null check on the "result" variable, sin
Allon Mureinik has uploaded a new change for review.
Change subject: core: EJBUtilsStratehy - fix NPE in error log
..
core: EJBUtilsStratehy - fix NPE in error log
In the findBean method, jndiNameSB is initialized inside the try
Vojtech Szocs has posted comments on this change.
Change subject: userportal: fix memory leak when VM selected
..
Patch Set 3:
Long story short: I think we should remove "if (this.model != model)" condition
in FormBuilder.show
Vojtech Szocs has posted comments on this change.
Change subject: userportal: fix memory leak when VM selected
..
Patch Set 3:
Except one question (below) the patch looks good.
I fixed some code formatting, e.g. "if(.." should
Vojtech Szocs has posted comments on this change.
Change subject: webadmin,userportal: Improve form-based sub tabs
..
Patch Set 1: Verified
Verified in FF10/Linux (WebAdmin, UserPortal) and in IE8 (UserPortal).
Form-based sub
Ravi Nori has posted comments on this change.
Change subject: cli: collection-based-options could be passed in 2 ways(#859684)
..
Patch Set 1: Verified
--
To view, visit http://gerrit.ovirt.org/12324
To unsubscribe, visit http:
Ravi Nori has uploaded a new change for review.
Change subject: cli: collection-based-options could be passed in 2 ways(#859684)
..
cli: collection-based-options could be passed in 2 ways(#859684)
Collection based options can be
Ravi Nori has abandoned this change.
Change subject: cli: collection-based-options could be passed in 2 ways(#859684)
..
Patch Set 1: Abandoned
Will submit another patch
--
To view, visit http://gerrit.ovirt.org/12323
To unsub
Ravi Nori has uploaded a new change for review.
Change subject: cli: collection-based-options could be passed in 2 ways(#859684)
..
cli: collection-based-options could be passed in 2 ways(#859684)
Collection based options can be
Juan Hernandez has posted comments on this change.
Change subject: core: Move the session cleaner interceptor to bll
..
Patch Set 1: Verified
Federico, this was the reason the browser kept asking for the user name and
password
Juan Hernandez has uploaded a new change for review.
Change subject: core: Move the session cleaner interceptor to bll
..
core: Move the session cleaner interceptor to bll
Commit 028ff6 moved the utils library to a JBoss module,
Alexander Wels has posted comments on this change.
Change subject: engine:solve the language switch fuction failure problem
..
Patch Set 1: I would prefer that you didn't submit this
Yes this is a duplicate of that issue, the p
Allon Mureinik has posted comments on this change.
Change subject: core: Added RegisterDiskCommand and GetUnregisteredDisksQuery
..
Patch Set 5: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ov
Allon Mureinik has posted comments on this change.
Change subject: core: Unfilter ImagesHandler.PerformImagesChecks
..
Patch Set 1: Verified
--
To view, visit http://gerrit.ovirt.org/12321
To unsubscribe, visit http://gerrit.ov
Allon Mureinik has posted comments on this change.
Change subject: core: Add ImagesHandler.filterEditableImageDisks
..
Patch Set 1: Verified
--
To view, visit http://gerrit.ovirt.org/12320
To unsubscribe, visit http://gerrit.ov
Allon Mureinik has posted comments on this change.
Change subject: core: ImageHandlerTest - add missing annotation
..
Patch Set 1: Verified
--
To view, visit http://gerrit.ovirt.org/12319
To unsubscribe, visit http://gerrit.ovi
Allon Mureinik has posted comments on this change.
Change subject: core: ImagesHandler: filterImageDisks readability
..
Patch Set 1: Verified
--
To view, visit http://gerrit.ovirt.org/12318
To unsubscribe, visit http://gerrit.o
Allon Mureinik has uploaded a new change for review.
Change subject: core: Add ImagesHandler.filterEditableImageDisks
..
core: Add ImagesHandler.filterEditableImageDisks
In the current implementation, an image that can be snapsh
Allon Mureinik has uploaded a new change for review.
Change subject: core: Unfilter ImagesHandler.PerformImagesChecks
..
core: Unfilter ImagesHandler.PerformImagesChecks
Before this patch, ImagesHandler.PerformImagesChecks recei
Allon Mureinik has uploaded a new change for review.
Change subject: core: ImagesHandler: filterImageDisks readability
..
core: ImagesHandler: filterImageDisks readability
Improved readability of ImagesHandler.filterImageDisks:
Allon Mureinik has uploaded a new change for review.
Change subject: core: ImageHandlerTest - add missing annotation
..
core: ImageHandlerTest - add missing annotation
Added the missing @Test annotation to
testGetAllStorageIdsFo
Chris Morrissey has posted comments on this change.
Change subject: core: Added RegisterDiskCommand and GetUnregisteredDisksQuery
..
Patch Set 5:
Patch set 5 includes fixes for all inline comments from patch set 4 as well as
a
Alexander Wels has posted comments on this change.
Change subject: userportal: fix memory leak when VM selected
..
Patch Set 2: Verified; Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org
Allon Mureinik has posted comments on this change.
Change subject: core: Extract SD validations from ImagesHandler
..
Patch Set 4: Verified
Removed useless ImagesHandler.PerformImagesCheck call from AddDiskCommand - see
detail
Allon Mureinik has posted comments on this change.
Change subject: core: Move lock RunVmCommand -> RunVmCommandBase
..
Patch Set 1: Verified
--
To view, visit http://gerrit.ovirt.org/12315
To unsubscribe, visit http://gerrit.ov
Allon Mureinik has uploaded a new change for review.
Change subject: core: Move lock RunVmCommand -> RunVmCommandBase
..
core: Move lock RunVmCommand -> RunVmCommandBase
Move RunVmCommand's exclusive lock up to its ancestor, Run
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: Remove useless null check
..
webadmin: Remove useless null check
Remove a useless null check from
VdcQueryReturnValue_CustomFieldSerializer's
Allon Mureinik has submitted this change and it was merged.
Change subject: build: NlsCheck - proper inner class
..
build: NlsCheck - proper inner class
Made the inner class QuotedString private static, as it is not used
outsid
Allon Mureinik has submitted this change and it was merged.
Change subject: build: NlsCheck - unwrap else clause
..
build: NlsCheck - unwrap else clause
Unwrapped a useless else clause, since the if clause does not terminate
pr
Allon Mureinik has posted comments on this change.
Change subject: build: NlsCheck - unwrap else clause
..
Patch Set 2: Verified; Looks good to me, approved
Rebased, no code changes.
+2 by Tal, +1 by Maor, Liron Alissa.
--
To
Allon Mureinik has posted comments on this change.
Change subject: build: NlsCheck - proper inner class
..
Patch Set 2: Verified; Looks good to me, approved
Rebased, no code changes.
+2 by Tal, +1 by Maor and Alissa.
--
To vie
Allon Mureinik has posted comments on this change.
Change subject: webadmin: Remove useless null check
..
Patch Set 2: Verified; Looks good to me, approved
Rebased, no code changes.
+2 by Tal.
--
To view, visit http://gerrit.o
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Clean up exception in AuditLogDirectorTest
..
core: Clean up exception in AuditLogDirectorTest
Fixed an Exception being printed in AuditLgDirecto
Allon Mureinik has submitted this change and it was merged.
Change subject: core: DbFacadeUtils basic Java cleanup
..
core: DbFacadeUtils basic Java cleanup
Some basic Java cleanup - removed useless commit message, added braces
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Fix NPE in AuditLogableBaseTest
..
core: Fix NPE in AuditLogableBaseTest
AuditLogableBaseTest would print an annoying NullPointerException
stackt
Allon Mureinik has posted comments on this change.
Change subject: core: DbFacadeUtils basic Java cleanup
..
Patch Set 2: Verified; Looks good to me, approved
Rebased, no code changes.
+2 by Maor, +1 by Alissa.
--
To view, vis
Allon Mureinik has posted comments on this change.
Change subject: core: Clean up exception in AuditLogDirectorTest
..
Patch Set 2: Verified; Looks good to me, approved
Rebased, removed commented out import as per Alissa's sugg
Allon Mureinik has posted comments on this change.
Change subject: core: Fix NPE in AuditLogableBaseTest
..
Patch Set 2: Verified; Looks good to me, approved
Rebased, no code changes.
+2 by Maor, +1 by Vered and Alissa.
--
To
Allon Mureinik has posted comments on this change.
Change subject: core: Clean up exception in AuditLogDirectorTest
..
Patch Set 1: (1 inline comment)
File
backend/manager/m
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Clean up Version.OpEquality
..
core: Clean up Version.OpEquality
Proper handling of boolean values in OpEquality.
Change-Id: Ib09be089763a101ff7
Allon Mureinik has posted comments on this change.
Change subject: core: Clean up Version.OpEquality
..
Patch Set 3: Verified; Looks good to me, approved
Rebased, no code changes.
+2 by Tal, +1 Vered.
--
To view, visit http://
Allon Mureinik has submitted this change and it was merged.
Change subject: core: PropertyInfo method name
..
core: PropertyInfo method name
Changes PropertyInfo' GetValue method to getValue, as per Java
conventions.
Change-Id
Allon Mureinik has posted comments on this change.
Change subject: core: PropertyInfo method name
..
Patch Set 3: Verified; Looks good to me, approved
Rebased, no code changes.
+2 by Tal, +1 Vered.
--
To view, visit http://ger
Allon Mureinik has posted comments on this change.
Change subject: core: Fix log modifiers in PropretyInfo
..
Patch Set 3: Verified; Looks good to me, approved
Rebased, no code changes.
+2 by Tal
--
To view, visit http://gerri
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Fix log modifiers in PropretyInfo
..
core: Fix log modifiers in PropretyInfo
Fixed PropertyInfo's log to have correct modifiers, as per Java
conv
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Remove PropertyCompat
..
core: Remove PropertyCompat
PropertyCompat was an empty extension to PropertyInfo, with no
additional logic of it's own,
Allon Mureinik has posted comments on this change.
Change subject: core: Remove PropertyCompat
..
Patch Set 3: Verified; Looks good to me, approved
Rebased, no code changes.
+2 by Tal, +1 by Maor and Vered.
--
To view, visit h
Allon Mureinik has submitted this change and it was merged.
Change subject: core: JUnit 4 style for PropertyCompatTest
..
core: JUnit 4 style for PropertyCompatTest
Fixed PropertyCompatTest to use JUnit 4 style instead of JUnit
Allon Mureinik has posted comments on this change.
Change subject: core: JUnit 4 style for PropertyCompatTest
..
Patch Set 2: Verified; Looks good to me, approved
Rebased, no code changes.
+2 by Maor, +1 by Alissa.
--
To view,
Allon Mureinik has submitted this change and it was merged.
Change subject: core: TypeCompat - make log final
..
core: TypeCompat - make log final
Fixed the log's modifiers, as per proper Java conventions.
Change-Id: Ia540ae7e
Allon Mureinik has posted comments on this change.
Change subject: core: TypeCompat - make log final
..
Patch Set 2: Verified; Looks good to me, approved
Rebased, no code changes.
+2 by Maor, +1 by Alissa.
--
To view, visit ht
Juan Hernandez has posted comments on this change.
Change subject: cleanup: pep8 compliant
..
Patch Set 1: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/12314
To unsubscribe, visit ht
Sandro Bonazzola has posted comments on this change.
Change subject: cleanup: pep8 compliant
..
Patch Set 1: Verified
just for having make check running without failures.
--
To view, visit http://gerrit.ovirt.org/12314
To unsu
Sandro Bonazzola has uploaded a new change for review.
Change subject: cleanup: pep8 compliant
..
cleanup: pep8 compliant
Change-Id: Ic1c47d19ba75c7b681c132d6a5738448d9a5d5b8
Signed-off-by: Sandro Bonazzola
---
M src/__main__.p
Sandro Bonazzola has posted comments on this change.
Change subject: packaging: changed psql execution environment
..
Patch Set 3: Verified
--
To view, visit http://gerrit.ovirt.org/12227
To unsubscribe, visit http://gerrit.ovi
Juan Hernandez has submitted this change and it was merged.
Change subject: packaging: Add beanutils as dependency of utils
..
packaging: Add beanutils as dependency of utils
This is needed by the OVF related code.
Change-Id:
Juan Hernandez has posted comments on this change.
Change subject: packaging: Add beanutils as dependency of utils
..
Patch Set 1: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/12313
To unsubscribe, visit
Federico Simoncelli has posted comments on this change.
Change subject: packaging: Add beanutils as dependency of utils
..
Patch Set 1: Verified; Looks good to me, but someone else must approve
--
To view, visit http://gerrit.o
Juan Hernandez has uploaded a new change for review.
Change subject: packaging: Add beanutils as dependency of utils
..
packaging: Add beanutils as dependency of utils
This is needed by the OVF related code.
Change-Id: I633a0a3
Sahina Bose has posted comments on this change.
Change subject: engine: Support for gluster asynchronous tasks(WIP)
..
Patch Set 3: (1 inline comment)
File
backend/manager/m
Michael Pasternak has posted comments on this change.
Change subject: core: Added RegisterDiskCommand and GetUnregisteredDisksQuery
..
Patch Set 4:
You're right Chris,
If you'll take a look at general comment in patch set 1,
i
Juan Hernandez has posted comments on this change.
Change subject: packaging: changed psql execution environment
..
Patch Set 2: Looks good to me, but someone else must approve
(1 inline comment)
Only a very minor comment insi
Sandro Bonazzola has posted comments on this change.
Change subject: packaging: changed psql execution environment
..
Patch Set 2: Verified
--
To view, visit http://gerrit.ovirt.org/12227
To unsubscribe, visit http://gerrit.ovi
77 matches
Mail list logo