On Wed, Aug 11, 2021 at 2:18 AM Chris Johns wrote:
>
> On 11/8/21 3:21 pm, Sebastian Huber wrote:
> > On 10/08/2021 16:50, Sebastian Huber wrote:
> >> On 10/08/2021 16:46, Gedare Bloom wrote:
> >>> This is a good cleanup. The naming seems a bit off to me, but it's all
> >>> internal so we can alwa
On 11/8/21 3:21 pm, Sebastian Huber wrote:
> On 10/08/2021 16:50, Sebastian Huber wrote:
>> On 10/08/2021 16:46, Gedare Bloom wrote:
>>> This is a good cleanup. The naming seems a bit off to me, but it's all
>>> internal so we can always adjust it later. (I think it should be
>>> singular "Priority
On 10/08/2021 16:50, Sebastian Huber wrote:
On 10/08/2021 16:46, Gedare Bloom wrote:
This is a good cleanup. The naming seems a bit off to me, but it's all
internal so we can always adjust it later. (I think it should be
singular "Priority_Flag", but really it's not just a flag, it's
something l
On 10/08/2021 16:46, Gedare Bloom wrote:
This is a good cleanup. The naming seems a bit off to me, but it's all
internal so we can always adjust it later. (I think it should be
singular "Priority_Flag", but really it's not just a flag, it's
something like the "Priority_Discipline" -- I can't thin
This is a good cleanup. The naming seems a bit off to me, but it's all
internal so we can always adjust it later. (I think it should be
singular "Priority_Flag", but really it's not just a flag, it's
something like the "Priority_Discipline" -- I can't think what is the
right word however for how yo
Use an enum instead of a boolean to indicated if a priority should be
appended or prepended to its priority group. This makes the code more
expressive and it a bit more efficient since a branch in
_Scheduler_Node_set_priority() is avoided.
---
cpukit/include/rtems/posix/muteximpl.h| 2 +-