On 7/7/22 13:11, Duc Doan wrote:
Maybe it's as simple as renaming the identifiers from stm32f4_gpio =>
stm32_gpio for clarity for most functions, and declaring these files
in
the H7 scripts.
I think I will wait for Karel's opinion about that.
I just need to catch a bit of breath and then I'l
Hello Cedric,
On Thu, 2022-07-07 at 10:32 +0200, Cedric Berger wrote:
> Hello,
>
> On 07.07.22 09:35, Duc Doan wrote:
> > Actually my project is focused on STM32F4, but it is nice that the
> > code
> > could be extensible to H7. However, I can't think of a good way to
> > use
> > that code with H
Hello,
On 07.07.22 09:35, Duc Doan wrote:
Actually my project is focused on STM32F4, but it is nice that the code
could be extensible to H7. However, I can't think of a good way to use
that code with H7 right now; do you think that the code can be copied
and pasted to H7 BSP? Or is there a bette
Hello Cedric,
On Wed, 2022-07-06 at 16:41 +0200, Cedric Berger wrote:
> One more detail and one question follows:
>
> > static unsigned int EXTIx_IRQn[] = {
> > EXTI0_IRQn,
> > EXTI1_IRQn,
>
> Detail: You should really mark all constants like that "const": on a
> STM32 with little
Hi Duc,
As I mentioned in the other patch, please save and consolidate all
patch revisions and send an entire new patch set of -v2 patches with
all your changes. You can also squash changes into your patch set, for
example to address reviewer comments like these. We would like to have
a clean set
Hello,
On 06.07.22 13:03, Duc Doan wrote:
Hello Cedric,
Thank you for your feedback. I agree with you that there are places that could
be optimized out. Here is a new patch for that.
Yes, this looks good, thanks!
One more detail and one question follows:
static unsigned int EXTIx_IRQn[]
Hello Cedric,
Thank you for your feedback. I agree with you that there are places that could
be optimized out. Here is a new patch for that.
Best,
Duc Doan
---
bsps/arm/stm32f4/gpio/gpio.c | 87
1 file changed, 29 insertions(+), 58 deletions(-)
diff --git