This revision was automatically updated to reflect the committed changes.
Closed by commit rL355368: Replace clang::FileData with llvm::vfs::Status
(authored by harlanhaskins, committed by ).
Herald added a project: LLVM.
Herald added a subscriber: llvm-commits.
Changed prior to commit:
https:/
benlangmuir added inline comments.
Comment at: clang/lib/Basic/FileManager.cpp:305
+UFE = &UniqueRealFiles[Status.getUniqueID()];
+Status = llvm::vfs::Status(
+ Status.getName(), Status.getUniqueID(),
harlanhaskins wrote:
> benlangmuir wrote:
> > Why
harlanhaskins marked an inline comment as done.
harlanhaskins added inline comments.
Comment at: clang/lib/Basic/FileManager.cpp:305
+UFE = &UniqueRealFiles[Status.getUniqueID()];
+Status = llvm::vfs::Status(
+ Status.getName(), Status.getUniqueID(),
benlangmuir accepted this revision.
benlangmuir added a comment.
This revision is now accepted and ready to land.
LGTM, although I made a small suggestion for clarity. FYI `InPCH` was used by
PTH, which was removed a couple of months ago.
Comment at: clang/lib/Basic/FileManag
harlanhaskins created this revision.
Herald added a project: clang.
Herald added a subscriber: cfe-commits.
harlanhaskins edited the summary of this revision.
harlanhaskins added a reviewer: benlangmuir.
Herald added a subscriber: ormris.
`FileData` was only ever used as a container for the values