benlangmuir accepted this revision. benlangmuir added a comment. This revision is now accepted and ready to land.
LGTM, although I made a small suggestion for clarity. FYI `InPCH` was used by PTH, which was removed a couple of months ago. ================ Comment at: clang/lib/Basic/FileManager.cpp:305 + UFE = &UniqueRealFiles[Status.getUniqueID()]; + Status = llvm::vfs::Status( + Status.getName(), Status.getUniqueID(), ---------------- Why copy Status back into Status instead of mutating the relevant fields? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D58924/new/ https://reviews.llvm.org/D58924 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits