aardappel added inline comments.
Comment at: llvm/test/DebugInfo/WebAssembly/dwarf-headers.ll:47
+;
+; SINGLE-4: .debug_types contents:
+; SINGLE-4: 0x: Type Unit: {{.*}} version = 0x0004, abbr_offset
I guess this doesn't actually test that only one copy
aardappel added inline comments.
Comment at: llvm/lib/MC/WasmObjectWriter.cpp:1313
+ }
+ return writeOneObject(Asm, Layout, DwoMode::AllSections);
+}
Nit picking on this because I can't find anything else to complain about:
This line would be more readable insi
aardappel accepted this revision.
aardappel added a comment.
This revision is now accepted and ready to land.
Nice, fairly unintrusive actually. If you desperately wanted to fix the need
for changing `W` dynamically, you could instead make it allocate a second
`WasmObjectWriter` to write the `dw
This revision was automatically updated to reflect the committed changes.
Closed by commit rG29f8c9f6c25d: [WebAssembly] Triple::wasm64 related cleanup
(authored by aardappel).
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D83713/new/
https://reviews
aardappel updated this revision to Diff 277627.
aardappel added a comment.
Made LLD `is64` optional, so we can know if is set consistently.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D83713/new/
https://reviews.llvm.org/D83713
Files:
clang/lib/Driver/ToolChain.cpp
lld/wasm/Config
aardappel created this revision.
aardappel added reviewers: dschuff, sbc100.
Herald added subscribers: llvm-commits, cfe-commits, sunfish, aheejin,
hiraditya, jgravelle-google.
Herald added projects: clang, LLVM.
A few cases that didn't cover Triple::wasm64 correctly.
Repository:
rG LLVM Gith
This revision was not accepted when it landed; it landed in state "Needs
Review".
This revision was automatically updated to reflect the committed changes.
Closed by commit rG16d83c395a1f: [WebAssembly] Added 64-bit
memory.grow/size/copy/fill (authored by aardappel).
Herald added a project: clang
This revision was automatically updated to reflect the committed changes.
Closed by commit rG16d83c395a1f: [WebAssembly] Added 64-bit
memory.grow/size/copy/fill (authored by aardappel).
Herald added a project: clang.
Herald added a subscriber: cfe-commits.
Changed prior to commit:
https://revie
This revision was automatically updated to reflect the committed changes.
Closed by commit rGb9a539c01084: [WebAssembly] Adding 64-bit versions of
__stack_pointer and other globals (authored by aardappel).
Changed prior to commit:
https://reviews.llvm.org/D82130?vs=273539&id=273548#toc
Reposit
aardappel updated this revision to Diff 273539.
aardappel added a comment.
types & variables in InputChunks.cpp
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D82130/new/
https://reviews.llvm.org/D82130
Files:
clang/lib/Driver/ToolChains/WebAssembly.cpp
lld/wasm/Config.h
lld/wasm/D
aardappel updated this revision to Diff 273503.
aardappel added a comment.
- Fixed ISEL for FrameIndex
- Fixed 64-bit conditions in branches (thanks @aheejin!)
- Made the FrameIndex generation code in WebAssemblyRegisterInfo work.
- Made userstack.ll and stack-alignment.ll pass in wasm64.
- Code r
aardappel added a comment.
@dschuff still working on it, it uncovered some issues (as it should :)
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D82130/new/
https://reviews.llvm.org/D82130
___
cfe-commits mailing list
cfe-commits@lists.llvm.
aardappel marked 2 inline comments as done.
aardappel added a comment.
I'll likely fork `userstack.ll` since the majority of lines need changes.
Comment at: lld/wasm/Driver.cpp:385
+StringRef s = arg->getValue();
+if (s == "wasm32")
+ config->is64 = false;
aardappel created this revision.
aardappel added reviewers: sbc100, dschuff.
Herald added subscribers: llvm-commits, cfe-commits, sunfish, aheejin,
hiraditya, jgravelle-google.
Herald added projects: clang, LLVM.
aardappel updated this revision to Diff 271859.
aardappel added a comment.
This is a
aardappel updated this revision to Diff 271859.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D82130/new/
https://reviews.llvm.org/D82130
Files:
clang/lib/Driver/ToolChains/WebAssembly.cpp
lld/wasm/Config.h
lld/wasm/Driver.cpp
lld/wasm/InputChunks.cpp
lld/wasm/Options.td
llvm/
aardappel added a comment.
This is a first iteration, probably needs more tests :) I was thinking of
forking `userstack.ll` since it has most `__stack_pointer` tests, but I am not
sure if it's that useful. Needs a test that uses the new wasm-ld flag. Opinions
welcome.
CHANGES SINCE LAST ACTIO
aardappel added a comment.
@MyDeveloperDay thanks for your thoughts.. while `-stable` would be helpful
once you know you have the issue (or to permanently turn on in a git
pre-submit), it does not help developers that don't even know this is a thing,
and waste a bunch of time figuring out what
aardappel added a comment.
@krasimir first you say that fixing it is hard, then when someone wants to
attempt, that it is not necessary?
Plenty of people run `clang-format` in automated fashion as part of some
pipeline, seems to me results ping-ponging between two formattings and
cluttering co
18 matches
Mail list logo