aardappel added inline comments.
================ Comment at: llvm/lib/MC/WasmObjectWriter.cpp:1313 + } + return writeOneObject(Asm, Layout, DwoMode::AllSections); +} ---------------- Nit picking on this because I can't find anything else to complain about: This line would be more readable inside an `else`. I know LLVM prefers "early out" (and so do I), but here IsSplitDwarf is really not an early out case since it is the most complex case, and !IsSplitDwarf is not great for early out either because it is the common case. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D85685/new/ https://reviews.llvm.org/D85685 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits