[PATCH] D93179: [X86] Convert fmin/fmax _mm_reduce_* intrinsics to emit llvm.reduction intrinsics (PR47506)

2021-02-06 Thread Pengfei Wang via Phabricator via cfe-commits
pengfei added a comment. In D93179#2535702 , @pengfei wrote: > Hi @RKSimon, what's the status of updating these reduce intrinsics? Is there > any difficulty for always assigning them fast math flag? I received bug > report for the previous change D92940

[PATCH] D94973: [clang][OpenMP] Use OpenMPIRBuilder for workshare loops.

2021-02-06 Thread Michael Kruse via Phabricator via cfe-commits
Meinersbur added inline comments. Comment at: clang/include/clang/AST/StmtOpenMP.h:41 +/// purposes: +/// * Loop variable: The user-accessible variable with different value for each +/// iteration. jdenny wrote: > I suggest the terms "loop user variable" and "l

[PATCH] D96215: [clang-tidy] Recognize captures as a form of aliasing.

2021-02-06 Thread Artem Dergachev via Phabricator via cfe-commits
NoQ created this revision. NoQ added reviewers: alexfh, gribozavr2, aaron.ballman, vsavchenko. Herald added subscribers: nullptr.cpp, martong, mgehre, Charusso, xazax.hun. NoQ requested review of this revision. The utility function `clang::tidy::utils::`()` scans the function for pointer/referenc

[PATCH] D68682: format::cleanupAroundReplacements removes whole line when Removals leave previously non-blank line blank

2021-02-06 Thread Conrad Poelman via Phabricator via cfe-commits
poelmanc added a comment. On 2 Feb Harbormaster found a bug from my switching some char* code to use StringRef. I uploaded a new patch on 4 Feb, but Harbormaster does not appear to have rerun. What triggers Harbormaster - do I need to take some action? I haven'

LLVM buildmaster will be restarted tonight

2021-02-06 Thread Galina Kistanova via cfe-commits
Hello everyone, LLVM buildmaster will be restarted after 7PM PST today. Thanks Galina ___ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

[PATCH] D95771: [clang-tidy] fix modernize-loop-convert to retain needed array-like operator[]

2021-02-06 Thread Conrad Poelman via Phabricator via cfe-commits
poelmanc added a comment. In D95771#2547102 , @njames93 wrote: > Should this be committed using `poelmanc `? That or `Conrad Poelman ` would be great, thanks. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D95771/new/ https://reviews.llvm.org/D95

[PATCH] D96114: [ASTMatchers] Fix parent-child traversal between functions and parms

2021-02-06 Thread Nathan James via Phabricator via cfe-commits
njames93 added a reviewer: klimek. njames93 added a comment. I have no issues here, but see what the others say as well. Also related post to cfe-dev - https://lists.llvm.org/pipermail/cfe-dev/2021-February/067629.html Comment at: clang/lib/ASTMatchers/ASTMatchFinder.cpp:148-1

[PATCH] D96044: DebugInfo: Emit "LocalToUnit" flag on local member function decls.

2021-02-06 Thread David Blaikie via Phabricator via cfe-commits
dblaikie accepted this revision. dblaikie added a comment. This revision is now accepted and ready to land. Sounds good. Out of curiosity, how'd you come across this/do you have any particular use case that uses DW_AT_external? Comment at: clang/test/CodeGenCXX/debug-info-clas

[PATCH] D95771: [clang-tidy] fix modernize-loop-convert to retain needed array-like operator[]

2021-02-06 Thread Nathan James via Phabricator via cfe-commits
njames93 added a comment. Herald added a subscriber: nullptr.cpp. In D95771#2540598 , @poelmanc wrote: > @njames93 Thanks for the review and for accepting this revision. I lack > llvm-project commit access so if it's good to go I would greatly appreciate

[PATCH] D94735: CGDebugInfo CreatedLimitedType: Drop file/line for RecordType with invalid location

2021-02-06 Thread Fangrui Song via Phabricator via cfe-commits
MaskRay added a subscriber: ABataev. MaskRay added a comment. Perhaps we should just drop `llvm/IR/Verifier.cpp:1075` (which is not tested): if (N.getTag() == dwarf::DW_TAG_class_type || N.getTag() == dwarf::DW_TAG_union_type) { AssertDI(N.getFile() && !N.getFile()->getFilename().empt

[PATCH] D96209: [clang-tidy] Fix readability-avoid-const-params-in-decls removing const in template paramaters

2021-02-06 Thread Nathan James via Phabricator via cfe-commits
njames93 created this revision. njames93 added reviewers: aaron.ballman, alexfh. Herald added subscribers: nullptr.cpp, xazax.hun. njames93 requested review of this revision. Herald added a project: clang. Herald added a subscriber: cfe-commits. Fixes https://bugs.llvm.org/show_bug.cgi?id=49063

[PATCH] D94735: CGDebugInfo CreatedLimitedType: Drop file/line for RecordType with invalid location

2021-02-06 Thread David Blaikie via Phabricator via cfe-commits
dblaikie added a comment. @MaskRay Sounds like this should be reverted (& that revert picked up by the 12 release branch) & some investigation can continue after that? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D94735/new/ https://reviews.llvm.o

[PATCH] D96204: [clangd] Fix clang tidy provider when multiple config files exist in directory tree

2021-02-06 Thread Nathan James via Phabricator via cfe-commits
njames93 added a comment. I have made an extra test case that compares the output of our provider to the output of a `clang::tidy::FileOptionsProvider`, This would ensure coherent behaviour between our implementation and clang-tidy implementation. However I'm not sure it should be included as an

[PATCH] D96203: [clang][patch] Modify sanitizer options names: renaming blacklist to blocklist

2021-02-06 Thread Aaron Ballman via Phabricator via cfe-commits
aaron.ballman added a comment. Thank you for working on this! > This changes the option names that include substring blacklist to blocklist. I think this change works in some places, but in other places we say things like "blocklisted" which feels a bit awkward. I don't super love the name `bl

[PATCH] D96204: [clangd] Fix clang tidy provider when multiple config files exist in directory tree

2021-02-06 Thread Nathan James via Phabricator via cfe-commits
njames93 updated this revision to Diff 321937. njames93 added a comment. Newline at eof. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D96204/new/ https://reviews.llvm.org/D96204 Files: clang-tools-extra/clangd/TidyProvider.cpp clang-tools-extr

[PATCH] D96204: [clangd] Fix clang tidy provider when multiple config files exist in directory tree

2021-02-06 Thread Nathan James via Phabricator via cfe-commits
njames93 created this revision. njames93 added a reviewer: sammccall. Herald added subscribers: usaxena95, kadircet, arphaman, mgorny. njames93 requested review of this revision. Herald added subscribers: cfe-commits, MaskRay, ilya-biryukov. Herald added a project: clang. Currently Clang tidy prov

[PATCH] D96203: [clang][patch] Modify sanitizer options names: renaming blacklist to blocklist

2021-02-06 Thread Melanie Blower via Phabricator via cfe-commits
mibintc created this revision. mibintc added reviewers: Sanitizers, aaron.ballman, echristo, MaskRay. Herald added subscribers: dexonsmith, dang. Herald added a reviewer: jansvoboda11. mibintc requested review of this revision. Herald added a project: clang. This changes the option names that incl

[PATCH] D93800: [clangd] Add caching behaviour for clang-format config

2021-02-06 Thread Nathan James via Phabricator via cfe-commits
njames93 added a comment. Ping? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D93800/new/ https://reviews.llvm.org/D93800 ___ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi

[PATCH] D96147: [SEMA] Added warn_decl_shadow support for structured bindings

2021-02-06 Thread David Crook via Phabricator via cfe-commits
Vexthil updated this revision to Diff 321930. Vexthil added a comment. Fixed the update by doing a full diff rather than just the additive update CHANGES SINCE LAST ACTION https://reviews.llvm.org/D96147/new/ https://reviews.llvm.org/D96147 Files: clang/docs/ReleaseNotes.rst clang/includ