chandlerc accepted this revision.
chandlerc added a reviewer: asbirlea.
chandlerc added a comment.
This revision is now accepted and ready to land.
Adding Alina so she is aware of the change and can comment if she spots
anything I'm missing...
I think this is fine to go in as-is to fix the immed
yonghong-song updated this revision to Diff 223405.
yonghong-song retitled this revision from "[WIP][CLANG][BPF] do compile-once
run-everywhere relocation for bitfields" to "[CLANG][BPF] do compile-once
run-everywhere relocation for bitfields".
yonghong-song edited the summary of this revision.
y
yonghong-song marked an inline comment as done.
yonghong-song added inline comments.
Comment at: llvm/lib/Target/BPF/BPFCORE.h:17
+ enum OffsetRelocKind : uint32_t {
+FIELD_ACCESS_OFFSET = 0,
+FIELD_EXISTENCE,
yonghong-song wrote:
> ast wrote:
> > why AC
yonghong-song added a comment.
> All these names are not added as builtin enum before compilation starts,
> right?
Do you prefer to have builtin enum? If we do this, we will emit this enum all
the time,
regardless of whether people uses this builtin or not. Are you worried about API
stability?
yonghong-song marked 4 inline comments as done and an inline comment as not
done.
yonghong-song added inline comments.
Comment at: llvm/lib/Target/BPF/BPFCORE.h:17
+ enum OffsetRelocKind : uint32_t {
+FIELD_ACCESS_OFFSET = 0,
+FIELD_EXISTENCE,
ast wrote
ast added inline comments.
Comment at: llvm/lib/Target/BPF/BPFCORE.h:17
+ enum OffsetRelocKind : uint32_t {
+FIELD_ACCESS_OFFSET = 0,
+FIELD_EXISTENCE,
why ACCESS_OFFSET is necessary?
Isn't it the same as BYTE_OFFSET but for non-bitfield?
May be single k
joerg added a comment.
I wonder if we should actually enumerate evil here, i.e. give the situations in
which inlining actually fails. As mentioned on IRC, I wonder if we shouldn't
aim for the stronger semantics and at least warn by default of any situation
that prevents always_inline from doing
Daniel599 updated this revision to Diff 223372.
Daniel599 added a comment.
code fixes according to code-review comments
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D68539/new/
https://reviews.llvm.org/D68539
Files:
clang-tools-extra/clang-tidy/
Mordante added a comment.
Thanks for the review. Can you commit the patch since I don't have commit
access?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D65695/new/
https://reviews.llvm.org/D65695
___
cfe-commits mailing list
cfe-commits@l
Mordante added a comment.
Thanks for the review. Can you commit the patch since I don't have commit
access?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D64820/new/
https://reviews.llvm.org/D64820
___
cfe-commits mailing list
cfe-commits@l
Author: rksimon
Date: Sat Oct 5 09:08:17 2019
New Revision: 373831
URL: http://llvm.org/viewvc/llvm-project?rev=373831&view=rev
Log:
Try to fix sphinx indentation error
Modified:
cfe/trunk/docs/ReleaseNotes.rst
Modified: cfe/trunk/docs/ReleaseNotes.rst
URL:
http://llvm.org/viewvc/llvm-proj
Author: rksimon
Date: Sat Oct 5 06:42:14 2019
New Revision: 373829
URL: http://llvm.org/viewvc/llvm-project?rev=373829&view=rev
Log:
RewriteObjC - silence static analyzer getAs<> null dereference warnings. NFCI.
The static analyzer is warning about potential null dereferences, but we should
be
Eugene.Zelenko added inline comments.
Comment at:
clang-tools-extra/clang-tidy/readability/IdentifierNamingCheck.cpp:865
+ auto &Idents = Decl->getASTContext().Idents;
+ auto CheckNewIdentifier = Idents.find(Fixup);
Please don't use auto when type is
Daniel599 created this revision.
Daniel599 added reviewers: llvm-commits, alexfh, alexfh_.
Daniel599 added projects: clang-tools-extra, LLVM.
Herald added a project: clang.
Herald added a subscriber: cfe-commits.
Daniel599 edited the summary of this revision.
This patch fixes 'Bug 41120'
https://b
Author: xbolva00
Date: Sat Oct 5 06:28:15 2019
New Revision: 373828
URL: http://llvm.org/viewvc/llvm-project?rev=373828&view=rev
Log:
[Diagnostics] Highlight expr's source range for -Wbool-operation
Warning message looks better; and GCC adds it too.
Modified:
cfe/trunk/lib/Sema/SemaExpr.cp
Author: rksimon
Date: Sat Oct 5 06:20:51 2019
New Revision: 373825
URL: http://llvm.org/viewvc/llvm-project?rev=373825&view=rev
Log:
Remove redundant !HasDependentValue check. NFCI.
Fixes cppcheck warning.
Modified:
cfe/trunk/lib/Sema/SemaStmt.cpp
Modified: cfe/trunk/lib/Sema/SemaStmt.cpp
Author: rksimon
Date: Sat Oct 5 06:20:59 2019
New Revision: 373826
URL: http://llvm.org/viewvc/llvm-project?rev=373826&view=rev
Log:
TreeTransform - silence static analyzer getAs<> null dereference warnings. NFCI.
The static analyzer is warning about potential null dereferences, but we should
b
Author: rksimon
Date: Sat Oct 5 06:21:08 2019
New Revision: 373827
URL: http://llvm.org/viewvc/llvm-project?rev=373827&view=rev
Log:
SemaTemplate - silence static analyzer getAs<> null dereference warnings. NFCI.
The static analyzer is warning about potential null dereferences, but we should
be
Author: rksimon
Date: Sat Oct 5 06:20:42 2019
New Revision: 373824
URL: http://llvm.org/viewvc/llvm-project?rev=373824&view=rev
Log:
SemaStmt - silence static analyzer getAs<> null dereference warnings. NFCI.
The static analyzer is warning about potential null dereferences, but we should
be abl
MyDeveloperDay added inline comments.
Comment at: clang/lib/Format/TokenAnnotator.cpp:1617
+if (Tok.Next->isOneOf(tok::kw_noexcept, tok::kw_volatile, tok::kw_const,
+ tok::kw_throw, tok::l_square, tok::arrow))
+ return false;
mit
MyDeveloperDay updated this revision to Diff 223369.
MyDeveloperDay marked 2 inline comments as done.
MyDeveloperDay added a comment.
Add additional override and final keywords
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D68481/new/
https://reviews.llvm.org/D68481
Files:
clang/lib/F
echristo added a comment.
The idea was that we'd have a much more graceful error message as well as a way
for the front end to do the diagnosis. The code is being called out of
SemaStmtAsm.cpp and I'm pretty sure we can probably accumulate the target
attributes there?
-eric
CHANGES SINCE LAS
This revision was automatically updated to reflect the committed changes.
Closed by commit rL373821: [clang-format] SpacesInSquareBrackets should affect
lambdas with parameters too (authored by paulhoad, committed by ).
Herald added a project: LLVM.
Herald added a subscriber: llvm-commits.
Change
MyDeveloperDay added inline comments.
Comment at: clang/lib/Format/TokenAnnotator.cpp:2613
+ TT_StructuredBindingLSquare,
+ TT_LambdaLSquare) &&
Style.SpacesInSquareBrackets && Right.isNot(tok::r_square));
-
Author: paulhoad
Date: Sat Oct 5 02:55:23 2019
New Revision: 373821
URL: http://llvm.org/viewvc/llvm-project?rev=373821&view=rev
Log:
[clang-format] SpacesInSquareBrackets should affect lambdas with parameters too
Summary:
This patch makes the `SpacesInSquareBrackets` setting also apply to C++ l
Author: xbolva00
Date: Sat Oct 5 01:09:06 2019
New Revision: 373818
URL: http://llvm.org/viewvc/llvm-project?rev=373818&view=rev
Log:
[NFCI] Slightly improve warning message
Modified:
cfe/trunk/include/clang/Basic/DiagnosticSemaKinds.td
cfe/trunk/test/SemaCXX/warn-xor-as-pow.cpp
Modifi
Author: xbolva00
Date: Sat Oct 5 01:02:11 2019
New Revision: 373817
URL: http://llvm.org/viewvc/llvm-project?rev=373817&view=rev
Log:
[Diagnostics] Use Expr::isKnownToHaveBooleanValue() to check bitwise negation
of bool in languages without a bool type
Thanks for this advice, Richard Trieu!
M
mgorny added a comment.
Got me a while to understand what you're saying. It's all high magic but looks
reasonable enough.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D68520/new/
https://reviews.llvm.org/D68520
_
28 matches
Mail list logo