mgorny added a comment.
In https://reviews.llvm.org/D24903#551890, @rmaprath wrote:
> When the `` headers where split into `` and `` headers in
> https://reviews.llvm.org/D12747, we have left out `` and ``.
> I was going to put up a patch to fix this but couldn't get to it. It's good
> that yo
Author: omtcyfz
Date: Mon Sep 26 01:33:58 2016
New Revision: 282384
URL: http://llvm.org/viewvc/llvm-project?rev=282384&view=rev
Log:
Revert r282382; it had no reference to Revision.
Modified:
clang-tools-extra/trunk/clang-tidy/readability/RedundantSmartptrGetCheck.cpp
clang-tools-extra/
Author: omtcyfz
Date: Mon Sep 26 01:22:54 2016
New Revision: 282382
URL: http://llvm.org/viewvc/llvm-project?rev=282382&view=rev
Log:
[clang-tidy] make readability-redundant-smartptr-get report get() usage in
conditions
This patch extends clang-tidy's readability-redundant-smartptr-get to produc
omtcyfz added a comment.
In https://reviews.llvm.org/D24893#551914, @alexfh wrote:
> Still LG.
Thank you! Landing the patch.
https://reviews.llvm.org/D24893
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mai
Author: compnerd
Date: Sun Sep 25 23:48:22 2016
New Revision: 282379
URL: http://llvm.org/viewvc/llvm-project?rev=282379&view=rev
Log:
Driver: avoid failing in the backend
Avoid failing in the backend when the rewrite map does not exist. Rather check
that the map exists in the frontend before ha
alexfh added a comment.
Still LG.
https://reviews.llvm.org/D24893
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
klimek added inline comments.
Comment at: unittests/ASTMatchers/ASTMatchersTraversalTest.cpp:2119
@@ +2118,3 @@
+ "template \n"
+ "void Function(Namespace::Template param) {\n"
+ " param.Method();\n"
Given your use case: why do we need hasDeclarati
Author: kzhuravl
Date: Sun Sep 25 20:02:57 2016
New Revision: 282371
URL: http://llvm.org/viewvc/llvm-project?rev=282371&view=rev
Log:
[AMDGPU] Expose flat work group size, register and wave control attributes
__attribute__((amdgpu_flat_work_group_size(, ))) - request minimum
and maximum flat wo
This revision was automatically updated to reflect the committed changes.
Closed by commit rL282371: [AMDGPU] Expose flat work group size, register and
wave control attributes (authored by kzhuravl).
Changed prior to commit:
https://reviews.llvm.org/D24513?vs=71970&id=72436#toc
Repository:
r
EricWF added inline comments.
Comment at: include/stdint.h:24
@@ +23,3 @@
+*/
+#if __cplusplus >= 201103L && !defined(__STDC_LIMIT_MACROS)
+# define __STDC_LIMIT_MACROS
Please take a look at how `clang/lib/Headers/stdint.h` handles forwarding this
header, an
rmaprath added a subscriber: rmaprath.
rmaprath added a comment.
When the `` headers where split into `` and `` headers in
https://reviews.llvm.org/D12747, we have left out `` and ``. I
was going to put up a patch to fix this but couldn't get to it. It's good that
you are adding ``, perhaps you
EricWF added reviewers: mclow.lists, rsmith.
EricWF added subscribers: mclow.lists, rsmith.
EricWF added a comment.
Adding reviewers @mclow.lists and @rsmith since he originally wrote the C
wrappers.
https://reviews.llvm.org/D24903
___
cfe-commits
mgorny created this revision.
mgorny added a reviewer: EricWF.
mgorny added a subscriber: cfe-commits.
Declare __STDC_FORMAT_MACROS, __STDC_LIMIT_MACROS and __STDC_CONSTANT_MACROS
before including real inttypes.h/stdint.h when the wrapper-header is included
in C++11, in order to enable the neces
NewProggie added a comment.
In https://reviews.llvm.org/D24791#551662, @omtcyfz wrote:
> @NewProggie do you have commit access or do you want me to land this patch
> for you?
I don't have commit access. Please, land it for me. Glad, you've accepted my
patch.
https://reviews.llvm.org/D24791
zizhar added a comment.
Hello :)
I will prepare another patch as you suggested,
is this patch good?
Can it be submitted?
Ziv
https://reviews.llvm.org/D15075
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mai
NoQ marked an inline comment as done.
NoQ added a comment.
Ouch, seems inline answers don't automatically post themselves when you update
the diff :o
Comment at: lib/StaticAnalyzer/Checkers/BoolConversionChecker.cpp:62
@@ +61,3 @@
+ << "' to a plain boolean value: probabl
omtcyfz updated this revision to Diff 72422.
omtcyfz marked an inline comment as done.
omtcyfz added a comment.
Replace `anyOf(hasName("..."), hasName("..."))` with `hasAnyName("...", "...")`.
https://reviews.llvm.org/D24893
Files:
clang-tidy/readability/RedundantSmartptrGetCheck.cpp
test/c
Author: ericwf
Date: Sun Sep 25 03:30:05 2016
New Revision: 282352
URL: http://llvm.org/viewvc/llvm-project?rev=282352&view=rev
Log:
Update -verify test to use new static assert message
Modified:
libcxx/trunk/test/std/containers/sequences/array/array.tuple/get.fail.cpp
Modified:
libcxx/trun
18 matches
Mail list logo