Hi @EricWD, @mclow.lists,
Thanks for the comments.
I will discuss this downstream a bit and get back. What I don't want to do
is deviate too much from upstream in terms of expectations. We may have to
shed some of our old expectations with libc++, I wanted to first clarify
upstream position on th
Renato, I remember you saying you worked around the bot problem by making
the build dir a symlink. Maybe stuff gets confused by that setup? Symlink
build dirs tend to cause trouble.
On Sep 5, 2016 8:11 PM, "Craig Topper via cfe-commits" <
cfe-commits@lists.llvm.org> wrote:
> This error makes even
This error makes even less sense. Nothing about __builtin_ia32_selectd_512
requires a constant integer.
/home/linaro/buildbot/clang-cmake-thumbv7-a15/stage1/bin/../lib/clang/4.0.0/include/avx512fintrin.h:223:19:
error: argument to '__builtin_ia32_selectd_512' must be a constant
integer
return (_
On 6 September 2016 at 00:27, Craig Topper wrote:
> This failure doesn't make sense. It's acting like the test was updated for
> r280596, but not the intrinsic header or the clang binary. That's the only
> way I can think that the output IR could contain
> @llvm.x86.avx512.mask.padd.b.256.
Hi Cra
majnemer accepted this revision.
majnemer added a comment.
This revision is now accepted and ready to land.
LGTM
https://reviews.llvm.org/D23503
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/c
This failure doesn't make sense. It's acting like the test was updated for
r280596, but not the intrinsic header or the clang binary. That's the only
way I can think that the output IR could contain
@llvm.x86.avx512.mask.padd.b.256.
/home/linaro/buildbot/clang-cmake-armv7-a15-full/llvm/tools/clang
On 3 September 2016 at 20:19, Craig Topper via cfe-commits
wrote:
> Author: ctopper
> Date: Sat Sep 3 14:19:49 2016
> New Revision: 280597
>
> URL: http://llvm.org/viewvc/llvm-project?rev=280597&view=rev
> Log:
> [AVX-512] Remove masked integer mullo builtins and replace with native IR.
>
> Modif
zdtorok marked 8 inline comments as done.
zdtorok added a comment.
Thank you for both of your comments and feedbacks! Also please forgive me for
my (really) late response. Please have a look at my fixes and the new attached
diff. Thanks!
Comment at: lib/StaticAnalyzer/Checkers
zdtorok removed rL LLVM as the repository for this revision.
zdtorok updated this revision to Diff 70345.
zdtorok marked an inline comment as done.
zdtorok added a comment.
Fixed based on the provided comments and feedbacks.
- added new inter-procedural tests
- minor styling fix (trailing whitesp
EricWF added a comment.
In https://reviews.llvm.org/D23926#531226, @rmaprath wrote:
> Simplified the patch a little bit more.
>
> Now, library vendors should be able to define
> `_LIBCPP_STRICT_C99_COMPATIBILITY` and `libc++` will not use/test C99 math
> functions in `C++03/98` modes. Currently
Author: ed
Date: Mon Sep 5 13:38:34 2016
New Revision: 280672
URL: http://llvm.org/viewvc/llvm-project?rev=280672&view=rev
Log:
Add support for targeting armv6-unknown-cloudabi-eabihf.
I'm in the progress of adding ARMv6 support to CloudABI. On the compiler
side, everything seems to work properl
Pajesz marked 12 inline comments as done.
Pajesz added a comment.
so i have to submit K good to know
Comment at: test/clang-tidy/readability-misleading-indentation.cpp:48
@@ +47,3 @@
+ }
+ foo2(); // ok
+
nlewycky wrote:
> This is arguably misleading ind
Anastasia requested changes to this revision.
Anastasia added a comment.
This revision now requires changes to proceed.
Have you done any investigation regarding the compilation speed as this change
adds expensive container lookups for all OpenCL declarations and function calls.
It would be nice
Author: dim
Date: Mon Sep 5 13:01:13 2016
New Revision: 280669
URL: http://llvm.org/viewvc/llvm-project?rev=280669&view=rev
Log:
Add missing _US_ACTION_MASK constant to unwind.h
Summary:
During building of recent compiler-rt sources on FreeBSD for arm, I
noticed that our unwind.h (which originat
sisnkemp added a comment.
Ping?
https://reviews.llvm.org/D22130
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
vmiklos added a comment.
Sure, I have no problems merging rename-all and rename-at, I added it as it
looked like a good idea at that time.
https://reviews.llvm.org/D24224
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org
Anastasia accepted this revision.
Anastasia added a comment.
LGTM!
https://reviews.llvm.org/D23915
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Anastasia added inline comments.
Comment at: test/CodeGenOpenCL/pipe_builtin.cl:64
@@ +63,3 @@
+void test8(read_only pipe int r, write_only pipe int w, global int *ptr) {
+ // verify that return type is correctly casted to i1 value
+ // CHECK: %[[R:[0-9]+]] = call i32 @__read_pi
Anastasia added a comment.
Could we add a CodeGen test as well to check that the constants generated are
in the right precision format?
https://reviews.llvm.org/D24235
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cg
Anastasia added inline comments.
Comment at: lib/CodeGen/CGOpenCLRuntime.cpp:97
@@ +96,3 @@
+ return llvm::ConstantInt::get(Int32Ty,
+TypeSizeInBits / 8, // Size in bytes.
+false);
Perhaps it's safer
neil.hickey created this revision.
neil.hickey added a reviewer: Anastasia.
neil.hickey added a subscriber: cfe-commits.
Improve handling of floating point literals to only use double precision if it
is supported.
https://reviews.llvm.org/D24235
Files:
lib/Sema/SemaExpr.cpp
lib/Sema/SemaTyp
szepet updated this revision to Diff 70324.
szepet marked 4 inline comments as done.
szepet added a comment.
cast to dyn-cast change in order to fix a bug, changes based on comments
https://reviews.llvm.org/D22507
Files:
clang-tidy/misc/CMakeLists.txt
clang-tidy/misc/EnumMisuseCheck.cpp
c
pgousseau added a comment.
Ping!
https://reviews.llvm.org/D23503
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
delena added inline comments.
Comment at: lib/Headers/avx512fintrin.h:9337
@@ +9336,3 @@
+{
+ return (__m128) _mm_move_ss( __A, __builtin_ia32_selectps_128 ((__mmask8)
__U,
+ (__v4sf) __B,
selectps
I'll fix this.
Vladimir
---
From: *Akira Hatanaka*
Date: Fri, Sep 2, 2016 at 3:00 AM
Subject: Re: [PATCH] D21678: Fix For pr28288 - Error message in shift of
vector values
To: vladimi...@gmail.com, ulrich.weig...@
Author: chapuni
Date: Mon Sep 5 08:14:54 2016
New Revision: 280659
URL: http://llvm.org/viewvc/llvm-project?rev=280659&view=rev
Log:
clang/test/Modules/compiler_builtins_x86.c: Fix r280658.
Modified:
cfe/trunk/test/Modules/compiler_builtins_x86.c
Modified: cfe/trunk/test/Modules/compiler_bu
halyavin added a comment.
False alarm. I figured out that only -Wattributes warnings ignore gcc
system_header pragma. So this -Wcast-qual and other warnings doesn't block us.
https://reviews.llvm.org/D23831
___
cfe-commits mailing list
cfe-commits@
Hi Elad,
This commit broke all buildbots that don't default to targetting x86. I've
committed a fix with r280658, but could you please double check it's
correct.
Cheers,
James
On Sun, 4 Sep 2016 at 07:09 Elad Cohen via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Author: eladcohen
> Date
Author: jamesm
Date: Mon Sep 5 07:28:49 2016
New Revision: 280658
URL: http://llvm.org/viewvc/llvm-project?rev=280658&view=rev
Log:
Attempt to fix buildbots not targetting x86
r280613 introduced failures for all builds that don't target x86 by default.
Add an explicit target to avoid a missing
omtcyfz added inline comments.
Comment at: change-namespace/ChangeNamespace.cpp:480
@@ +479,3 @@
+Replaces = Replaces.merge(NewReplacements);
+format::FormatStyle Style = format::getStyle("file", FilePath, "google");
+// Clean up old namespaces if there is nothing in i
m_zuckerman updated this revision to Diff 70318.
https://reviews.llvm.org/D21505
Files:
lib/Headers/avx512fintrin.h
test/CodeGen/avx512f-builtins.c
Index: test/CodeGen/avx512f-builtins.c
===
--- test/CodeGen/avx512f-builtins.c
+
m_zuckerman marked an inline comment as done.
m_zuckerman added a comment.
https://reviews.llvm.org/D21505
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: omtcyfz
Date: Mon Sep 5 04:42:02 2016
New Revision: 280653
URL: http://llvm.org/viewvc/llvm-project?rev=280653&view=rev
Log:
[clang-rename] Add comment after namespace closing
Modified:
clang-tools-extra/trunk/clang-rename/RenamingAction.h
Modified: clang-tools-extra/trunk/clang-ren
omtcyfz added inline comments.
Comment at: change-namespace/ChangeNamespace.cpp:480
@@ +479,3 @@
+Replaces = Replaces.merge(NewReplacements);
+format::FormatStyle Style = format::getStyle("file", FilePath, "google");
+// Clean up old namespaces if there is nothing in i
ioeric added inline comments.
Comment at: change-namespace/ChangeNamespace.cpp:22
@@ +21,3 @@
+ (void)NS.ltrim(':');
+ return NS.str();
+}
Yes, it is added to please `LLVM_ATTRIBUTE_UNUSED_RESULT` of
`llvm::StringRef::ltrim`.
Comment at: chan
ioeric updated this revision to Diff 70308.
ioeric marked 4 inline comments as done.
ioeric added a comment.
- Addressed review comments.
https://reviews.llvm.org/D24183
Files:
CMakeLists.txt
change-namespace/CMakeLists.txt
change-namespace/ChangeNamespace.cpp
change-namespace/ChangeNam
36 matches
Mail list logo