Add support for PKGLIBDIR, PKGINCLUDEDIR, PKGDATADIR to configmake

2006-09-15 Thread Paul Eggert
For Bison, I installed the following to add support for Automake-supplied variables to configmake. The javaversion module can now be simplified a bit, by adding a dependency on configmake, so that its 'make' output is made a bit shorter. 2006-09-15 Paul Eggert <[EMAIL PROTECTED]> * mod

Re: bug fix: mv and 'cp -r' no longer fail when ...

2006-09-15 Thread Jim Meyering
Bruno Haible <[EMAIL PROTECTED]> wrote: > Jim Meyering wrote: ... > then shouldn't the first test be this? > > if (len <= FILE_SYSTEM_PREFIX_LEN (file) + 1) >return false; Yes, that is better: more efficient on non-POSIX systems. Thanks. >> + { >> +/* Fail now, unless SRC is a d

Re: [bug-gnulib] bug fix: mv and 'cp -r' no longer fail when ...

2006-09-15 Thread Bruno Haible
Hi, Jim Meyering wrote: > +static inline bool > +has_trailing_slash (char const *file, size_t len) > +{ > + /* Don't count "/" as having a trailing slash. */ > + if (len <= 1) > +return false; > + > + char last = file[len - 1]; > + return ISSLASH (last); Since you use ISSLASH, you appare

speed up gnulib-tool a bit

2006-09-15 Thread Ralf Wildenhues
Hello Bruno, all, For some invocations, gnulib-tool is rather slow[1], which impacts productivity a bit. The following tries to improve things without sacrificing portability, while hopefully it doesn't compromise readability. ;-) First, `sort -u' is already used in gnulib-tool, so it would see

FYI: regex_internal.c: avoid a warning

2006-09-15 Thread Jim Meyering
Since this file is already different from libc, this shouldn't hurt... 2006-09-15 Jim Meyering <[EMAIL PROTECTED]> Avoid a warning about an unused variable. * regex_internal.c (re_dfa_add_node): Move declaration of "type" into the #ifdef block where it's used. Index: re

Re: bug fix: mv and 'cp -r' no longer fail when ...

2006-09-15 Thread Jim Meyering
GNU mv, with changes in the upcoming coreutils-6.2, had the portability problem outlined in I've fixed it with the following additions to gnulib: [ChangeLog] * modules/rename-dest-slash: New module. * MO

Re: ensure that generated files are read-only

2006-09-15 Thread Jim Meyering
Paul Eggert <[EMAIL PROTECTED]> wrote: > Jim Meyering <[EMAIL PROTECTED]> writes: > >> aren't the warning and possible annoyance at least a little more >> appropriate for the build-generated files whose rules I was proposing >> to change in gnulib? > > I suppose so, yes. > > Isn't this a generic pr

Re: [bug-gnulib] removed many uses of HAVE_CONFIG_H from gnulib

2006-09-15 Thread Ralf Wildenhues
Hello Bruno, * Bruno Haible wrote on Fri, Sep 15, 2006 at 02:31:22PM CEST: > Ralf Wildenhues wrote: > > CVS Libtool's libltdl allows third-party user code to decide over the > > naming of the config header file it may share with it (and whether to > > use one) > The only project I know of which u

Re: [bug-gnulib] Question concerning c-ctype, c-strcase, c-strcasestr and c-strstr modules

2006-09-15 Thread Bruno Haible
Yoann Vandoorselaere wrote: > The c-ctype, c-strcase, c-strcasestr and c-strstr modules seem only to > implement their replacement functions using a "c_" prefix. > > However, there is no autoconf test implemented by these modules that > redefine the original function (in case it is missing) to po

Re: [bug-gnulib] removed many uses of HAVE_CONFIG_H from gnulib

2006-09-15 Thread Bruno Haible
Ralf Wildenhues wrote: > CVS Libtool's libltdl allows third-party user code to decide over the > naming of the config header file it may share with it (and whether to > use one) Gettextize doesn't allow this choice, when including intl/ as a subdirectory, and I'm not aware that anybody complained

Re: Question concerning c-ctype, c-strcase, c-strcasestr and c-strstr modules

2006-09-15 Thread Eric Blake
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 According to Yoann Vandoorselaere on 9/15/2006 5:40 AM: > > I recall platform missing strcasestr, although I can't remember which. > Anyway, what's the purpose of these modules if they are not used > anywhere ? The c_* modules ARE used, particularly

Re: Question concerning c-ctype, c-strcase, c-strcasestr and c-strstr modules

2006-09-15 Thread Yoann Vandoorselaere
On Fri, 2006-09-15 at 05:35 -0600, Eric Blake wrote: > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA1 > > According to Yoann Vandoorselaere on 9/15/2006 5:29 AM: > > Hi, > > > > The c-ctype, c-strcase, c-strcasestr and c-strstr modules seem only to > > implement their replacement functions using

Re: Question concerning c-ctype, c-strcase, c-strcasestr and c-strstr modules

2006-09-15 Thread Eric Blake
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 According to Yoann Vandoorselaere on 9/15/2006 5:29 AM: > Hi, > > The c-ctype, c-strcase, c-strcasestr and c-strstr modules seem only to > implement their replacement functions using a "c_" prefix. > > However, there is no autoconf test implemented

Question concerning c-ctype, c-strcase, c-strcasestr and c-strstr modules

2006-09-15 Thread Yoann Vandoorselaere
Hi, The c-ctype, c-strcase, c-strcasestr and c-strstr modules seem only to implement their replacement functions using a "c_" prefix. However, there is no autoconf test implemented by these modules that redefine the original function (in case it is missing) to point to their GnuLib replacement.

FYI: rename macro renamed

2006-09-15 Thread Jim Meyering
I noticed a non-gl_-prefixed name and fixed it. [ChangeLog] * modules/rename: Reflect vb_FUNC_RENAME -> gl_FUNC_RENAME change. [m4/ChangeLog] * rename.m4 (gl_FUNC_RENAME): Rename from vb_FUNC_RENAME. Index: modules/rename ===