[Lldb-commits] [lldb] r259344 - Set correct ThreadStopInfo in case of trace event

2016-02-01 Thread Abhishek Aggarwal via lldb-commits
Author: abhishek Date: Mon Feb 1 03:01:42 2016 New Revision: 259344 URL: http://llvm.org/viewvc/llvm-project?rev=259344&view=rev Log: Set correct ThreadStopInfo in case of trace event Summary: - The patch solves Bug 23478 and Bug 19311. Resolving Bug 23478 also resolves Bug 23039. Corr

Re: [Lldb-commits] [lldb] r258919 - [LLDB][MIPS] A small fix in GetBreakableLoadAddress() for MIPS

2016-02-01 Thread Bhushan Attarde via lldb-commits
Hi Hans, Could you please add this (r258919) to the release branch? Also commit r258967 (on top of this) by Zachary which fixes some python 3 incompatibilities. Thanks, Bhushan -Original Message- From: lldb-commits [mailto:lldb-commits-boun...@lists.llvm.org] On Behalf Of Bhushan D. At

Re: [Lldb-commits] [PATCH] D16741: Make many of the skip decorators use common code

2016-02-01 Thread Pavel Labath via lldb-commits
labath added a comment. I am confused as to how could this even work, since all your decorators seem to be ignoring the function they are decorating. I'm pretty sure this is going to cause some very weird things to happen things to come out of the decoration process, which might explain your co

[Lldb-commits] [PATCH] D16766: [RenderScript] Use LLVM DWARF language enum

2016-02-01 Thread Ewan Crawford via lldb-commits
EwanCrawford created this revision. EwanCrawford added a reviewer: clayborg. EwanCrawford added a subscriber: lldb-commits. EwanCrawford set the repository for this revision to rL LLVM. A DWARF language vender extension for RenderScript was added to LLVM in r259348(http://reviews.llvm.org/D16409)

[Lldb-commits] [PATCH] D16767: Fix single-stepping onto a breakpoint

2016-02-01 Thread Pavel Labath via lldb-commits
labath created this revision. labath added reviewers: tberghammer, emaste. labath added subscribers: lldb-commits, abhishek.aggarwal. Herald added a subscriber: emaste. r259344 introduced a bug, where we fail to perform a single step, when the instruction we are stepping onto contains a breakpoin

Re: [Lldb-commits] [PATCH] D16736: Always write the session log file in UTF-8

2016-02-01 Thread Pavel Labath via lldb-commits
labath added a comment. TestGDBRemoteMemoryRead.py is my test and I gotta admit it is somewhat hackish. If this is the only issue that is stopping this from going through, then please xfail it, and i'll rewrite it in some other way. http://reviews.llvm.org/D16736 ___

Re: [Lldb-commits] [PATCH] D16722: Remove Timer::Initialize routine

2016-02-01 Thread Pavel Labath via lldb-commits
labath added a comment. We are still using VS2013 at the moment, but we have started to investigate the possibility of migrating to 2015. I can report back when I know more, but I would leave the thread_local keyword out for now. http://reviews.llvm.org/D16722 __

Re: [Lldb-commits] [PATCH] D16767: Fix single-stepping onto a breakpoint

2016-02-01 Thread Tamas Berghammer via lldb-commits
tberghammer accepted this revision. tberghammer added a comment. This revision is now accepted and ready to land. Looks reasonable but should we merge TestSingleStepOntoBreakpoint.py and TestConsecutiveBreakpoints.py? I think they have quite a bit of code in common. http://reviews.llvm.org/D167

[Lldb-commits] [lldb] r259356 - Remove Timer::Initialize routine

2016-02-01 Thread Pavel Labath via lldb-commits
Author: labath Date: Mon Feb 1 07:29:41 2016 New Revision: 259356 URL: http://llvm.org/viewvc/llvm-project?rev=259356&view=rev Log: Remove Timer::Initialize routine Summary: I've run into an issue when running unit tests, where the underlying problem turned out to be that we were creating Timer

Re: [Lldb-commits] [PATCH] D16722: Remove Timer::Initialize routine

2016-02-01 Thread Pavel Labath via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL259356: Remove Timer::Initialize routine (authored by labath). Changed prior to commit: http://reviews.llvm.org/D16722?vs=46380&id=46524#toc Repository: rL LLVM http://reviews.llvm.org/D16722 Files

Re: [Lldb-commits] [PATCH] D16767: Fix single-stepping onto a breakpoint

2016-02-01 Thread Abhishek via lldb-commits
abhishek.aggarwal added a comment. source/Plugins/Process/FreeBSD/FreeBSDThread.cpp will not compile for FreeBSD. In Line 576, bp_id is undefined. Please replace it with bp_site_sp->GetID() http://reviews.llvm.org/D16767 ___ lldb-commits mailing li

Re: [Lldb-commits] [PATCH] D16767: Fix single-stepping onto a breakpoint

2016-02-01 Thread Pavel Labath via lldb-commits
labath updated this revision to Diff 46528. labath added a comment. Merged test cases, and updated the FreeBSD version. Please take another look. http://reviews.llvm.org/D16767 Files: packages/Python/lldbsuite/test/functionalities/breakpoint/consecutive_breakpoints/TestConsecutiveBreakpoints

Re: [Lldb-commits] [PATCH] D16736: Always write the session log file in UTF-8

2016-02-01 Thread Todd Fiala via lldb-commits
Just that x command needs to be commented out. The m command is fine as is. -Todd > On Feb 1, 2016, at 5:03 AM, Pavel Labath wrote: > > labath added a comment. > > TestGDBRemoteMemoryRead.py is my test and I gotta admit it is somewhat > hackish. If this is the only issue that is stopping this

[Lldb-commits] [PATCH] D16769: [NFC] Cleanup RangeMap.h

2016-02-01 Thread Tamas Berghammer via lldb-commits
tberghammer created this revision. tberghammer added reviewers: clayborg, labath. tberghammer added a subscriber: lldb-commits. [NFC] Cleanup RangeMap.h The file contained very similar 4 implementation of the same data structure with a lot of duplicated code and some minor API differences. This C

Re: [Lldb-commits] [PATCH] D16736: Always write the session log file in UTF-8

2016-02-01 Thread Todd Fiala via lldb-commits
tfiala added a subscriber: tfiala. tfiala added a comment. Just that x command needs to be commented out. The m command is fine as is. -Todd http://reviews.llvm.org/D16736 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.

[Lldb-commits] [PATCH] D16772: Fix single stepping over the IT instruction

2016-02-01 Thread Tamas Berghammer via lldb-commits
tberghammer created this revision. tberghammer added reviewers: omjavaid, clayborg. tberghammer added a subscriber: lldb-commits. Herald added a subscriber: aemerson. Fix single stepping over the IT instruction The ARM instruction emulator had 2 bugs related to the handling of the IT instruction

[Lldb-commits] [lldb] r259368 - Remove flaky annotation for TestCallWithTimeout on linux

2016-02-01 Thread Pavel Labath via lldb-commits
Author: labath Date: Mon Feb 1 10:50:28 2016 New Revision: 259368 URL: http://llvm.org/viewvc/llvm-project?rev=259368&view=rev Log: Remove flaky annotation for TestCallWithTimeout on linux The test has passed last 100 runs of the buildbot. Modified: lldb/trunk/packages/Python/lldbsuite/tes

Re: [Lldb-commits] [lldb] r258919 - [LLDB][MIPS] A small fix in GetBreakableLoadAddress() for MIPS

2016-02-01 Thread Hans Wennborg via lldb-commits
On Mon, Feb 1, 2016 at 2:37 AM, Bhushan Attarde wrote: > Hi Hans, > > Could you please add this (r258919) to the release branch? > Also commit r258967 (on top of this) by Zachary which fixes some python 3 > incompatibilities. Since this touched more than just MIPS-specific files, I'd like Greg t

Re: [Lldb-commits] [PATCH] D16746: Use an artifical namespace so that member vars do not hide local vars.

2016-02-01 Thread Greg Clayton via lldb-commits
clayborg accepted this revision. clayborg added a comment. This revision is now accepted and ready to land. Looks good to me, but Sean should be the one to OK this for real. http://reviews.llvm.org/D16746 ___ lldb-commits mailing list lldb-commits@l

Re: [Lldb-commits] [PATCH] D16745: Fix a thinko in StackFrame::GetInScopeVariableList.

2016-02-01 Thread Greg Clayton via lldb-commits
clayborg accepted this revision. clayborg added a comment. This revision is now accepted and ready to land. Looks good. http://reviews.llvm.org/D16745 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/li

Re: [Lldb-commits] [PATCH] D16508: NetBSD: Define initial RegisterContextNetBSD_x86_64

2016-02-01 Thread Greg Clayton via lldb-commits
clayborg accepted this revision. clayborg added a comment. This revision is now accepted and ready to land. Looks good. Repository: rL LLVM http://reviews.llvm.org/D16508 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm

[Lldb-commits] [lldb] r259379 - Always write the session file in UTF-8.

2016-02-01 Thread Zachary Turner via lldb-commits
Author: zturner Date: Mon Feb 1 12:12:59 2016 New Revision: 259379 URL: http://llvm.org/viewvc/llvm-project?rev=259379&view=rev Log: Always write the session file in UTF-8. This patch attempts to solve the Python 2 / Python 3 incompatibilities by introducing a new `encoded_file` abstraction that

[Lldb-commits] [lldb] r259378 - Fix misnamed variable in TestProcessAPI.py

2016-02-01 Thread Zachary Turner via lldb-commits
Author: zturner Date: Mon Feb 1 12:12:54 2016 New Revision: 259378 URL: http://llvm.org/viewvc/llvm-project?rev=259378&view=rev Log: Fix misnamed variable in TestProcessAPI.py Modified: lldb/trunk/packages/Python/lldbsuite/test/python_api/process/TestProcessAPI.py Modified: lldb/trunk/pac

Re: [Lldb-commits] [PATCH] D16736: Always write the session log file in UTF-8

2016-02-01 Thread Zachary Turner via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL259379: Always write the session file in UTF-8. (authored by zturner). Changed prior to commit: http://reviews.llvm.org/D16736?vs=46426&id=46556#toc Repository: rL LLVM http://reviews.llvm.org/D1673

Re: [Lldb-commits] [PATCH] D16746: Use an artifical namespace so that member vars do not hide local vars.

2016-02-01 Thread Sean Callanan via lldb-commits
spyffe requested changes to this revision. spyffe added a comment. This revision now requires changes to proceed. Siva, this is a clever and self-contained solution to a problem that's annoyed us a great deal for a while now. I have a few minor quibbles about implementation but overall this is

Re: [Lldb-commits] [PATCH] D16508: NetBSD: Define initial RegisterContextNetBSD_x86_64

2016-02-01 Thread Todd Fiala via lldb-commits
tfiala accepted this revision. tfiala added a comment. Seems reasonable to start. If there are issues, they'll show up when lldb starts using registers. This will get you started, though. Repository: rL LLVM http://reviews.llvm.org/D16508 ___

Re: [Lldb-commits] [PATCH] D16769: [NFC] Cleanup RangeMap.h

2016-02-01 Thread Greg Clayton via lldb-commits
clayborg accepted this revision. clayborg added a comment. This revision is now accepted and ready to land. Looks fine. A few things I don't like, but I can live with: - Making constructors appear all on one line does save space, but it means you can't debug very well as stepping into these cons

Re: [Lldb-commits] [PATCH] D16772: Fix single stepping over the IT instruction

2016-02-01 Thread Greg Clayton via lldb-commits
clayborg added a comment. Looks good. A related comment about IT instructions. You need to be careful when software single stepping through instructions that are in the middle of an ITSTATE block. You can NOT use a 16 bit instruction that isn't a BKPT otherwise you change your instructions. Ar

Re: [Lldb-commits] [PATCH] D16766: [RenderScript] Use LLVM DWARF language enum

2016-02-01 Thread Greg Clayton via lldb-commits
clayborg added a comment. See inlined comments. Comment at: source/Target/Language.cpp:272 @@ -271,2 +271,3 @@ case eLanguageTypeC11: +case eLanguageTypeExtRenderScript: return true; Why is this needed? Seems like this is incorrect.

[Lldb-commits] [lldb] r259396 - Add a note on how to create an empty target and use it to attach to

2016-02-01 Thread Jim Ingham via lldb-commits
Author: jingham Date: Mon Feb 1 14:05:37 2016 New Revision: 259396 URL: http://llvm.org/viewvc/llvm-project?rev=259396&view=rev Log: Add a note on how to create an empty target and use it to attach to processes whose executables you don't know up front. Modified: lldb/trunk/scripts/interface

Re: [Lldb-commits] [PATCH] D16772: Fix single stepping over the IT instruction

2016-02-01 Thread Muhammad Omair Javaid via lldb-commits
omjavaid accepted this revision. omjavaid added a comment. Looks good. Was there a test failing in testsuite due to this? http://reviews.llvm.org/D16772 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/

Re: [Lldb-commits] [lldb] r257926 - Implement missing GoASTContext methods

2016-02-01 Thread Hans Wennborg via lldb-commits
Greg: ping? On Tue, Jan 26, 2016 at 11:10 AM, Hans Wennborg wrote: > Greg: Ping? > > On Tue, Jan 19, 2016 at 1:12 PM, Hans Wennborg wrote: >> Sure. Greg, are you the code owner for this, or is there a specific >> owner for Go? >> >> Thanks, >> Hans >> >> On Fri, Jan 15, 2016 at 11:43 AM, Ryan Br

Re: [Lldb-commits] [lldb] r258485 - Use "_$" prefix instead of "$" for dynamic checker function inserted by LLDB during expression evaluation

2016-02-01 Thread Hans Wennborg via lldb-commits
Greg: ping? On Mon, Jan 25, 2016 at 11:40 AM, Hans Wennborg wrote: > SGTM if Greg approves. > > On Mon, Jan 25, 2016 at 2:03 AM, Bhushan Attarde > wrote: >> Could you please add this to the release branch? >> >> Thanks, >> Bhushan >> >> >> -Original Message- >> From: lldb-commits [mailto

Re: [Lldb-commits] [lldb] r257926 - Implement missing GoASTContext methods

2016-02-01 Thread Greg Clayton via lldb-commits
Sorry for the delay. This is fine. In general, feel free to accept any patches that are architecture specific for architectures that aren't x86 or ARM (MIPS, hexagon for example), and for any languages that aren't C/C++/ObjC or Swift (renderscript, go). > On Feb 1, 2016, at 1:49 PM, Hans Wenn

Re: [Lldb-commits] [lldb] r257926 - Implement missing GoASTContext methods

2016-02-01 Thread Hans Wennborg via lldb-commits
Thanks! r259423. On Mon, Feb 1, 2016 at 2:19 PM, Greg Clayton wrote: > Sorry for the delay. This is fine. > > In general, feel free to accept any patches that are architecture specific > for architectures that aren't x86 or ARM (MIPS, hexagon for example), and for > any languages that aren't C/

[Lldb-commits] LLVM buildmaster will be restarted tonight

2016-02-01 Thread Galina Kistanova via lldb-commits
Hello everyone, LLVM buildmaster will be updated and restarted after 7 PM Pacific time today. Thanks Galina ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

[Lldb-commits] [lldb] r259433 - Fix getCompiler in unit testing framework on compiler symlinks

2016-02-01 Thread Stephane Sezer via lldb-commits
Author: sas Date: Mon Feb 1 17:21:27 2016 New Revision: 259433 URL: http://llvm.org/viewvc/llvm-project?rev=259433&view=rev Log: Fix getCompiler in unit testing framework on compiler symlinks Summary: Checks using the result of getCompiler() will fail to identify the compiler correctly if CC is

Re: [Lldb-commits] [PATCH] D16508: NetBSD: Define initial RegisterContextNetBSD_x86_64

2016-02-01 Thread Kamil Rytarowski via lldb-commits
krytarowski added a comment. Thank you very much! You made this patch possible. Repository: rL LLVM http://reviews.llvm.org/D16508 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commi

Re: [Lldb-commits] [PATCH] D16741: Make many of the skip decorators use common code

2016-02-01 Thread Zachary Turner via lldb-commits
zturner marked an inline comment as done. Comment at: packages/Python/lldbsuite/test/lldbtest.py:560 @@ -559,3 +559,1 @@ """Decorate the item as a debugserver test.""" -if isinstance(func, type) and issubclass(func, unittest2.TestCase): -raise Exception("@debugser

Re: [Lldb-commits] [PATCH] D16741: Make many of the skip decorators use common code

2016-02-01 Thread Zachary Turner via lldb-commits
zturner marked an inline comment as done. zturner added a comment. I guess we need to be consistent. Do we want to be able to decorate entire classes, or not? If we do, then we should remove the check. If we don't then we should leave the check. But since many tests are already using these

[Lldb-commits] [lldb] r259443 - We try to avoid static objects. These are on the error path for unsupported features

2016-02-01 Thread Jim Ingham via lldb-commits
Author: jingham Date: Mon Feb 1 18:21:39 2016 New Revision: 259443 URL: http://llvm.org/viewvc/llvm-project?rev=259443&view=rev Log: We try to avoid static objects. These are on the error path for unsupported features in the socket, so just returning freshly constructed objects is fine. Modifi

Re: [Lldb-commits] [PATCH] D16767: Fix single-stepping onto a breakpoint

2016-02-01 Thread Adrian McCarthy via lldb-commits
amccarth added a subscriber: amccarth. amccarth added a comment. I was chasing this same bug on Windows before I noticed you were working on it. I patched in your latest diff, and the problem still occurs. In fact, now I get two failures: >

Re: [Lldb-commits] [PATCH] D16741: Make many of the skip decorators use common code

2016-02-01 Thread Zachary Turner via lldb-commits
zturner updated this revision to Diff 46599. zturner added a comment. Herald added subscribers: srhines, danalbert, tberghammer. I think this should fix most of the issues. A few of the decorators I wasn't able to touch because of the issues with class-level decorators. But I think this is a g

Re: [Lldb-commits] [PATCH] D16741: Make many of the skip decorators use common code

2016-02-01 Thread Todd Fiala via lldb-commits
tfiala added a subscriber: tfiala. tfiala added a comment. I'll see if I can run this tonight. If not tonight, I'll do it first thing in the morning. http://reviews.llvm.org/D16741 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://l

Re: [Lldb-commits] [PATCH] D16741: Make many of the skip decorators use common code

2016-02-01 Thread Todd Fiala via lldb-commits
I'll see if I can run this tonight. If not tonight, I'll do it first thing in the morning. On Mon, Feb 1, 2016 at 5:17 PM, Zachary Turner wrote: > zturner updated this revision to Diff 46599. > zturner added a comment. > Herald added subscribers: srhines, danalbert, tberghammer. > > I think th

Re: [Lldb-commits] [PATCH] D16508: NetBSD: Define initial RegisterContextNetBSD_x86_64

2016-02-01 Thread Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL259462: NetBSD: Define initial RegisterContextNetBSD_x86_64 (authored by kamil). Changed prior to commit: http://reviews.llvm.org/D16508?vs=46489&id=46610#toc Repository: rL LLVM http://reviews.llvm

[Lldb-commits] [lldb] r259462 - NetBSD: Define initial RegisterContextNetBSD_x86_64

2016-02-01 Thread Kamil Rytarowski via lldb-commits
Author: kamil Date: Mon Feb 1 21:47:44 2016 New Revision: 259462 URL: http://llvm.org/viewvc/llvm-project?rev=259462&view=rev Log: NetBSD: Define initial RegisterContextNetBSD_x86_64 Summary: Add basic support, i386 version will be added later. Reviewers: emaste, joerg, clayborg, tfiala Subscr

Re: [Lldb-commits] [PATCH] D16627: Add support to detect arm hard float ABI based binaries for ABISysV_arm

2016-02-01 Thread Muhammad Omair Javaid via lldb-commits
omjavaid updated this revision to Diff 46620. omjavaid marked 4 inline comments as done. omjavaid added a comment. Updated after addressing concerns. LGTM? http://reviews.llvm.org/D16627 Files: include/lldb/Core/ArchSpec.h source/Plugins/ABI/SysV-arm/ABISysV_arm.cpp source/Plugins/ABI/Sy