On 5 December 2011 10:14, Michael Zolotukhin
wrote:
> Ok, will several tests with short arrays be enough for that or should
> we keep all the original tests plus new ones with longer arrays?
BTW, there is another problem with current tests with short arrays -
scans are expecting specific number o
gcc-patches-ow...@gcc.gnu.org wrote on 05/12/2011 10:39:07 AM:
> From: Michael Zolotukhin
> To: Richard Guenther
> Cc: gcc-patches@gcc.gnu.org, izamya...@gmail.com
> Date: 05/12/2011 10:39 AM
> Subject: Re: [Patch] Increase array sizes in vect-tests to enable
> 256-bit vectorization
> Sent by:
On Mon, Dec 5, 2011 at 9:48 AM, Ira Rosen wrote:
>
>
> gcc-patches-ow...@gcc.gnu.org wrote on 05/12/2011 10:39:07 AM:
>
>> From: Michael Zolotukhin
>> To: Richard Guenther
>> Cc: gcc-patches@gcc.gnu.org, izamya...@gmail.com
>> Date: 05/12/2011 10:39 AM
>> Subject: Re: [Patch] Increase array size
in http://gcc.gnu.org/ml/gcc-patches/2011-12/msg00312.html
I wrote:
where is "_CALL_DARWIN" supposed to come from? (it is not defined by
the preprocessor AFAICT).
===
it seems that we don't define rs6000_current_abi before cpp builtins
are emitted and the function uses it to decide to emit
Mike Stump writes:
> On Dec 4, 2011, at 4:02 AM, Richard Sandiford
> wrote:
>> A while back I added the target_globals structure, to allow a backend
>> to switch between two very different ISA modes without paying the full
>> target_reinit penalty each time. This made a huge difference to compi
> It's the interpretation and mode of VALUE that I'm worried about.
> Doesn't FIELDMODE describe STR_RTX (the stored bitfield) instead?
Yes, FIELDMODE is the mode of the target field.
> If so, it seems odd that we're using a property of STR_RTX to determine
> the interpretation/justification of V
> http://gcc.gnu.org/bugzilla/show_bug.cgi?id=50325#c4
>
> value was (subreg:DI (reg:TI 70) 8)
Not the original VALUE though, since it is 12-byte wide.
--
Eric Botcazou
This change fixes an incorrect assumption in s-oscons-tmplt.c that
CLOCK_REALTIME is always a C preprocessor macro. On HP-UX, it is actually
an enumeration literal. The incorrect assumption caused a build failure
that platform.
NOT tested on pa hp-ux directly, so change done blindly.
Dave, can you
This change enhances Source Coverage Obligations to convey information
about how a basic block can be entered (dominant statement, basic block
entry determined by a decision, or by an exception occurrence).
Tested on x86_64-pc-linux-gnu, committed on trunk
2011-12-05 Thomas Quinot
* p
On 04/12/11 13:32, kazu_hir...@mentor.com wrote:
> Hi,
>
> Attached is a patch to fix miscompilation in
> arm.md:*minmax_arithsi.
>
> The following testcase, reduced from efgcvt_r.c:fcvt_r in glibc, gets
> miscompiled:
>
> extern void abort (void);
>
> int __attribute__((noinline))
> foo (int a
The original RFC is here -
http://gcc.gnu.org/ml/gcc-patches/2011-10/msg01961.html
>
> * config/arm/arm.c (vfp3_const_double_for_fract_bits): Define.
> * config/arm/arm-protos.h (vfp3_const_double_for_fract_bits): Declare.
> * config/arm/constraints.md ("Dt"): New constraint.
>
This patch improves the output of Treepr.pp. This routine is only for use in
gdb, so there is no test case available.
Tested on x86_64-pc-linux-gnu, committed on trunk
2011-12-05 Bob Duff
* treepr.adb (pn): Print something useful for
Elmt_Ids. Add Write_Eol to 'when others' ca
Hi,
a stupid thinko of mine (consistent with my confusion at the time about
expressions vs types ;) : %qT not %qE for types. Tested x86_64-linux.
Thanks,
Paolo.
//
/cp
2011-12-05 Paolo Carlini
PR c++/51414
* semantics.c (finish_underlying_type): Use %
On Wed, 28 Sep 2011, Artem Shinkarov wrote:
> In the attachment there is a patch with the changes. I don't have
> rights to commit to the cvs.
Thanks, Michael. I have applied the patch on your behalf.
Gerald
Hi,
a simple ICE on invalid, 4.7 Regression. Tested x86_64-linux.
Thanks,
Paolo.
//
/cp
2011-12-05 Paolo Carlini
PR c++/51399
* init.c (perform_member_init): Check init for error_mark_node too.
/testsuite
2011-12-05 Paolo Carlini
PR c++/51399
Hi,
On Fri, 2 Dec 2011, Jeff Law wrote:
> So while continuing to have the phis in the available expression table
> is not useful beyond the current block, the equivalency created when a
> redundant PHI is encountered is useful to keep.
That's why I said to only clear the avail_exprs stack/vect
Hi,
On Sun, 4 Dec 2011, Eric Botcazou wrote:
> > I'm just a bit worried about the name "delete_label". "delete_insn
> > (label)" should always do the right thing for a pure deletion; the
> > point of the new routine is that it also moves instructions.
>
> It only fixes things up though, so tha
Hello,
Ping: http://gcc.gnu.org/ml/gcc-patches/2011-11/msg02444.html
Thanks,
Revital
Hi,
On Fri, 2 Dec 2011, William J. Schmidt wrote:
> > on top of your current version. That ought to remove the added PHI
> > expressions (and only them) from the hash table but retain the
> > information of equality in the const_or_copies_stack. Checking the BB
> > wouldn't be required then.
On Mon, Dec 5, 2011 at 2:28 PM, Michael Zolotukhin
wrote:
>> I'd just duplicate the tests you want to change to a larger array
>> size and change those duplicates accordingly, leaving the original
>> tests alone.
> Richard, I made the tests this way - please check them in the attached
> patch (it
With the alias-improvements rewrite I unfortunately disabled
most of the invariant (and store) motions in LIM due to the
fact how the current code uses virtual operands to track
clobbers through stmts it cannot analyze. Given that we only
have a single virtual operand now this boils down to disab
This simplifies the loop invariant motion cost function, removing
the use of the magic constant 20 (the default of lim-expensive),
and making SSA name copies and PAREN_EXPR wrappings have no cost
(movement decisions should not depend on the length of a SSA name
copy chain nor on whether an express
On Mon, 2011-12-05 at 14:59 +0100, Michael Matz wrote:
> Hi,
>
> On Fri, 2 Dec 2011, William J. Schmidt wrote:
>
> > > on top of your current version. That ought to remove the added PHI
> > > expressions (and only them) from the hash table but retain the
> > > information of equality in the
On Mon, 2011-12-05 at 08:36 -0600, William J. Schmidt wrote:
>
> On Mon, 2011-12-05 at 14:59 +0100, Michael Matz wrote:
> > Hi,
> >
> > On Fri, 2 Dec 2011, William J. Schmidt wrote:
> >
> > > > on top of your current version. That ought to remove the added PHI
> > > > expressions (and only t
Hmm, I think giving the additional error was intentional, which is why
we check for error_operand_p after giving it. But I suppose I'm not
attached to that.
We could avoid reformatting by adding
if (error_operand_p (bounds))
/* Already gave an error. */;
OK either way.
Jason
Hmm. I know I'm the one that suggested this approach, but I think I'm
uncomfortable with this minimal change, since code for handling
BOUND_TEMPLATE_TEMPLATE_PARM expects to be able to get a
TEMPLATE_TYPE_PARM_INDEX out of it, and that won't work for the alias
template use.
So I'd like to re
On 12/05/2011 02:00 AM, Fabien Chêne wrote:
2011/12/5 Jason Merrill:
Is there a reason not to just do
decl = strip_using_decl (decl);
early in finish_id_expression?
Not really, I've already tried it and it works. I wasn't sure it was
correct not to return a USING_DECL in aIl cases -- they
This fixes PR51363 - we can simplify the condition in DOM to not
use gimple_rhs_has_side_effects (a weird function which still contains
the checking code I removed from gimple_has_side_effects - the
LHS is never a side-effect considered by gimple_has_side_effects
anyway, side-effects are things no
Hi,
Hmm, I think giving the additional error was intentional, which is why
we check for error_operand_p after giving it. But I suppose I'm not
attached to that.
We could avoid reformatting by adding
if (error_operand_p (bounds))
/* Already gave an error. */;
OK either way.
Thanks. Thus
OK, I finally got permission from the FSF to put this patch in, and
since it was posted before the end of stage 1 it can still go in.
While applying it I noticed that we were sharing the argument trees
between the two calls in a way that might be problematic, and I went
ahead and fixed that.
On 5 December 2011 17:51, Jason Merrill wrote:
> While applying it I noticed that we were sharing the argument trees between
> the two calls in a way that might be problematic, and I went ahead and fixed
> that.
Ouch. Thanks.
> I noticed that template/meminit1.C is ill-formed in C++11 as well, d
Latest results for 4.6.x
-tgc
Testresults for 4.6.2:
i386-pc-solaris2.10
powerpc-ibm-aix6.1.0.0
sparc-sun-solaris2.10
Testresults for 4.6.1:
powerpc-ibm-aix6.1.0.0
Index: buildstat.html
===
RCS file: /cvs/gcc/wwwdocs/htdocs/
Let's exit earlier on error_mark_node, as it seems there are other
places in the function that might do the wrong thing.
Jason
OK.
Jason
This is for google-main branch.
Fix taking address of SSA_NAME in ThreadSanitizer pass.
Index: gcc/tree-tsan.c
===
--- gcc/tree-tsan.c (revision 182014)
+++ gcc/tree-tsan.c (working copy)
@@ -726,13 +726,20 @@
struct mop_de
On 12/04/2011 01:32 PM, Iain Sandoe wrote:
> where is "_CALL_DARWIN" supposed to come from? (it is not defined by the
> preprocessor AFAICT).
>
> I can produce a patch to add it if that's an oversight in the Darwin port.
It certainly is, or is supposed to be:
> switch (rs6000_current_abi)
>
On 12/05/2011 01:11 AM, Iain Sandoe wrote:
> in http://gcc.gnu.org/ml/gcc-patches/2011-12/msg00312.html
> I wrote:
>
> where is "_CALL_DARWIN" supposed to come from? (it is not defined by the
> preprocessor AFAICT).
>
> ===
>
> it seems that we don't define rs6000_current_abi before cpp builtin
Hello!
Just skip these tests when -fno-fat-lto-objects was added to options.
2011-12-05 Uros Bizjak
PR testsuite/51128
* gcc.dg/torture/pr23821.c: Skip if -fno-fat-lto-objects was passed.
* gcc.dg/torture/pr39074.c: Ditto.
* gcc.dg/torture/pr39074-2.c: Ditto.
Ping?
http://codereview.appspot.com/5394041/
And, as indicated, the list might change in the future.
ChangeLog:
2011-12-05 Toon Moene
PR/51310
invoke.texi: Itemize the cases for which -finit- doesn't
work.
OK for trunk ? (and perhaps later for the 4.6 branch ?
--
Toon Moene - e-mail: t...@moene.org - phone: +3
2011/12/5 Jason Merrill :
[...]
> Since finish_id_expression often returns something that isn't a decl at all,
> I think stripping the using here makes sense.
Good, here is an updated patch, (re)tested x86_64-unknown-linux-gnu.
OK to commit ?
--
Fabien
51319.patch
Description: Binary data
Hi,
Let's exit earlier on error_mark_node, as it seems there are other
places in the function that might do the wrong thing.
Good. The below also passes testing on x86_64-linux.
Thanks,
Paolo.
/cp
2011-12-05 Paolo Carlini
PR c++/51399
* init.c (perform_
On 12/02/2011 08:35 AM, Hans-Peter Nilsson wrote:
On Tue, 29 Nov 2011, Vladimir Makarov wrote:
3. The patch rewrite the way of dealing with the secondary memory
moves in constraint pass of LRA. Previously we generated secondary
moves if macro SECONDARY_MEMORY_NEEDED says so. Unfortunat
Chung-Lin Tang writes:
> On 2011/12/5 12:39 AM, Mike Stump wrote:
>> On Dec 4, 2011, at 3:29 AM, Richard Sandiford
>> wrote:
>>> The problem is that MIPS has
>>> native TLS support, but the ABI has not "yet" been extended to MIPS16.
>>> MIPS16 is supposed to be link-compatible with non-MIPS16, s
Eric Botcazou writes:
>> If so, it seems odd that we're using a property of STR_RTX to determine
>> the interpretation/justification of VALUE. That is, we're using
>> FIELDMODE before, rather than after:
>>
>> /* This is the mode we must force value to, so that there will be
>> enough subwo
Jason Merrill writes:
> Hmm. I know I'm the one that suggested this approach, but I think I'm
> uncomfortable with this minimal change, since code for handling
> BOUND_TEMPLATE_TEMPLATE_PARM expects to be able to get a
> TEMPLATE_TYPE_PARM_INDEX out of it, and that won't work for the alias
> tem
OK.
Jason
OK.
Jason
Hi!
The following testcase ICEs, because in finish_decl the C FE doesn't
relayout_decl after changing the type from char [] to char [2], so it
is not updated from BLKmode to HImode. WHen OpenMP creates the private
copy of the var, the type is complete from the beginning and therefore
it is HImode
Hi!
The VAR_DECL in this testcase is pushed to both external_scope
and file_scope, which unfortunately triggers the creation of the local
extern I've added for PR39563. That was only intended for function scope,
for DWARF file_scope and external_scope are the same thing.
Bootstrapped/regtested o
Hi!
When a multiply stmt has zero uses, convert_mult_to_fma immediately
returns true, meaning the multiplication can be deleted. Normally it should
be DCE job to remove dead stmts, not widening_mul pass IMHO, and in this
case it shouldn't be removed because it can throw and wasn't DCEd because of
Hi Ahmad,
This is a backport for two upstream patches into our 4.6-mobile branch.
These two patches have been backported to google-4.6 by Doug Kwan last week.
2011-12-05 Jing Yu
Backport r171347 and r181549 from trunk.
gcc/
2011-03-23 Julian Brown
* ex
Hi Ahmad,
This is a backport for two upstream patches into our 4.6-mobile branch.
These two patches have been backported to google-4.6 by Doug Kwan last week.
2011-12-05 Jing Yu
Backport r171347 and r181549 from trunk.
gcc/
2011-03-23 Julian Brown
* ex
http://codereview.appspot.com/5453050/
On Mon, 5 Dec 2011, Jakub Jelinek wrote:
> 2011-12-05 Jakub Jelinek
>
> PR c/51339
> * c-decl.c (c_finish_incomplete_decl, finish_decl): Call
> relayout_decl instead of layout_decl.
>
> * gcc.dg/gomp/pr51339.c: New test.
OK.
--
Joseph S. Myers
jos...@codesourcery.co
On Mon, 5 Dec 2011, Jakub Jelinek wrote:
> 2011-12-05 Jakub Jelinek
>
> PR debug/51410
> * c-decl.c (pop_scope): Don't add DECL_EXTERNAL decls
> for debug info if scope is file_scope.
>
> * gcc.dg/debug/dwarf2/pr51410.c: New test.
OK.
--
Joseph S. Myers
jos...@codes
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On 12/05/11 13:34, Jakub Jelinek wrote:
> Hi!
>
> When a multiply stmt has zero uses, convert_mult_to_fma
> immediately returns true, meaning the multiplication can be
> deleted. Normally it should be DCE job to remove dead stmts, not
> widening_mul
On Fri, 18 Nov 2011, Han Shen wrote:
> Hi, Joseph, thanks!
>
> ChangeLog entries added to the issue description.
>
> ChangeLog
> * Makefile.in (GPLUSPLUS_INCLUDE_DIR_ADD_SYSROOT): add a macro
> definition to compile command.
> * cppdefault.c (GPLUSPLUS_INCLUDE_DIR_ADD_SYS
2011/12/5 Jonathan Wakely:
> 2011/12/5 Marco Antonio Gómez Martín:
>> Hello,
>>
>> Just to let you know that I have found some broken links at
>>
>> http://gcc.gnu.org/projects/cxx0x.html
>>
>> The table entries:
>>
>> Defining move special member functions N3053 GCC 4.6
>>
Hi
Recently I discovered that the warning for unreachable code
(-Wunreachable-code) was removed from GCC two years ago.
http://gcc.gnu.org/ml/gcc-patches/2009-11/msg00251.html
I think this is unfortunate, as this warning is very valuable for static code
analysis checking.
Maybe the warning
Ping http://gcc.gnu.org/ml/gcc-patches/2011-11/msg00543.html
--
Alan Modra
Australia Development Lab, IBM
On Mon, Dec 5, 2011 at 9:01 AM, Jason Merrill wrote:
> it took me a little while to realize that "nb" is short for "number".
you need to spend more time in Paris :-)
-- Gaby
On Fri, Nov 4, 2011 at 9:07 AM, Alan Modra wrote:
> OK to apply? gcc-4.6 branch too?
>
> PR target/50906
> * config/rs6000/rs6000.c (rs6000_emit_prologue ):
> Do not mark r11 setup as frame-related. Pass correct offset to
> rs6000_emit_savres_rtx. Correct out-of-lin
On Mon, Nov 28, 2011 at 11:03 PM, Alan Modra wrote:
> On Mon, Nov 28, 2011 at 05:15:08PM +0100, Rainer Orth wrote:
>> Alan Modra writes:
>>
>> > On Sun, Nov 27, 2011 at 08:36:38PM -0500, David Edelsohn wrote:
>> >> I was hoping that other targets affected by the patch would test it as
>> >> well
I've applied this patch adding release notes for the C1X features added in
4.7. (If the C1X revision is published by ISO before 4.7 comes out, I
intend to add appropriate new names for the options such as -std=c11 or
-std=c12, and the final __STDC_VERSION__ value, and will then update these
re
Hi,
There was a missing %P with the last commit for the fixed to floating
point conversion idioms which caused ffmpeg builds to break by
accidentally putting out a vmov.f64 s0, r0, r0 instead of the vmov.f64
d0, r0, r0. Tested with a simple testcase and made sure that the
output obtained is sane.
Hi,
Like the .ctors array, __do_global_dtors_aux_fini_array_entry and
__frame_dummy_init_array_entry arrays need a specific alignment. This
patch fixes those two arrays. This patch fixes the bootstrap on
mips64-linux-gnu.
Bootstrapped on mips64-linux-gnu.
Bootstrapped and tested on x86-linux-g
Hi, All
I am freshman in the GCC community. If I want to use gcc to get the
dependence analysis information, how should I get it? And how to debug gcc
middle end ?
Thanks!
Eric
On Mon, Dec 5, 2011 at 5:42 PM, Andrew Pinski
wrote:
> Hi,
> Like the .ctors array, __do_global_dtors_aux_fini_array_entry and
> __frame_dummy_init_array_entry arrays need a specific alignment. This
> patch fixes those two arrays. This patch fixes the bootstrap on
> mips64-linux-gnu.
>
> Bootst
BTW, is there a reason that C1X _Alignas is supported, but not C++11
alignas? Is the latter harder?
Thanks,
-Miles
--
Generous, adj. Originally this word meant noble by birth and was rightly
applied to a great multitude of persons. It now means noble by nature and is
taking a bit of a rest.
70 matches
Mail list logo