On Sun, Apr 24, 2011 at 23:32, Jerry DeLisle wrote:
> The final solution to 48602 I want to do as a second phase to this. The
> second phase will attempt to avoid floating point comparisons which are
> sensitive to optimizations and or printf behavior.
Sounds like a good idea. I think it should b
This is just for the parser, the semantic analysis of virt-specifiers
will be done later. Also, these changes don't yet support a final
specifier on class.
diff --git a/gcc/cp/cp-tree.h b/gcc/cp/cp-tree.h
index e538825..08d939f 100644
--- a/gcc/cp/cp-tree.h
+++ b/gcc/cp/cp-tree.h
@@ -4420,6 +4420
On 04/25/2011 03:48 AM, Janne Blomqvist wrote:
On Sun, Apr 24, 2011 at 23:32, Jerry DeLisle wrote:
The final solution to 48602 I want to do as a second phase to this. The
second phase will attempt to avoid floating point comparisons which are
sensitive to optimizations and or printf behavior.
Committed. I'll be converting other pages with similar fake markup
over the next days, too.
Gerald
2011-04-25 Gerald Pfeifer
* contrib.html: Use regular markup for section headers
instead of fake tables.
Index: contrib.html
==
On Apr 15, 2011, at 4:38 PM, Maxim Kuvyrkov wrote:
> On Apr 15, 2011, at 3:34 PM, Eric Botcazou wrote:
>
>>> The problem this patch fixes is that combine_simplify_rtx() prefers to
>>> return an expression (say, ) even when a comparison is
>>> prefered (say, ). Expressions are not recognized as
>
Nathan,
I think this patch overlaps or duplicates part of Alan Modra's recent
patch improving sibcalls on rs6000.
- David
Honza,
This patch causes a bootstrap failure when building libstdc++ on AIX:
In file included from
/farm/dje/src/src/libstdc++-v3/include/precompiled/stdc++.h:94:0:
/tmp/20110423/powerpc-ibm-aix5.3.0.0/libstdc++-v3/include/valarray:1163:1:
internal compiler error: vector VEC(tree,base) index doma
On Mon, Apr 25, 2011 at 14:44, Jerry DeLisle wrote:
> On 04/25/2011 03:48 AM, Janne Blomqvist wrote:
>> Now, for one of the testcase changes:
>>
>> --- gcc/testsuite/gfortran.dg/char4_iunit_1.f03 (revision 172909)
>> +++ gcc/testsuite/gfortran.dg/char4_iunit_1.f03 (working copy)
>> @@ -24,11 +24,1
On Mon, Apr 25, 2011 at 6:03 AM, Ville Voutilainen
wrote:
>
> This is just for the parser, the semantic analysis of virt-specifiers
> will be done later. Also, these changes don't yet support a final
> specifier on class.
>
> diff --git a/gcc/cp/cp-tree.h b/gcc/cp/cp-tree.h
> index e538825..08d939
On 25 April 2011 18:32, Gabriel Dos Reis wrote:
>> typedef int cp_cv_quals;
>> +/* A type-qualifier, or bitmask therefore, using the VIRT_SPEC
>> + constants. */
>> +typedef int cp_virt_specifiers;
> could we use enums instead?
No reason not to, except that we don't for the cp_cv_quals above.
Hi All,
The attached patch changes the reload class for NEON constant vectors
from GENERAL_REGS to NO_REGS.
The issue was found on this code from libevas:
void
_op_blend_p_caa_dp(unsigned *s, unsigned* e, unsigned *d, unsigned c) {
while (d < e) {
*d = ( (*s) >> 8) & 0x00ff00ff)
Ping? Ping? Ping?
On Mon, Apr 18, 2011 at 9:45 AM, Paul Pluzhnikov wrote:
> Ping? Ping?
>
> On Mon, Apr 11, 2011 at 11:00 AM, Paul Pluzhnikov
> wrote:
>> Ping?
--
Paul Pluzhnikov
Is the patch ok?
Thanks,
David
On Fri, Apr 22, 2011 at 12:48 PM, Jan Hubicka wrote:
>> Please review the new patch which only implements cfg checksum.
>>
>> The auto version generation was introduced in 2002 before FDO support
>> was added (so the old way never existed), so it might be better t
This patch from Evan Shaw uses the backend interface for simple types.
Bootstrapped and ran Go testsuite on x86_64-unknown-linux-gnu.
Committed to mainline.
Ian
2011-04-25 Evan Shaw
* go-gcc.c (class Gcc_tree): Make get_tree const.
(Gcc_backend::void_type): Implement.
On 04/25/2011 07:03 AM, Ville Voutilainen wrote:
This is just for the parser, the semantic analysis of virt-specifiers
will be done later. Also, these changes don't yet support a final
specifier on class.
I mentioned the minor formatting issues in personal mail; also, please
include ChangeLog
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On 04/22/11 14:19, Easwaran Raman wrote:
> Hi,
> This patch improves RTL DSE by not assuming that calls read all
> memory locations. With this patch, calls are assumed to read any
> non-frame memory and any stack variables that can potentially escape.
On Sun, Apr 24, 2011 at 11:02 PM, Jan Kratochvil
wrote:
> include/
> 2011-04-25 Jan Kratochvil
>
> * ansidecl.h (ENUM_BITFIELD): New, from gcc/system.h.
>
> contrib/
> 2011-04-25 Jan Kratochvil
>
> * paranoia.cc (ENUM_BITFIELD): Remove.
>
> gcc/
> 2011-04-25 Jan Kratochvil
On 04/25/2011 11:34 AM, Ville Voutilainen wrote:
On 25 April 2011 18:32, Gabriel Dos Reis wrote:
typedef int cp_cv_quals;
+/* A type-qualifier, or bitmask therefore, using the VIRT_SPEC
+ constants. */
+typedef int cp_virt_specifiers;
could we use enums instead?
No reason not to, except
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On 04/22/11 09:21, Chung-Lin Tang wrote:
> This patch abstracts out a small part of simplify_comparison(), into a
> new function simplify_compare_const(). The parts are basically where the
> comparison RTX code and a constant operand (op1) can be simpl
This patch to the Go frontend uses the backend interface for function
types. It also drops the type_tree functions for Float_type and
Complex_type, and makes that work by not defining builtin functions
until the gogo object is created. It also checks for errors in a
backend pointer type. Bootstr
On 25 April 2011 20:06, Jason Merrill wrote:
>>> could we use enums instead?
>> No reason not to, except that we don't for the cp_cv_quals above. :) I
>> followed
>> the same approach.
> Sure, let's use enums for the named values. But I think we still want to
> use the int typedef for variables a
Ian,
This is the patch I am using to be able to build libgo in GCC.
See:
http://gcc.gnu.org/ml/gcc-testresults/2011-04/msg02325.html
MIPS/Linux support is not perfect, but this is a start. I'm not sure
what the mechanics of applying the patch are, but I think you need to do
something with it
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On 04/22/11 09:21, Chung-Lin Tang wrote:
> This patch is the main bulk of this submission. It modifies the compare
> combining part of try_combine(), adding a call of
> CANONICALIZE_COMPARISON into the entire logic.
>
> Also, instead of testing for XE
On 04/25/2011 01:23 PM, Ville Voutilainen wrote:
Would you like me to convert the cp_cv_quals values to enums in the same go?
Sure.
Where should I put the flags for semantic analysis? DECL_LANG_FLAG?
Or TREE_LANG_FLAG?
Use a two-bit bit-field in lang_decl_fn. To avoid a size increase for
Hello, gentle maintainer.
This is a message from the Translation Project robot.
A revised PO file for textual domain 'gcc' has been submitted
by the German team of translators. The file is available at:
http://translationproject.org/latest/gcc/de.po
(This file, 'gcc-4.6.0.de.po', has just
On Mon, 25 Apr 2011 19:05:22 +0200, Ian Lance Taylor wrote:
> On Sun, Apr 24, 2011 at 11:02 PM, Jan Kratochvil
> wrote:
>
> > include/
> > 2011-04-25 Jan Kratochvil
> >
> > * ansidecl.h (ENUM_BITFIELD): New, from gcc/system.h.
> >
> > contrib/
> > 2011-04-25 Jan Kratochvil
> >
> >
On 4/22/11, Hans-Peter Nilsson wrote:
> On Sat, 16 Apr 2011, Diego Novillo wrote:
>> On Thu, Apr 14, 2011 at 22:01, Lawrence Crowl wrote:
>> > +unsigned char too_many_directives_for_bitfield[
>> > +N_DIRECTIVES <= (1 << CPP_HASHNODE_INDEX_BITS)
>> > +? 1 : -1];
>>
>> Heh, I'm not
Hi,
this is the work I did over the last days, with the off-list guidance of
Jason, on a C++ front-end "builtin" necessary in order to implement the
C++1x std::underlying_type, part of .
Most of the code is rather straightforward, in my opinion, maybe the
most interesting bits are in finish_
Historically, gfortran has accepted real-literal-constants
of the form 1.23Q45 as single precision values. Many commercial
compilers (dating back years) have used the 'Q' exponent-letter
to mean quadruple precision. With the addition of software
support for REAL(16) on i386 and x86_64 targets, I
On Mon, Apr 25, 2011 at 11:42:07AM -0700, Steve Kargl wrote:
>
> 2011-04-25 Steven G. Kargl
>
> PR fortran/48720
> * gfortran.texi: Document the 'Q' exponent-letter extension.
> * primary.c (match_real_constant): Accept 'Q' as exponent-letter
> for REAL(16) real-litera
"Andreas Krebbel" writes:
> 2011-04-18 Andreas Krebbel
>
> * calls.c (emit_library_call_value_1): Invoke
> promote_function_mode hook on libcall arguments.
> * explow.c (promote_function_mode, promote_mode): Handle TYPE
> argument being NULL.
> * targhooks.c (defa
On Thu, Apr 21, 2011 at 3:20 PM, Andrew Pinski wrote:
> On Thu, Apr 21, 2011 at 3:18 PM, Easwaran Raman wrote:
>> When using gcc with a post-assembly tool, we use a wrapper that
>> invokes the tool and needs to know if the tool's output (another
>> assembly file) needs to be saved. The wrapper do
On Mon, Apr 25, 2011 at 21:42, Steve Kargl
wrote:
> Historically, gfortran has accepted real-literal-constants
> of the form 1.23Q45 as single precision values. Many commercial
> compilers (dating back years) have used the 'Q' exponent-letter
> to mean quadruple precision. With the addition of s
Rainer Orth writes:
> 2011-01-30 Rainer Orth
>
> libgo:
> PR go/47515
> * mksysinfo.sh: Avoid \(, \), \? with grep, sed REs.
> Handle _f0 in IRIX 6.5 N64 struct timeval.
> (sysinfo.c) [__sgi__]: Move ...
> * configure.ac: ... here.
> (OSCFLAGS) [mips
On Mon, Apr 25, 2011 at 10:26:20PM +0300, Janne Blomqvist wrote:
> On Mon, Apr 25, 2011 at 21:42, Steve Kargl
> wrote:
> > Historically, gfortran has accepted real-literal-constants
> > of the form 1.23Q45 as single precision values. ??Many commercial
> > compilers (dating back years) have used th
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On 04/22/11 02:56, Richard Guenther wrote:
> On Thu, Apr 21, 2011 at 5:47 PM, Jeff Law wrote:
>
> For some dumb reason I thought handling threading through a SWITCH_EXPR
> was hard in VRP; that's definitely not the case, it's no more difficult
> than
Put the regression links under a stylesheet class of their own. Use that
to reduce font size a bit. In other words, make these links into Bugzilla
that accompany all our release entries in the status pane a bit smaller
(and allow for easier changes going forward).
Installed.
Gerald
Index: gcc.
It messes up the output of make -j builds.
Approved by David, and obvious anyway; applied.
2011-04-25 Segher Boessenkool
* config/rs6000/titan.md (automata_option "progress"): Remove.
---
gcc/config/rs6000/titan.md |2 --
1 files changed, 0 insertions(+), 2 deletions(-)
On Mon, Apr 25, 2011 at 22:45, Steve Kargl
wrote:
> On Mon, Apr 25, 2011 at 10:26:20PM +0300, Janne Blomqvist wrote:
>> On Mon, Apr 25, 2011 at 21:42, Steve Kargl
>> wrote:
>> > Historically, gfortran has accepted real-literal-constants
>> > of the form 1.23Q45 as single precision values. ??Many
Remove to (now) superflous instances of bgcolor and other manual
color settings.
Applied. I have regenerated and verified gcc.gnu.org manually and
www.gnu.org should pick this up over night.
Gerald
Index: style.mhtml
===
RCS file:
On Sun, 3 Apr 2011, Gerald Pfeifer wrote:
> I was just going to add this sever, but something does not seem
> right: All directories have 29-Mar-2011 09:14 (plus some minutes
> in some cases) as their date and time. Is there, possibly, a
> problem with the sync always pulling everything down?
>
In GCC 4.4.3, I found a case where a defining declaration of a subprogram
was included within the DIE structure for the containing class declaration,
and the class was moved into a DWARF-4 type unit, causing a later ICE in
output_pubnames. That case doesn't cause a problem in 4.5 and later, as
the
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On 04/21/11 11:43, Xinliang David Li wrote:
>
> There are three different kind of uninit warnings:
>
> 1) definitely uninitialized, and the use the variable dominates the
> exit -- this is the must be used uninitialized case
> 2) definitely uninitia
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On 04/15/11 10:26, Bernd Schmidt wrote:
> On 04/15/2011 04:18 PM, Jeff Law wrote:
>
>> http://gcc.gnu.org/ml/gcc-patches/2011-03/msg02247.html
>
> I don't know. I sympathize with the goal, but I'm not too happy about
> the structure of this patch. Do
OK.
Jason
In C++0x we can have an initializer that is potentially constant and yet
still type-dependent if it involves a call, so we need to handle that.
For 4.7 I'm explicitly testing for type-dependency; for 4.6 I've made a
smaller change to make value_dependent_expression_p return true for
type-depen
On Fri, Apr 22, 2011 at 12:59:21AM -0400, Jason Merrill wrote:
> On 04/21/2011 10:55 PM, Nathan Froyd wrote:
>> On Thu, Apr 21, 2011 at 10:49:05PM -0400, Jason Merrill wrote:
>>> Hunh. How does that work? They fill in CASE_LABEL later? Can that be
>>> changed?
>>
>> Yeah, tree-eh.c:lower_try_fin
Am 22.04.2011 22:07, schrieb Thomas Koenig:
Hello world,
the attached patch makes block names unique, so that
-fdump-fortran-original dumps are easier to read.
Regression-tested. OK for trunk?
Thomas
2011-04-22 Thomas Koenig
* decl.c (gfc_match_end): Check that the block name starts
with "b
Am 23.04.2011 17:22, schrieb Thomas Koenig:
Hello world,
the attached patch puts temporary variables, and the statement they are
being generated for, in their own BLOCK.
This may or may not be useful for data locality, and for telling the
middle end explicitly about the lifetime of the temporar
Hi,
tested x86_64-linux, committed to mainline.
Paolo.
//
2011-04-25 Paolo Carlini
* include/std/type_traits (struct underlying_type): Add.
* testsuite/20_util/underlying_type/requirements/typedefs-1.cc: New.
* testsuite/20_util/underlying_type/re
On 04/25/2011 11:50 PM, Jason Merrill wrote:
OK.
Committed. Thanks again!
Paolo.
On 04/23/2011 08:22 AM, Thomas Koenig wrote:
Hello world,
the attached patch puts temporary variables, and the statement they are being
generated for, in their own BLOCK.
This may or may not be useful for data locality, and for telling the middle end
explicitly about the lifetime of the tempora
On Mon, Apr 25, 2011 at 10:34 AM, Ville Voutilainen
wrote:
> On 25 April 2011 18:32, Gabriel Dos Reis
> wrote:
>>> typedef int cp_cv_quals;
>>> +/* A type-qualifier, or bitmask therefore, using the VIRT_SPEC
>>> + constants. */
>>> +typedef int cp_virt_specifiers;
>> could we use enums inste
On Mon, 18 Apr 2011, Eric Botcazou wrote:
> Compiling dwarf2out.c with older versions of GCC yields a warning because
> is_redundant_typedef has a prototype without the 'inline' keyboard and a
> declaration with it, and is called from another function in-between.
Shouldn't there be a warning from
On Mon, Apr 25, 2011 at 12:23 PM, Ville Voutilainen
wrote:
> On 25 April 2011 20:06, Jason Merrill wrote:
could we use enums instead?
>>> No reason not to, except that we don't for the cp_cv_quals above. :) I
>>> followed
>>> the same approach.
>> Sure, let's use enums for the named values.
On 04/25/2011 07:36 AM, Janne Blomqvist wrote:
On Mon, Apr 25, 2011 at 14:44, Jerry DeLisle wrote:
On 04/25/2011 03:48 AM, Janne Blomqvist wrote:
Now, for one of the testcase changes:
--- gcc/testsuite/gfortran.dg/char4_iunit_1.f03 (revision 172909)
+++ gcc/testsuite/gfortran.dg/char4_iunit_1
56 matches
Mail list logo