graesslin requested changes to this revision. graesslin added a comment. This revision now requires changes to proceed.
Looks good to me. Just a minor comment regarding where to put the new virtual method. Setting to reject changes as requested by Albert :-) INLINE COMMENTS > scene_opengl.cpp:682-685 > +void SceneOpenGL::paintCursor() > +{ > + > +} Instead of adding an empty method you could make it pure virtual > scene_opengl.h:103 > virtual void updateProjectionMatrix() = 0; > + virtual void paintCursor(); > Given that we have also a method called paintCursor in SceneQPainter, I suggest to move it up to Scene directly and mark the call in SceneQPainter as override. > scene_opengl.h:141 > virtual void updateProjectionMatrix() override; > + virtual void paintCursor() override; > you don't need to readd the virtual keyword when using override. REPOSITORY R108 KWin REVISION DETAIL https://phabricator.kde.org/D6186 To: Kanedias, graesslin, davidedmundson Cc: aacid, luebking, plasma-devel, kwin, #kwin, ZrenBot, progwolff, lesliezhai, ali-mohamed, hardening, jensreuterberg, abetts, eliasp, sebas, apol, mart, hein, lukas