-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/109825/#review30284
-----------------------------------------------------------



resources/facebook/CMakeLists.txt
<http://git.reviewboard.kde.org/r/109825/#comment22538>

    the resource's identifier is akonadi_facebook_resource, any reason this is 
_agent?



resources/facebook/facebookresource.h
<http://git.reviewboard.kde.org/r/109825/#comment22539>

    maybe make an enum with two values for better readability, e.g. like 
QString::SplitBehavior



resources/facebook/facebookresource.h
<http://git.reviewboard.kde.org/r/109825/#comment22540>

    I think the preferred way to track QObject pointer life times is QPointer 
again



resources/facebook/facebookresource_notifications.cpp
<http://git.reviewboard.kde.org/r/109825/#comment22541>

    This should probably be a plural form i18n call. 



resources/facebook/facebookresource_notifications.cpp
<http://git.reviewboard.kde.org/r/109825/#comment22542>

    this also looks like something that would make sense as a plural form string



resources/facebook/facebookresource_notifications.cpp
<http://git.reviewboard.kde.org/r/109825/#comment22543>

    if you remove an element at i, shouldn't you check i again?
    



resources/facebook/serializer/akonadi_serializer_socialnotification.cpp
<http://git.reviewboard.kde.org/r/109825/#comment22544>

    this is actually a bugfix, right?
    maybe do this as a separate commit to 4.10 branch and merge to master so it 
is properly independent from the feature commit?


- Kevin Krammer


On April 2, 2013, 4:47 p.m., Martin Klapetek wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/109825/
> -----------------------------------------------------------
> 
> (Updated April 2, 2013, 4:47 p.m.)
> 
> 
> Review request for KDEPIM and Plasma.
> 
> 
> Description
> -------
> 
> This patch displays a KNotification whenever an unread notification exists on 
> Facebook. This KNotification groups at most 3 notifications into one popup 
> and then say "...and N more" if there is more. It also keeps track of which 
> notifications were already displayed and does not display them again unless 
> they were updated on the server. This is all stored in a separate config 
> file. 
> 
> Then it creates a KSNI for the notifications where it always show the newest 
> three notifications in the tooltip (regardless if it was displayed before or 
> not) and creates a menu with the notifications, which opens browser with the 
> notification link.
> 
> 
> Diffs
> -----
> 
>   resources/facebook/CMakeLists.txt e8c6381 
>   resources/facebook/facebookresource.h 4a16c0c 
>   resources/facebook/facebookresource.cpp 67e8f3b 
>   resources/facebook/facebookresource_notifications.cpp 7f6b8c4 
>   resources/facebook/serializer/akonadi_serializer_socialnotification.cpp 
> a261e14 
>   resources/facebook/settingsbase.kcfg 9f8e4b5 
>   resources/facebook/settingsdialog.cpp bfb7826 
>   resources/facebook/settingsdialog.ui 68b6a24 
> 
> Diff: http://git.reviewboard.kde.org/r/109825/diff/
> 
> 
> Testing
> -------
> 
> Yes.
> 
> 
> File Attachments
> ----------------
> 
> KSNI
>   
> http://git.reviewboard.kde.org/media/uploaded/files/2013/04/02/facebook_notifications.png
> 
> 
> Thanks,
> 
> Martin Klapetek
> 
>

_______________________________________________
Plasma-devel mailing list
Plasma-devel@kde.org
https://mail.kde.org/mailman/listinfo/plasma-devel

Reply via email to