ngraham added a comment.
  Making a second slider is fine, but it's not actually necessary. Instead, you 
could make `cfg_iconSize` and `cfg_listViewIconSize` not be aliases, and 
instead bind the single slider's value to whichever one is appropriate, like so:
  
    value: viewMode.currentIndex === 1 ? cfg_iconSize : cfg_listViewIconSize

INLINE COMMENTS

> main.xml:102
>      <entry name="iconSize" type="Int">
>        <label>The icon size to use for Folder View icons. One of the list of 
> Plasma icon sizes.</label>
>        <default>4</default>

This label needs updating now, to differentiate it from `listViewIconSize`

REPOSITORY
  R119 Plasma Desktop

REVISION DETAIL
  https://phabricator.kde.org/D28057

To: pereira.alex, #plasma, #vdg, ngraham
Cc: ngraham, plasma-devel, Orage, LeGast00n, The-Feren-OS-Dev, cblack, 
jraleigh, zachus, fbampaloukas, GB_2, ragreen, ZrenBot, himcesjf, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, ahiemstra, mart

Reply via email to