ngraham added a comment.
Thanks, looking better. I don't see explanatory text below the combobox yet; looks like that part isn't quite working. Also, suppose I want to contribute both usage and system information, how do I do that? The wording in the combobox implies that I can only contribute one or the other. If there are multiple pieces of information that it would make sense to send, then a combobox isn't the right control and we'll need to use radio buttons or checkboxes--or else we'll need to re-word the options so that they reveal the full set of what will be included. INLINE COMMENTS > feedback.cpp:41 > + setAboutData(new KAboutData(QStringLiteral("kcm_feedback"), > + i18n("Configure User Feedback > Settings"), > + QStringLiteral("1.0"), QString(), > KAboutLicense::LGPL)); Title should be the same as the name i.e. "User Feedback" > feedback.cpp:42 > + i18n("Configure User Feedback > Settings"), > + QStringLiteral("1.0"), QString(), > KAboutLicense::LGPL)); > + Description should be "Configure user feedback settings" > kcm_feedback.desktop:14 > +Name=User Feedback > + > +Categories=Qt;KDE; Add `Comment=Configure user feedback settings` > main.qml:23 > +import QtQuick.Layouts 1.1 > +import QtQuick.Controls 2.3 as QtControls > +import org.kde.kirigami 2.6 as Kirigami "as QQC2" > main.qml:41 > + wrapMode: Text.WordWrap > + text: i18n("We make Plasma for you. You can help us improve it > by contributing information on how you use it. This allows us to focus on > things that matter to you.\n\nContributing usage information is optional and > entirely anonymous. It will not associate the data with any kind of unique > identifier, and will never track the documents you open, the websites you > visit, or any other kind of personal information.\n\nYou can read more about > our policy in the following link.") > + } 1. Since this is no longer just about Plasma, maybe the first sentence should say, "We make software for you". 2. Use kuit formatting for newlines: `xi18nc("@info", "Line 1<nl/>Line 2<nl/>Line 3<nl/>etc.");` REPOSITORY R120 Plasma Workspace REVISION DETAIL https://phabricator.kde.org/D24011 To: apol, #plasma, vkrause, ngraham Cc: aspotashev, ngraham, bcooksley, davidedmundson, ognarb, broulik, plasma-devel, LeGast00n, The-Feren-OS-Dev, jraleigh, fbampaloukas, GB_2, ragreen, ZrenBot, alexeymin, himcesjf, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, mart