ngraham added a comment.
If this KCM is purely for Plasma, then we kind of have a problem, because we're putting the global switch in it, but it also has to show Plasma-specific stuff. If you change the text that says "We make Plasma for you" into "We make software for you", then the text can apply to all KDE software and we can move it out of the Plasma section and above everything else as first proposed. INLINE COMMENTS > feedback.cpp:41 > + setAboutData(new KAboutData(QStringLiteral("kcm_feedback"), > + i18n("Configure Telemetry Settings"), > + QStringLiteral("1.0"), QString(), > KAboutLicense::LGPL)); I would avoid using the word "Telemetry". It has negative connotations. Maybe "Feedback" instead. > main.qml:45 > + } > + QtControls.Label { > + text: i18n("This will only affect KDE software") This is aligned in a weird way. Let's come up with a better way to communicate this information. Maybe we could add it to the text block. > main.qml:57 > + > + QtControls.Frame { > + Layout.preferredWidth: parent.width * 0.75 Ew gross, frames REPOSITORY R120 Plasma Workspace REVISION DETAIL https://phabricator.kde.org/D24011 To: apol, #plasma, vkrause Cc: ngraham, bcooksley, davidedmundson, ognarb, broulik, plasma-devel, LeGast00n, The-Feren-OS-Dev, jraleigh, fbampaloukas, GB_2, ragreen, ZrenBot, himcesjf, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, mart