From: Alexander Duyck <alexander.du...@gmail.com>
Date: Wed, 23 Sep 2015 09:31:06 -0700

> It is the general direction of this I don't like since it is just
> making the code uglier before you attempt to fix it.

I agree, I don't like these refactorings at all.

Some of these code paths have been this way for a decade or longer,
and are etched into the back of our skulls.

Unless there is _true_ benefit, just leave the code alone, really.

I also really don't like "un-goto" conversions at all, they generally
make the code harder to read.  And as Eric Dumazet said, unless you
carefully pair such changes with appropriate likely()/unlikely()
taggin you pessimize the code.

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to