Stephen Hemminger <step...@networkplumber.org> writes: > On Fri, 27 Apr 2018 18:11:06 +0300 > Ido Schimmel <ido...@mellanox.com> wrote: > >> +int br_vlan_pvid_rtnl(const struct net_device *dev, u16 *p_pvid) >> +{ >> + struct net_bridge_vlan_group *vg; >> + >> + ASSERT_RTNL(); >> + if (netif_is_bridge_master(dev)) >> + vg = br_vlan_group(netdev_priv(dev)); >> + else >> + return -EINVAL; >> + >> + *p_pvid = br_get_pvid(vg); >> + return 0; >> +} >> +EXPORT_SYMBOL_GPL(br_vlan_pvid_rtnl); > > Unless there is a RCU version, no need for _rtnl suffix.
All right, I wanted to be explicit, but if you prefer to drop the _rtnl, no problem. > Minor style issue, why not make error then go on and return -1 on error. Basically to make it more straightforward to extend when people want to add support for the other device kind (bridge / port). > > > int br_vlan_pvid(const struct net_device *dev) > { > const struct net_bridge_vlan_group *vg; > > ASSERT_RTNL(); > > if (!netif_is_bridge_master(dev)) > return -1; > > vg = br_vlan_group(netdev_priv(dev)); > return br_get_pvid(vg); > }