From: Saeed Mahameed <sae...@mellanox.com>
Date: Tue, 19 Dec 2017 12:33:30 -0800

> +int esw_offloads_init_reps(struct mlx5_eswitch *esw)
> +{
> +     struct mlx5_core_dev *dev = esw->dev;
> +     struct mlx5_esw_offload *offloads;
> +     struct mlx5_eswitch_rep *rep;
> +     int total_vfs = MLX5_TOTAL_VPORTS(dev);
> +     u8 hw_id[ETH_ALEN];
> +     int vport;

Reverse christmas-tree please.

> +     esw->offloads.vport_reps =
> +             kcalloc(total_vfs, sizeof(struct mlx5_eswitch_rep),
> +                     GFP_KERNEL);

That looks really unpleasant:

        x = kcalloc(y,
                    z, GFP_KERNEL);

would look so much nicer.

Reply via email to