On 09/28/2017 10:34 AM, Jiri Pirko wrote: > From: Yotam Gigi <yot...@mellanox.com> > > Change the ipmr module to not forward packets if: > - The packet is marked with the offload_mr_fwd_mark, and > - Both input interface and output interface share the same parent ID. > > This way, a packet can go through partial multicast forwarding in the > hardware, where it will be forwarded only to the devices that share the > same parent ID (AKA, reside inside the same hardware). The kernel will > forward the packet to all other interfaces. > > To do this, add the ipmr_offload_forward helper, which per skb, ingress VIF > and egress VIF, returns whether the forwarding was offloaded to hardware. > The ipmr_queue_xmit frees the skb and does not forward it if the result is > a true value. > > All the forwarding path code compiles out when the CONFIG_NET_SWITCHDEV is > not set. > > Signed-off-by: Yotam Gigi <yot...@mellanox.com> > Reviewed-by: Ido Schimmel <ido...@mellanox.com> > Signed-off-by: Jiri Pirko <j...@mellanox.com> > --- > net/ipv4/ipmr.c | 37 ++++++++++++++++++++++++++++++++----- > 1 file changed, 32 insertions(+), 5 deletions(-) > > diff --git a/net/ipv4/ipmr.c b/net/ipv4/ipmr.c > index 4566c54..deba569 100644 > --- a/net/ipv4/ipmr.c > +++ b/net/ipv4/ipmr.c > @@ -1857,10 +1857,33 @@ static inline int ipmr_forward_finish(struct net > *net, struct sock *sk, > return dst_output(net, sk, skb); > } > > +#ifdef CONFIG_NET_SWITCHDEV > +static bool ipmr_forward_offloaded(struct sk_buff *skb, struct mr_table *mrt, > + int in_vifi, int out_vifi) > +{ > + struct vif_device *out_vif = &mrt->vif_table[out_vifi]; > + struct vif_device *in_vif = &mrt->vif_table[in_vifi];
Nit: in_vifi and out_vifi may be better named as in_vif_idx and out_vif_idx, oh well you are just replicating the existing naming conventions used down below, never mind then. -- Florian