JDevlieghere accepted this revision. JDevlieghere added a comment. This revision is now accepted and ready to land.
LGTM with Adrian's and my comments addressed. ================ Comment at: lldb/include/lldb/Symbol/Function.h:439 /// The section offset based address for this function. + /// \param[in] generic_trampoline + /// If this function is a generic trampoline. A generic trampoline ---------------- aprantl wrote: > Is the "generic" qualifier necessary here? If we later add support for > trampolines with a jump target maybe, but without that this seems to just > create opportunity for confusion, particularly for Swift where the word > "generic" has very different connotations. I wondered that too, but assumed we were still planning to support trampolines with a target. If not, then +1 on making this just "trampoline". ================ Comment at: lldb/source/Target/ThreadPlanStepRange.cpp:520-522 + if (log) + log->PutCString("ThreadPlanStepRange got asked if it explains the " + "stop for some reason other than step."); ---------------- ``` LLDB_LOG(GetLog(LLDBLog::Step), "ThreadPlanStepRange got asked if it explains the stop for some reason other than step."); ``` Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D147292/new/ https://reviews.llvm.org/D147292 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits