aprantl added inline comments.
================ Comment at: lldb/include/lldb/Symbol/Function.h:439 /// The section offset based address for this function. + /// \param[in] generic_trampoline + /// If this function is a generic trampoline. A generic trampoline ---------------- Is the "generic" qualifier necessary here? If we later add support for trampolines with a jump target maybe, but without that this seems to just create opportunity for confusion, particularly for Swift where the word "generic" has very different connotations. ================ Comment at: lldb/source/Target/ThreadPlanStepThroughGenericTrampoline.cpp:2 +//===-- ThreadPlanStepThroughGenericTrampoline.cpp +//-----------------------------------------===// +// ---------------- formatting Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D147292/new/ https://reviews.llvm.org/D147292 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits