jingham added a comment.

So the problem is that regex commands don't want to add the resolved command to 
the history, and so they need to force the creation of the repeat command even 
though they aren't adding to the history.  But `allow_repeat_command` is a 
misleading name for that.  It makes is sound like if I don't pass that flag I 
won't get a repeat command.  `force_repeat_command` would be a better name - 
you aren't allowing this you're requiring it...  And some explanation of why 
it's necessary would help make this patch understandable.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D143695/new/

https://reviews.llvm.org/D143695

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to