clayborg added a comment. Looks fine to me. I am assuming the full test suite passes with this change in place?
================ Comment at: lldb/source/Expression/IRExecutionUnit.cpp:717 + if (ConstString best_alternate_mangled_name = + FindBestAlternateMangledName(demangled, sc)) + CPP_names.push_back(best_alternate_mangled_name); ---------------- Seems like we should be passing in the "Mangled" object into "FindBestAlternateMangledName" in case it has extra information. For example constructors and destructors have many different types (in charge, not in charge, etc). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D109928/new/ https://reviews.llvm.org/D109928 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits