JDevlieghere marked an inline comment as done. JDevlieghere added inline comments.
================ Comment at: lldb/source/Interpreter/CommandInterpreter.cpp:2472 + flags |= eHandleCommandFlagPrintErrors; + } else if (m_command_source_flags.back() & eHandleCommandFlagPrintErrors) { + flags |= eHandleCommandFlagPrintErrors; ---------------- aprantl wrote: > Is `m_command_source_flags.empty() || > Flags(m_command_source_flags.back()).Test(eHandleCommandFlagPrintErrors)` > better? Not sure. Personally I think this is easier to read, and consistent with what we do elsewhere. Happy to be convinced otherwise though :-) Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D61579/new/ https://reviews.llvm.org/D61579 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits