JDevlieghere added inline comments.

================
Comment at: source/Core/Mangled.cpp:30
 
 #include "llvm/ADT/StringRef.h"    // for StringRef
+#include "llvm/Demangle/Demangle.h"
----------------
While you're here I'd remove these redundant comments so this block looks more 
consistent. 


================
Comment at: source/Core/Mangled.cpp:292
+          // Default buffer and size (realloc is used in case it's too small).
+          size_t default_size = 80;
+          demangled_name = static_cast<char *>(::malloc(default_size));
----------------
Nit: I'd call this `demangled_size` because finishDemangle will update the 
value.


https://reviews.llvm.org/D49612



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to