joerg added inline comments.
================ Comment at: source/Plugins/DynamicLoader/POSIX-DYLD/AuxVector.cpp:115 _type: \ name = #_type switch (type) { ---------------- labath wrote: > If we go about renaming them, then we should change this, as we still want to > display the standard name of the entries. Or name = "AUXV_AT_???" ENTRY_NAME(type) name = #type and then return name + 4; ================ Comment at: source/Plugins/DynamicLoader/POSIX-DYLD/AuxVector.h:46 + /// Added AUXV prefix because some targets already define names such as + /// AT_DCACHEBSIZE in system headers enum EntryType { ---------------- I think most targets do, but they don't pull the relevant system headers in via namespace pollution. https://reviews.llvm.org/D35065 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits