tberghammer added a comment. What is your opinion about replacing the ProcessGDBRemote::LoadModuleAtAddress with the following code:
lldb::ModuleSP ProcessGDBRemote::LoadModuleAtAddress (const FileSpec &file, lldb::addr_t base_addr, bool value_is_offset) { DynamicLoader* loader = GetDynamicLoader(); if (!loader) return nullptr; return loader->LoadModuleAtAddress(file, LLDB_INVALID_ADDRESS, base_addr, value_is_offset); } I think this should fix your problem while reducing the amount of code duplication we already has (I haven't tested it). http://reviews.llvm.org/D18531 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits