On Sun, 27 Apr 2014 11:26:14 -0400
Vakul Garg <va...@freescale.com> wrote:

> The variable 'keys_fit_inline' is initialised correctly to avoid using
> its stale value while creating shared descriptor for decryption and
> given-iv-encryption.

you mean givencrypt?  That's "generate an IV and encrypt".

> @@ -220,6 +220,8 @@ static int aead_null_set_sh_desc(struct crypto_aead *aead)
>       if (DESC_AEAD_NULL_ENC_LEN + DESC_JOB_IO_LEN +
>           ctx->split_key_pad_len <= CAAM_DESC_BYTES_MAX)
>               keys_fit_inline = true;
> +     else
> +             keys_fit_inline = false;

Can we do the easier to read:

        keys_fit_inline = false;
        if (DESC_AEAD_NULL_ENC_LEN + DESC_JOB_IO_LEN +
            ctx->split_key_pad_len <= CAAM_DESC_BYTES_MAX)
                keys_fit_inline = true;

?

Thanks.

Kim
--
To unsubscribe from this list: send the line "unsubscribe linux-crypto" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to