[ https://jira.codehaus.org/browse/MWAR-256?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=290986#comment-290986 ]
Rafal Krzewski commented on MWAR-256: ------------------------------------- It wouldn't bother me if the jar was only in WEB-INF/lib. In this case I wouldn't bother packaging it into a jar at all - WEB-INF/classes are also fine. It bothers me because it's all over my other module's dependencies. In my particular case I have a module that provides some java classes and some web resources (Velocity templates, js, css). The web resources need to be merged into the application WAR, and I'm using overlays for this. Hence WAR packaging on the project. The classes need to be packaged in the application WEB-INF/lib but are also needed to compile other modules' java sources - say, my module provides some base classes that are extended elsewhere. I could split the module into a jar and war parts, but the classes and web resources are tightly coupled it would be rather artificial. It would also add quite a few new modules to my project layout. Getting rid of a classifier in dependency spec in a dozen places does not warrant that. But I still would be able to change the classier - to be nothing :) > it's not possible to create classes attachment without classifier > ----------------------------------------------------------------- > > Key: MWAR-256 > URL: https://jira.codehaus.org/browse/MWAR-256 > Project: Maven 2.x WAR Plugin > Issue Type: Bug > Affects Versions: 2.1.1 > Reporter: Rafal Krzewski > > I would like to package classes in my war-packaged project into a jar, but I > don't want to use default 'classes' classifier assigned by the plugin. The > generated artifacts have distinct packaging types, so there is no conflict > and the classifier provides no useful additional information. Using the > following configuration: > {quote} > {{<configuration>}} > {{<classesClassifier/>}} > {{</configuration>}} > {quote} > Results in "classes" classifier being used anyway. If I understand the > behavior correctly Plexus assigns the variable it's default value, when > presented an empty input. I don't think this can be fixed in way that is both > clean and backward compatible. Either the default value will change, which > would break existing builds that don't specify plugin version explicitly, or > some clunky additional parameter like > {{<useClassesClassifier>false</useClassesClassifier>}}, or magic value like > {{<classesClassifier>NONE</classesClassifier>}} need to be introduced. -- This message is automatically generated by JIRA. If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa For more information on JIRA, see: http://www.atlassian.com/software/jira