On Wed, Mar 16, 2016 at 11:02:17PM +0000, Scott Aron Bloom wrote:
> I prefer “slotFoo” and “slotBar” as well as “sigFoo” and “sigBar”
> 
> It really lets the methods stand out as slots and signals.. It also means, 
> don’t
> think “sender()” can ever valid if you are not in a “slotXYZ” function.

sender() is pretty much never needed needed with lambda connects, as the sender
can be passed explicitly in the connect() call. This also removes the typical 
need
to qobject_cast<> the sender, as the correct type is available directly.

Andre'
_______________________________________________
Interest mailing list
Interest@qt-project.org
http://lists.qt-project.org/mailman/listinfo/interest

Reply via email to