On Tue, 15 Jan 2013 21:47:19 +0100
Michał Górny <mgo...@gentoo.org> wrote:

> On Tue, 15 Jan 2013 17:38:17 -0300
> Alexis Ballier <aball...@gentoo.org> wrote:
> 
> > On Tue, 15 Jan 2013 18:56:15 +0100
> > Michał Górny <mgo...@gentoo.org> wrote:
> > 
> > > On Tue, 15 Jan 2013 14:42:27 -0300
> > > Alexis Ballier <aball...@gentoo.org> wrote:
> > > 
> > > > On Tue, 15 Jan 2013 18:25:16 +0100
> > > > Michał Górny <mgo...@gentoo.org> wrote:
> > > > 
> > > > > On Tue, 15 Jan 2013 14:19:36 -0300
> > > > > Alexis Ballier <aball...@gentoo.org> wrote:
> > > > > 
> > > > > > On Tue, 15 Jan 2013 08:31:46 +0100
> > > > > > Michał Górny <mgo...@gentoo.org> wrote:
> > > > > > 
> > > > > > > Although the eclass does 'multilib?' only now, in the
> > > > > > > future it is likely to use more fine-tuned ABI flags.
> > > > > > > ---
> > > > > > >  gx86/eclass/autotools-multilib.eclass | 12 ++++++++++++
> > > > > > 
> > > > > > I think it'd better fit in a more generic eclass like
> > > > > > multilib.eclass
> > > > > 
> > > > > Yes, I was thinking about that. Probably would be easy to move
> > > > > the relevant functions into it.
> > > > > 
> > > > > The name remains the question -- multilib-utils? :D
> > > > 
> > > > I'd say multilib.eclass; it probably doesn't deserve a new
> > > > eclass, and multilib.eclass is already what could be called
> > > > multilib-utils.eclass :)
> > > 
> > > But that variable requires IUSE... and adding IUSE to
> > > multilib.eclass seems like a bad idea to me.
> > 
> > yes its a bad idea, but the variable doesnt require IUSE, only its
> > usage does.
> > 
> > I'd go for something like:
> > 
> > MULTILIB_IUSE=multilib
> > MULTILIB_USE_DEP=multilib?
> > 
> > and usage of MULTILIB_USE_DEP would imply MULTILIB_IUSE is in IUSE
> > so that later it can be populated by abi variables instead
> 
> I wanted to add the multilib_foreach_abi() there as well, and I think
> it really deserves its own eclass. And if it's own eclass where every
> func relies on IUSE, no point in hacking it over.

yep, it sounds sensible if you want to add more 'generic' functions
then, and indeed it's simpler to just set IUSE (not sure if it'd be
wanted in all cases but I can't imagine any)

> It's just the question of name, I believe. multilib-base?

-utils sounds better for utility functions, -base is better if it's
really the building blocks of most multilib packages; since the goal
should be the latter, I'd prefer -base, but then it makes me think
multilib.eclass is higher level than multilib-base, which is in fact the
contrary. Maybe multilib-builds ? multibuilds-base ?

Reply via email to