On 12/23/2014 11:30 AM, Paolo Carlini wrote:
if (maybe_range_for_decl) - *maybe_range_for_decl = error_mark_node; + { + *maybe_range_for_decl = error_mark_node; + if (*equal_loc == UNKNOWN_LOCATION) + tmp_equal_loc = token->location;
Even though the range-for case is the only place we care about the initializer location, I'd rather set *equal_loc whenever equal_loc is non-null. We can also use the local initializer location in place of initializer_start_token->location.
And let's call it init_loc rather than equal_loc. Jason