On Jul 21, 2013, at 8:37 AM, Marek Polacek <pola...@redhat.com> wrote:
> diff --git a/gcc/ada/gcc-interface/utils2.c b/gcc/ada/gcc-interface/utils2.c
> index 3f39a43..7f7f6af 100644
> --- a/gcc/ada/gcc-interface/utils2.c
> +++ b/gcc/ada/gcc-interface/utils2.c
> @@ -1902,7 +1902,7 @@ build_simple_component_ref (tree record_variable, tree 
> component,
>     {
>       tree new_field;
> 
> -      /* First loop thru normal components.  */
> +      /* First loop through normal components.  */
> 
> "thru" is not a typo.

Yes, it is.  Note, this _is_ a value judgement.  The source code is not a sign, 
and we do no accept the desire by some people to make thru standard, except for 
it's usage in space constrained places, like signs and headlines and inform 
writing.  Drive-thru is fine.

> -     then all auto increment forms are ok.  */
> +     then all auto increment forms are OK.  */
> 
> The patch would be much smaller if we'd keep "ok"s.

I don't care about size, but, I do prefer ok

> diff --git a/gcc/testsuite/c-c++-common/pr41779.c 
> b/gcc/testsuite/c-c++-common/pr41779.c
> index 80c8e6b..f80412c 100644
> --- a/gcc/testsuite/c-c++-common/pr41779.c
> +++ b/gcc/testsuite/c-c++-common/pr41779.c
> @@ -1,4 +1,4 @@
> -/* PR41779: Wconversion cannot see throught real*integer promotions. */
> +/* PR41779: Wconversion cannot see thought real*integer promotions. */
> 
> This change is not ok (eh, OK), it should've been "through".

Thanks.

Reply via email to