On Tue, Oct 30, 2012 at 2:17 AM, Bin.Cheng <amker.ch...@gmail.com> wrote: > On Tue, Oct 30, 2012 at 8:23 AM, Lawrence Crowl <cr...@googlers.com> wrote: >> On 10/29/12, Diego Novillo <dnovi...@google.com> wrote: >>> On Oct 29, 2012 Diego Novillo <dnovi...@google.com> wrote: >>> > Just to make sure. Testing on ppc should be fast, for example. >>> >>> And useless. Your patch does not touch ppc. >> >> I've fixed the #if 0 and the remaining suggestions will happen in >> another patch. I've committed this one. >> >> === >> >> This patch implements the unification of the *bitmap interfaces as discussed. >> Essentially, we rename ebitmap and sbitmap functions to use the same names >> as the bitmap functions. This rename works because we can now overload >> on the bitmap type. Some macros now become inline functions to enable >> that overloading. >> >> The sbitmap non-bool returning bitwise operations have been merged with >> the bool versions. Sometimes this merge involved modifying the non-bool >> version to compute the bool value, and sometimes modifying bool version to >> add additional work from the non-bool version. The redundant routines have >> been removed. >> >> The allocation functions have not been renamed, because we often do not >> have an argument on which to overload. The cardinality functions have not >> been renamed, because they have different parameters, and are thus not >> interchangable. The iteration functions have not been renamed, because >> they are functionally different. >> >> Tested on x86_64, contrib/config-list.mk testing passed. >> Index: gcc/ChangeLog >> > > Just one question: Should we change the name of functions > "sbitmap_intersection_of_succs/sbitmap_intersection_of_preds/sbitmap_union_of_succs/sbitmap_union_of_preds" > too? It might be a little confusing that sbitmap_* is used among > bitmap_*.
Yes. Lawrence is proceeding with this unification in stages. The next few patches should rename these. The only two sets of functions that will remain separate for now are the iterators and the bitmap creation routines, I think. Lawrence? Diego.