On Thu, Jul 16, 2026 at 08:58:29PM +0530, Kishan Parmar wrote: Onw additional that I noticed. Please incorporate this if possible.
> 2026-07-15 Kishan Parmar <[email protected]> > > gcc/testsuite/ChangeLog: > * gcc.target/powerpc/future-dmf-xxacc.c: New test. > * gcc.target/powerpc/future-nodmf-xxacc.c: New test. Please rename the tests to something like: * dmf-xxacc.c * nodmf-xxacc.c I.e. for dense math tests, just use either dmf or dmr in the filename, and likewise nodmf or nodmr. If we have 'future' in the test name, we will have to rename the tests if/when a future PowerPC product uses dense math registers to remove 'future'. Since we already have dmf/dmr in the name, that should be sufficient. To be clear, tests for -mcpu=future that don't involve Dense Math Registers, probably need to keep 'future' in the name. You don't have to resubmit a patch just to change the name. However, I think some of the other submissions use 'dmr' and some use 'dmf'. Please try to pick a consistant name strategy. Either 'dmr' (Dense Math Register) or 'dmf' (Dense Math Facility) is fine with me. I would just prefer the names to be consistant. -- Michael Meissner, IBM PO Box 98, Ayer, Massachusetts, USA, 01432 email: [email protected]
