Hi Mike, On Thu, Mar 22, 2018 at 08:11:52AM -0400, Michael Meissner wrote: > This patch renames the mode_supports_vsx_dform_quad function and changes all > of > the callers. I'm thinking about enhancing the addressing parts in the > secondary reload support, and I wanted a more logical naming scheme. There > will be mode_supports_d_form for offsettable addresses of any form, and > mode_supports_ds_form for addresses where the bottom 2 bits are 0 in the > future. > > I have built bootstrap compilers with the first 4 patches including this patch > on both big and little endian power8 systems. There were no regressions.
I like that new name. More succinct. > 2018-03-21 Michael Meissner <meiss...@linux.vnet.ibm.com> > > * config/rs6000/rs6000.c (mode_supports_dq_form): Rename > mode_supports_vsx_dform_quad to mode_supports_dq_form. > (mode_supports_vsx_dform_quad): Likeise. (typo, "likewise"). > (quad_address_p): Likewise. > (reg_offset_addressing_ok_p): Likewise. > (offsettable_ok_by_alignment): Likewise. > (rs6000_legitimate_offset_address_p): Likewise. > (legitimate_lo_sum_address_p): Likewise. > (rs6000_legitimize_address): Likewise. > (rs6000_legitimize_reload_address): Likewise. > (rs6000_secondary_reload_inner): Likewise. > (rs6000_preferred_reload_class): Likewise. > (rs6000_output_move_128bit): Likewise. Segher