On Wed, May 04, 2016 at 11:14:41AM +0930, Alan Modra wrote: > * config/rs6000/rs6000.c (rs6000_frame_related): Rewrite.
> - rtx real, temp; > + rtx patt, repl; If you don't rename "real" here it is probably easier to read? And it's a better name anyway? > - if (REGNO (reg) == STACK_POINTER_REGNUM && reg2 == NULL_RTX) > + repl = NULL_RTX; > + if (REGNO (reg) == STACK_POINTER_REGNUM) > + gcc_checking_assert (val == 0); > + else > + repl = gen_rtx_PLUS (Pmode, gen_rtx_REG (Pmode, STACK_POINTER_REGNUM), > + GEN_INT (val)); Put the NULL_RTX assignment in the first arm, please. Okay for trunk with those changes, thanks, Segher