Hi Joseph,
2011-04-26 Joseph Myers<jos...@codesourcery.com>
* config/fr30/fr30-protos.h (Mmode): Don't define.
* config/fr30/fr30.h (inhibit_libc): Don't define.
* config/m32r/m32r-protos.h (Mmode): Don't define. Expand
definition where used.
* config/mn10300/mn10300-protos.h (Mmode, Cstar, Rclas): Don't
define. Expand definitions where used.
* config/rx/rx-protos.h (Mmode, Fargs, Rcode): Don't define.
Expand definitions where used.
* config/rx/rx.c (rx_is_legitimate_address, rx_function_arg_size,
rx_function_arg, rx_function_arg_advance,
rx_function_arg_boundary): Expand definitions of those macros.
* config/v850/v850-protos.h (Mmode): Don't define. Expand
definition where used.
* config/v850/v850.h (GHS_default_section_names,
GHS_current_section_names): Use tree, not union tree_node *.
I am not keen on the removal of the Mmode macro. I think that having it
makes the prototypes cleaner and easier to read. I accept that it is
silly for individual targets to define the macro on their own. But in
my opinion the "enum machine_mode" type deserves its own abbreviating
definition like rtx or tree.
Similarly it would be nice to standard abbreviations for
CUMULATIVE_ARGS, enum rtx_code, enum reg_class and const char *. What
do you think ? I suspect that I am alone in this desire, in which case
I will bow to public opinion and approve the whole patch. But in the
meantime I am happy with the other parts:
Index: gcc/config/m32r/m32r-protos.h
===================================================================
-/* Function prototypes that cannot exist in v850.h due to dependency
+/* Function prototypes that cannot exist in m32r.h due to dependency
Approved.
Index: gcc/config/fr30/fr30.h
===================================================================
-/* If cross-compiling, don't require stdio.h etc to build libgcc.a. */
-#if defined CROSS_DIRECTORY_STRUCTURE&& ! defined inhibit_libc
-#define inhibit_libc
-#endif
-
Approved.
Index: gcc/config/v850/v850.h
===================================================================
-extern union tree_node * GHS_default_section_names [(int)
COUNT_OF_GHS_SECTION_KINDS];
-extern union tree_node * GHS_current_section_names [(int)
COUNT_OF_GHS_SECTION_KINDS];
+extern tree GHS_default_section_names [(int) COUNT_OF_GHS_SECTION_KINDS];
+extern tree GHS_current_section_names [(int) COUNT_OF_GHS_SECTION_KINDS];
Approved.
Cheers
Nick