> Most of people sems happy with the new framework options however it could be > yet > better, here is an attempt to improve it: > http://people.freebsd.org/~bapt/options%2bradio%2bgroup.diff
> Among the complains people tends to find that OPTIONS_SINGLE aka 1 among N is > nice but the 0 or 1 among N is not user friendly. So here is OPTIONS_RADIO > which > is natively 0 or 1 among N without the need of adding its name to > OPTIONS_DEFINE. > if everyone is happy with OPTIONS_RADIO, then the 0 or 1 feature from > OPTIONS_SINGLE will be removed later once the ports needed that has been > converted to OPTIONS_RADIO > Another feature request I received was the ability to group options into a > named > group, to avoid some sort of sorting of option name (nginx is a good example > in > my mind that could benefit it. So OPTIONS_GROUP has been created > OPTIONS_GROUP works exactly the same as OPTIONS_MULTI except that is accept 0 > or > N among M > if you have better name to propose feel free :) > Please test, send you remark etc. > regards, > Bapt Would this extended options framework be accessed by configuration dialog, or would it be by editing make.conf or other file? There needs to be a way to better make clear when exactly one, or at most one of a group of options can be selected. NetBSD pkgsrc makes this clear with the Makefile or options.mk . I have had instances when, after configuring with the dialog, a port couldn't build because I had selected two options not compatible with each other, and no warning before the port build failed. In most cases, I was able to build the port after reading the error message and reconfiguring the options to avoid the incompatible mix. Tom _______________________________________________ [email protected] mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-ports To unsubscribe, send any mail to "[email protected]"
