Hi all, Most of people sems happy with the new framework options however it could be yet better, here is an attempt to improve it: http://people.freebsd.org/~bapt/options%2bradio%2bgroup.diff
Among the complains people tends to find that OPTIONS_SINGLE aka 1 among N is nice but the 0 or 1 among N is not user friendly. So here is OPTIONS_RADIO which is natively 0 or 1 among N without the need of adding its name to OPTIONS_DEFINE. if everyone is happy with OPTIONS_RADIO, then the 0 or 1 feature from OPTIONS_SINGLE will be removed later once the ports needed that has been converted to OPTIONS_RADIO Another feature request I received was the ability to group options into a named group, to avoid some sort of sorting of option name (nginx is a good example in my mind that could benefit it. So OPTIONS_GROUP has been created OPTIONS_GROUP works exactly the same as OPTIONS_MULTI except that is accept 0 or N among M if you have better name to propose feel free :) Please test, send you remark etc. regards, Bapt
pgpZwvCfSitzf.pgp
Description: PGP signature
