Yair Zaslavsky has posted comments on this change.

Change subject: oVirt Node Upgrade: Support N configuration
......................................................................


Patch Set 9: (4 inline comments)

....................................................
File 
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetoVirtISOsQuery.java
Line 59:                         
isoData.setVdsmCompitibilityVersion(readVdsmCompatibiltyVersion((
Line 60:                                 
versionFile.getAbsolutePath().replace(OVIRT_ISO_VERSION_PREFIX,
Line 61:                                         
OVIRT_ISO_VDSM_COMPATIBILITY_PREFIX))));
Line 62: 
Line 63:                         if (StringUtils.isBlank(isoVersionText)) {
Hi, can this be null as well? Maybe change to StringUtils.isEmpty if so?
Line 64:                             log.infoFormat("Iso version file {0} is 
empty.", versionFile.getAbsolutePath());
Line 65:                             continue;
Line 66:                         }
Line 67: 


....................................................
File 
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/InstallVdsCommand.java
Line 53:                 retValue = false;
Line 54:             }
Line 55: 
Line 56:             RpmVersion ovirtHostOsVersion = 
VdsHandler.getOvirtHostOsVersion(getVds());
Line 57:             retValue = isIsoFileValid(isoFile, info, 
ovirtHostOsVersion);
Martin Perina introduced a VdsValidator class.
Please use it to provide validation methods that will be used  in canDoAction 
of host related commands.
You can also see StoragePoolValidator and MultiStorageDomainValidator classes 
for reference - so isIsoFile valid should be moved to that class IMHO.
Line 58:         }
Line 59:         return retValue;
Line 60:     }
Line 61: 


....................................................
File 
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/OVirtNodeInfo.java
Line 22:         this.path = path;
Line 23:         this.minimumVersion = minimumVersion;
Line 24:     }
Line 25: 
Line 26:     public static OVirtNodeInfo[] get() {
I would prefer to split the fetch logic of OvirtNodeInfo to a different class, 
and not have it in OvirtNodeInfo.
Line 27:         final String delimiter = ":";
Line 28:         final String[] path = 
Config.resolveOVirtISOsRepositoryPath().split(delimiter);
Line 29:         final String minimumVersion[] = Config.<String> 
GetValue(ConfigValues.OvirtInitialSupportedIsoVersion).split(delimiter);
Line 30: 


Line 47:             log.debugFormat("NodeInfo: regex {0} path {1}, 
minimumVersion {2}",
Line 48:                     regex[i], path[i], minimumVersion[i]);
Line 49:             info.add(new OVirtNodeInfo(Pattern.compile(regex[i]), new 
File(path[i]), minimumVersion[i]));
Line 50:         }
Line 51:         return info.toArray(new OVirtNodeInfo[info.size()]);
Any reason why this has to be translated to array?
Line 52:     }


-- 
To view, visit http://gerrit.ovirt.org/14756
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ibfb9dc5d0dc8780b519107acbe0ae866831f782c
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Douglas Schilling Landgraf <dougsl...@redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alo...@redhat.com>
Gerrit-Reviewer: Barak Azulay <bazu...@redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <dan...@redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsl...@redhat.com>
Gerrit-Reviewer: Michael Burns <mbu...@redhat.com>
Gerrit-Reviewer: Ravi Nori <rn...@redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to